Annotations not working

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Annotations not working

Brian Forsythe
I'm running XWiki Enterprise 3.3. Annotations simply do not work (via
Ctrl-M). I've tried resaving the Annotations pages (as per
http://extensions.xwiki.org/xwiki/bin/view/Extension/Annotations+Application)
using an id with programming rights. I've also installed the Admin
Tool and used it to check programming rights
(Admin.CheckProgrammingRights). Viewing page sources, it appears that
annotation styles, code, etc are being included in pages. I've also
turned the feature on in preferences.

Am I missing something I need to install? Is there logging, etc,
somewhere that I can examine? Would it be helpful to (re)install the
Annotations Application
(http://extensions.xwiki.org/xwiki/bin/view/Extension/Annotations+Application)?
Or, since Annotations is bundled with Enterprise, is this targeted at
an older xwiki version, so it would be harmful to do so?
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Annotations not working

Roman Muntyanu
+1, Ctrl-M does nothing.
XWiki 3.4

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Brian Forsythe
Sent: Sunday, March 04, 2012 22:04 PM
To: [hidden email]
Subject: [xwiki-users] Annotations not working

I'm running XWiki Enterprise 3.3. Annotations simply do not work (via Ctrl-M). I've tried resaving the Annotations pages (as per
http://extensions.xwiki.org/xwiki/bin/view/Extension/Annotations+Application)
using an id with programming rights. I've also installed the Admin Tool and used it to check programming rights (Admin.CheckProgrammingRights). Viewing page sources, it appears that annotation styles, code, etc are being included in pages. I've also turned the feature on in preferences.

Am I missing something I need to install? Is there logging, etc, somewhere that I can examine? Would it be helpful to (re)install the Annotations Application (http://extensions.xwiki.org/xwiki/bin/view/Extension/Annotations+Application)?
Or, since Annotations is bundled with Enterprise, is this targeted at an older xwiki version, so it would be harmful to do so?
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Annotations not working

Brian Forsythe
And the plot thickens... Annotations DO work for users on my wiki
without administrative / programming rights, but with my id (admin /
programming rights), annotations don't work.

On Mon, Mar 5, 2012 at 6:16 PM, Roman Muntyanu
<[hidden email]> wrote:

> +1, Ctrl-M does nothing.
> XWiki 3.4
>
> -----Original Message-----
> From: [hidden email] [mailto:[hidden email]] On Behalf Of Brian Forsythe
> Sent: Sunday, March 04, 2012 22:04 PM
> To: [hidden email]
> Subject: [xwiki-users] Annotations not working
>
> I'm running XWiki Enterprise 3.3. Annotations simply do not work (via Ctrl-M). I've tried resaving the Annotations pages (as per
> http://extensions.xwiki.org/xwiki/bin/view/Extension/Annotations+Application)
> using an id with programming rights. I've also installed the Admin Tool and used it to check programming rights (Admin.CheckProgrammingRights). Viewing page sources, it appears that annotation styles, code, etc are being included in pages. I've also turned the feature on in preferences.
>
> Am I missing something I need to install? Is there logging, etc, somewhere that I can examine? Would it be helpful to (re)install the Annotations Application (http://extensions.xwiki.org/xwiki/bin/view/Extension/Annotations+Application)?
> Or, since Annotations is bundled with Enterprise, is this targeted at an older xwiki version, so it would be harmful to do so?
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users