[Build error] Maven build fail

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

[Build error] Maven build fail

deshengchuan
Hi all. I am using Windows OS and performing an mvn clean install on the xwiki-platform project which I have cloned into my directory. It is currently showing me the following error message:

 [INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 01:47 min
[INFO] Finished at: 2017-05-10T18:20:17+08:00
[INFO] Final Memory: 241M/775M
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.revapi:revapi-maven-plugin:0.9.0:check (revapi-check) on project xwiki-platform-refactoring-api

I have attached the full error log as a reference. Thank you in advance for the help.error_log.txt
Reply | Threaded
Open this post in threaded view
|

Re: [Build error] Maven build fail

vmassol
Administrator
Hi,

> On 10 May 2017, at 12:31, deshengchuan <[hidden email]> wrote:
>
> Hi all. I am using Windows OS and performing an /mvn clean install/ on the
> xwiki-platform project which I have cloned into my directory. It is
> currently showing me the following error message:
>
> [INFO] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: 01:47 min
> [INFO] Finished at: 2017-05-10T18:20:17+08:00
> [INFO] Final Memory: 241M/775M
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] Failed to execute goal org.revapi:revapi-maven-plugin:0.9.0:check
> (revapi-check) on project xwiki-platform-refactoring-api
>
> I have attached the full error log as a reference. Thank you in advance for
> the help. error_log.txt
> <http://xwiki.475771.n2.nabble.com/file/n7603818/error_log.txt>  

Are you on master? Are you up to date (git pull —rebase)?

That’s weird since it’s passing for me locally and I don’t see the relationship with windows. It’s also passing on ci.xwiki.org.

Thanks
-Vincent

>
>
>
> --
> View this message in context: http://xwiki.475771.n2.nabble.com/Build-error-Maven-build-fail-tp7603818.html
> Sent from the XWiki- Dev mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|

Re: [Build error] Maven build fail

vmassol
Administrator
BTW you don’t need to build the full xwiki-platform. You can only build the module you’re working on.

See http://dev.xwiki.org/xwiki/bin/view/Community/Building#HBuildingwithMaven

Thanks
-Vincent

> On 10 May 2017, at 13:08, Vincent Massol <[hidden email]> wrote:
>
> Hi,
>
>> On 10 May 2017, at 12:31, deshengchuan <[hidden email]> wrote:
>>
>> Hi all. I am using Windows OS and performing an /mvn clean install/ on the
>> xwiki-platform project which I have cloned into my directory. It is
>> currently showing me the following error message:
>>
>> [INFO] BUILD FAILURE
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Total time: 01:47 min
>> [INFO] Finished at: 2017-05-10T18:20:17+08:00
>> [INFO] Final Memory: 241M/775M
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] Failed to execute goal org.revapi:revapi-maven-plugin:0.9.0:check
>> (revapi-check) on project xwiki-platform-refactoring-api
>>
>> I have attached the full error log as a reference. Thank you in advance for
>> the help. error_log.txt
>> <http://xwiki.475771.n2.nabble.com/file/n7603818/error_log.txt>  
>
> Are you on master? Are you up to date (git pull —rebase)?
>
> That’s weird since it’s passing for me locally and I don’t see the relationship with windows. It’s also passing on ci.xwiki.org.
>
> Thanks
> -Vincent
>
>>
>>
>>
>> --
>> View this message in context: http://xwiki.475771.n2.nabble.com/Build-error-Maven-build-fail-tp7603818.html
>> Sent from the XWiki- Dev mailing list archive at Nabble.com.

Reply | Threaded
Open this post in threaded view
|

Re: [Build error] Maven build fail

deshengchuan
Thanks for the help Vincent.
I have made sure that my git repo is up to date with the master branch.
I am still unable to install the whole platform.
As per your advice i have built only the required project, and the build is successful at least.