Cannot deal with Chinese tags on XWiki-7.3

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot deal with Chinese tags on XWiki-7.3

kirbyzhou
I create a new tag named "运营”
But, it displays just like rubbish, And I can not remove it nor rename it.

I think the problem is in "tag=è¿%C2%90è%C2%90¥" encodings.
If I manually input the URL with "tag=运营", the actions goes well, but display still be bad.

…/xwiki/bin/view/Main/Tags?do=viewTag&tag=è¿%C2%90è%C2%90¥

…/xwiki/bin/view/Main/Tags?do=viewTag&tag=运营

The expected display should be like below:

My browser is Safara 9.0.1 under Mac.








_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot deal with Chinese tags on XWiki-7.3

Thomas Mortagne
Administrator
From what I understand you get a badly generated URL somewhere but
it's not clear to me where exactly you get this. The link generated in
the bottom of the page is ok for me as you can see on
http://tuska.myxwiki.org/xwiki/bin/view/Main/TestChineseTag/.

It usually mean you have something wrong in your setup. You should
probably take a look at
http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Encoding.

On Fri, Dec 4, 2015 at 4:43 AM, KirbY ZhoU <[hidden email]> wrote:

> I create a new tag named "运营”
> But, it displays just like rubbish, And I can not remove it nor rename it.
>
> I think the problem is in "tag=è¿%C2%90è%C2%90¥" encodings.
> If I manually input the URL with "tag=运营", the actions goes well, but display still be bad.
>
> …/xwiki/bin/view/Main/Tags?do=viewTag&tag=è¿%C2%90è%C2%90¥
>
> …/xwiki/bin/view/Main/Tags?do=viewTag&tag=运营
>
> The expected display should be like below:
>
> My browser is Safara 9.0.1 under Mac.
>
>
>
>
>
>
>
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users



--
Thomas Mortagne
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot deal with Chinese tags on XWiki-7.3

Paul Libbrecht-2
One relevant element may be the use of a proxy in the front of your
wiki, are you using that?
Also, did you set-up anything like the default charset of URLs in the
servlet container?

paul

> Thomas Mortagne <mailto:[hidden email]>
> 4 décembre 2015 09:24
> From what I understand you get a badly generated URL somewhere but
> it's not clear to me where exactly you get this. The link generated in
> the bottom of the page is ok for me as you can see on
> http://tuska.myxwiki.org/xwiki/bin/view/Main/TestChineseTag/.
>
> It usually mean you have something wrong in your setup. You should
> probably take a look at
> http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Encoding.
>
>
>

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot deal with Chinese tags on XWiki-7.3

kirbyzhou

Thanks very much, I checked my configuration.
Set URIEncoding="UTF-8" in /etc/tomcat/server.xml
Everything goes well now.



在 15/12/4 下午4:31,“users 代表 Paul Libbrecht”<[hidden email] 代表 [hidden email]> 写入:

>One relevant element may be the use of a proxy in the front of your
>wiki, are you using that?
>Also, did you set-up anything like the default charset of URLs in the
>servlet container?
>
>paul
>
>> Thomas Mortagne <mailto:[hidden email]>
>> 4 décembre 2015 09:24
>> From what I understand you get a badly generated URL somewhere but
>> it's not clear to me where exactly you get this. The link generated in
>> the bottom of the page is ok for me as you can see on
>> http://tuska.myxwiki.org/xwiki/bin/view/Main/TestChineseTag/.
>>
>> It usually mean you have something wrong in your setup. You should
>> probably take a look at
>> http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Encoding.
>>
>>
>>
>
>_______________________________________________
>users mailing list
>[hidden email]
>http://lists.xwiki.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users