Cannot import default xar

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Cannot import default xar

hel-o
Hi,

just updated to 1.9.1 (from 1.8.4) and tried to import the default xar. I can upload the file but when i click on it to import nothing happens.

In the console i get the following error when i upload the file

"updateAttachName is not defined
function onclick(event) { return updateAttachName(this.form, "Do you want to replace the filename with"); }(click clientX=108, clientY=439)"

Thanks
hel.
semantic-web.hel.at
hel@hel.at
Reply | Threaded
Open this post in threaded view
|

Re: Cannot import default xar

Sergiu Dumitriu-2
hel-o wrote:

> Hi,
>
> just updated to 1.9.1 (from 1.8.4) and tried to import the default xar. I
> can upload the file but when i click on it to import nothing happens.
>
> In the console i get the following error when i upload the file
>
> "updateAttachName is not defined
> function onclick(event) { return updateAttachName(this.form, "Do you want to
> replace the filename with"); }(click clientX=108, clientY=439)"

Yes, this JS error is not important, and I think it's been fixed in the
SVN. Are there any errors logged on the server?

--
Sergiu Dumitriu
http://purl.org/net/sergiu/
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot import default xar

hel-o
Hi,

theres nothing in the xwiki or tomcat log. But when i enable "hold on every error" for scripts in Firebug i get the following when i click on the uploaded xar.

"                  74 function getXmlValue(tag, xml)
                   75 {
>xml is null  76 var nodes = xml.getElementsByTagName(tag);
                   77 if (nodes.length > 0 && nodes[0].firstChild)
                   78 return nodes[0].firstChild.data; "

The script is import.js. I use Firefox 3.5.

Thanks
hel.


Sergiu Dumitriu-2 wrote
hel-o wrote:
> Hi,
>
> just updated to 1.9.1 (from 1.8.4) and tried to import the default xar. I
> can upload the file but when i click on it to import nothing happens.
>
> In the console i get the following error when i upload the file
>
> "updateAttachName is not defined
> function onclick(event) { return updateAttachName(this.form, "Do you want to
> replace the filename with"); }(click clientX=108, clientY=439)"

Yes, this JS error is not important, and I think it's been fixed in the
SVN. Are there any errors logged on the server?

--
Sergiu Dumitriu
http://purl.org/net/sergiu/
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
semantic-web.hel.at
hel@hel.at
Reply | Threaded
Open this post in threaded view
|

Re: Cannot import default xar

PERINAUD Christophe
In reply to this post by hel-o
Hi,

Is the XAR file correct ? I mean not corrupted with the package.xml file in the root folder ? It looks like as if the load of the XML file has not been made.

-----Message d'origine-----
De : [hidden email] [mailto:[hidden email]] De la part de hel-o
Envoyé : lundi 20 juillet 2009 11:05
À : [hidden email]
Objet : Re: [xwiki-users] Cannot import default xar


Hi,

theres nothing in the xwiki or tomcat log. But when i enable "hold on every
error" for scripts in Firebug i get the following when i click on the
uploaded xar.

"                  74 function getXmlValue(tag, xml)
                   75 {
>xml is null  76 var nodes = xml.getElementsByTagName(tag);
                   77 if (nodes.length > 0 && nodes[0].firstChild)
                   78 return nodes[0].firstChild.data; "

The script is import.js. I use Firefox 3.5.

Thanks
hel.



Sergiu Dumitriu-2 wrote:

>
> hel-o wrote:
>> Hi,
>>
>> just updated to 1.9.1 (from 1.8.4) and tried to import the default xar. I
>> can upload the file but when i click on it to import nothing happens.
>>
>> In the console i get the following error when i upload the file
>>
>> "updateAttachName is not defined
>> function onclick(event) { return updateAttachName(this.form, "Do you want
>> to
>> replace the filename with"); }(click clientX=108, clientY=439)"
>
> Yes, this JS error is not important, and I think it's been fixed in the
> SVN. Are there any errors logged on the server?
>
> --
> Sergiu Dumitriu
> http://purl.org/net/sergiu/
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
>


-----
semantic-web.hel.at
[hidden email]

--
View this message in context: http://n2.nabble.com/Cannot-import-default-xar-tp3283800p3287792.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
--------------------------------------------------------------------------------

This e-mail is intended only for the addressee named above. It does not bind the sender, except in the case of an existing written convention with the addressee. This e-mail may contain material that is confidential and privileged for the sole use of the intended recipient. Any review, reliance or distribution by others or forwarding without express permission is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender and delete all copies.

While reasonable precautions have been taken to ensure that this e-mail and any attachments are free from any computer virus or similar defect, no liability will be accepted in that respect. Anyone accessing this e-mail must take their own precautions as to security and virus protection.

KBL European Private Bankers S.A., 43 boulevard Royal L-2955 Luxembourg, R.C.S. Luxembourg B 6395, T (352) 47 97 1
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot import default xar

hel-o
Hi,

It's the "xwiki-enterprise-wiki-1.9.1.xar" i downloaded from xwiki.org. So i hope the xar file is correct;) Also tried to export a page and import the xar -> same behavior

hel.


PERINAUD Christophe wrote
Hi,

Is the XAR file correct ? I mean not corrupted with the package.xml file in the root folder ? It looks like as if the load of the XML file has not been made.

-----Message d'origine-----
De : users-bounces@xwiki.org [mailto:users-bounces@xwiki.org] De la part de hel-o
Envoyé : lundi 20 juillet 2009 11:05
À : users@xwiki.org
Objet : Re: [xwiki-users] Cannot import default xar


Hi,

theres nothing in the xwiki or tomcat log. But when i enable "hold on every
error" for scripts in Firebug i get the following when i click on the
uploaded xar.

"                  74 function getXmlValue(tag, xml)
                   75 {
>xml is null  76 var nodes = xml.getElementsByTagName(tag);
                   77 if (nodes.length > 0 && nodes[0].firstChild)
                   78 return nodes[0].firstChild.data; "

The script is import.js. I use Firefox 3.5.

Thanks
hel.



Sergiu Dumitriu-2 wrote:
>
> hel-o wrote:
>> Hi,
>>
>> just updated to 1.9.1 (from 1.8.4) and tried to import the default xar. I
>> can upload the file but when i click on it to import nothing happens.
>>
>> In the console i get the following error when i upload the file
>>
>> "updateAttachName is not defined
>> function onclick(event) { return updateAttachName(this.form, "Do you want
>> to
>> replace the filename with"); }(click clientX=108, clientY=439)"
>
> Yes, this JS error is not important, and I think it's been fixed in the
> SVN. Are there any errors logged on the server?
>
> --
> Sergiu Dumitriu
> http://purl.org/net/sergiu/
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>
>


-----
semantic-web.hel.at
hel@hel.at

--
View this message in context: http://n2.nabble.com/Cannot-import-default-xar-tp3283800p3287792.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
--------------------------------------------------------------------------------

This e-mail is intended only for the addressee named above. It does not bind the sender, except in the case of an existing written convention with the addressee. This e-mail may contain material that is confidential and privileged for the sole use of the intended recipient. Any review, reliance or distribution by others or forwarding without express permission is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender and delete all copies.

While reasonable precautions have been taken to ensure that this e-mail and any attachments are free from any computer virus or similar defect, no liability will be accepted in that respect. Anyone accessing this e-mail must take their own precautions as to security and virus protection.

KBL European Private Bankers S.A., 43 boulevard Royal L-2955 Luxembourg, R.C.S. Luxembourg B 6395, T (352) 47 97 1
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
semantic-web.hel.at
hel@hel.at
Reply | Threaded
Open this post in threaded view
|

Re: Cannot import default xar

hel-o
Hi,

sorry to bother, but still no import.

Any suggestions.

Thanks
hel.

hel-o wrote
Hi,

It's the "xwiki-enterprise-wiki-1.9.1.xar" i downloaded from xwiki.org. So i hope the xar file is correct;) Also tried to export a page and import the xar -> same behavior

hel.


PERINAUD Christophe wrote
Hi,

Is the XAR file correct ? I mean not corrupted with the package.xml file in the root folder ? It looks like as if the load of the XML file has not been made.

-----Message d'origine-----
De : users-bounces@xwiki.org [mailto:users-bounces@xwiki.org] De la part de hel-o
Envoyé : lundi 20 juillet 2009 11:05
À : users@xwiki.org
Objet : Re: [xwiki-users] Cannot import default xar


Hi,

theres nothing in the xwiki or tomcat log. But when i enable "hold on every
error" for scripts in Firebug i get the following when i click on the
uploaded xar.

"                  74 function getXmlValue(tag, xml)
                   75 {
>xml is null  76 var nodes = xml.getElementsByTagName(tag);
                   77 if (nodes.length > 0 && nodes[0].firstChild)
                   78 return nodes[0].firstChild.data; "

The script is import.js. I use Firefox 3.5.

Thanks
hel.



Sergiu Dumitriu-2 wrote:
>
> hel-o wrote:
>> Hi,
>>
>> just updated to 1.9.1 (from 1.8.4) and tried to import the default xar. I
>> can upload the file but when i click on it to import nothing happens.
>>
>> In the console i get the following error when i upload the file
>>
>> "updateAttachName is not defined
>> function onclick(event) { return updateAttachName(this.form, "Do you want
>> to
>> replace the filename with"); }(click clientX=108, clientY=439)"
>
> Yes, this JS error is not important, and I think it's been fixed in the
> SVN. Are there any errors logged on the server?
>
> --
> Sergiu Dumitriu
> http://purl.org/net/sergiu/
> _______________________________________________
> users mailing list
> users@xwiki.org
> http://lists.xwiki.org/mailman/listinfo/users
>
>


-----
semantic-web.hel.at
hel@hel.at

--
View this message in context: http://n2.nabble.com/Cannot-import-default-xar-tp3283800p3287792.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
--------------------------------------------------------------------------------

This e-mail is intended only for the addressee named above. It does not bind the sender, except in the case of an existing written convention with the addressee. This e-mail may contain material that is confidential and privileged for the sole use of the intended recipient. Any review, reliance or distribution by others or forwarding without express permission is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender and delete all copies.

While reasonable precautions have been taken to ensure that this e-mail and any attachments are free from any computer virus or similar defect, no liability will be accepted in that respect. Anyone accessing this e-mail must take their own precautions as to security and virus protection.

KBL European Private Bankers S.A., 43 boulevard Royal L-2955 Luxembourg, R.C.S. Luxembourg B 6395, T (352) 47 97 1
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
semantic-web.hel.at
hel@hel.at
Reply | Threaded
Open this post in threaded view
|

Re: Cannot import default xar

Sergiu Dumitriu-2
hel-o wrote:
> Hi,
>
> sorry to bother, but still no import.
>
> Any suggestions.

I just tried to import the xar in a fresh 1.9.1, and it worked with no
problems.

Idea: try to clean the browser cache first. Som JS functions have been
moved around.

>
>
> hel-o wrote:
>> Hi,
>>
>> It's the "xwiki-enterprise-wiki-1.9.1.xar" i downloaded from xwiki.org. So
>> i hope the xar file is correct;) Also tried to export a page and import
>> the xar -> same behavior
>>
>> hel.
>>
>>
>>
>> PERINAUD Christophe wrote:
>>> Hi,
>>>
>>> Is the XAR file correct ? I mean not corrupted with the package.xml file
>>> in the root folder ? It looks like as if the load of the XML file has not
>>> been made.
>>>
>>> -----Message d'origine-----
>>> De : [hidden email] [mailto:[hidden email]] De la part
>>> de hel-o
>>> Envoyé : lundi 20 juillet 2009 11:05
>>> À : [hidden email]
>>> Objet : Re: [xwiki-users] Cannot import default xar
>>>
>>>
>>> Hi,
>>>
>>> theres nothing in the xwiki or tomcat log. But when i enable "hold on
>>> every
>>> error" for scripts in Firebug i get the following when i click on the
>>> uploaded xar.
>>>
>>> "                  74 function getXmlValue(tag, xml)
>>>                    75 {
>>>> xml is null  76 var nodes = xml.getElementsByTagName(tag);
>>>                    77 if (nodes.length > 0 && nodes[0].firstChild)
>>>                    78 return nodes[0].firstChild.data; "
>>>
>>> The script is import.js. I use Firefox 3.5.
>>>
>>> Thanks
>>> hel.
>>>
>>>
>>>
>>> Sergiu Dumitriu-2 wrote:
>>>> hel-o wrote:
>>>>> Hi,
>>>>>
>>>>> just updated to 1.9.1 (from 1.8.4) and tried to import the default xar.
>>>>> I
>>>>> can upload the file but when i click on it to import nothing happens.
>>>>>
>>>>> In the console i get the following error when i upload the file
>>>>>
>>>>> "updateAttachName is not defined
>>>>> function onclick(event) { return updateAttachName(this.form, "Do you
>>>>> want
>>>>> to
>>>>> replace the filename with"); }(click clientX=108, clientY=439)"
>>>> Yes, this JS error is not important, and I think it's been fixed in the
>>>> SVN. Are there any errors logged on the server?
>>>>

--
Sergiu Dumitriu
http://purl.org/net/sergiu/
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot import default xar

hel-o
Hi,

Sergiu Dumitriu-2 wrote
hel-o wrote:

Idea: try to clean the browser cache first. Som JS functions have been
moved around.
thats what i've done first.

I tried to import the xar also in my local installation. Same result. Tried step by step with hold on every error in firebug:

When i upload the xar it stopps with the following error:

                                                 1 function onclick(event) {
updateAttachName is not defined 2 return updateAttachName(this.form, "Do you want to replace the      filename with");
                                                 3 }

But the file the upload is done and the file displayed.

When i click on the uploaded file it stopps with the following error:

                74 function getXmlValue(tag, xml)
                75 {
xml is null 76 var nodes = xml.getElementsByTagName(tag);
                77 if (nodes.length > 0 && nodes[0].firstChild)
                78 return nodes[0].firstChild.data;
                79 else
                80 return "";

and nothing happens.

Can there be any connection with the switch to utf8?
I also notized that there was no data base update.

Thanks
hel.
semantic-web.hel.at
hel@hel.at
Reply | Threaded
Open this post in threaded view
|

Re: Cannot import default xar

hel-o
Hi,

still no import and no idea why.

Any help?

Thanks
hel.

hel-o wrote
thats what i've done first.

I tried to import the xar also in my local installation. Same result. Tried step by step with hold on every error in firebug:

When i upload the xar it stopps with the following error:

                                                 1 function onclick(event) {
updateAttachName is not defined 2 return updateAttachName(this.form, "Do you want to replace the      filename with");
                                                 3 }

But the file the upload is done and the file displayed.

When i click on the uploaded file it stopps with the following error:

                74 function getXmlValue(tag, xml)
                75 {
xml is null 76 var nodes = xml.getElementsByTagName(tag);
                77 if (nodes.length > 0 && nodes[0].firstChild)
                78 return nodes[0].firstChild.data;
                79 else
                80 return "";

and nothing happens.

Can there be any connection with the switch to utf8?
I also notized that there was no data base update.

Thanks
hel.
semantic-web.hel.at
hel@hel.at
Reply | Threaded
Open this post in threaded view
|

Re: Cannot import default xar

PERINAUD Christophe
In reply to this post by hel-o
Hi,

xml is null so it seems the answer from the request is empty or wrong. Did you try to put some alert commands in the js file on the server to debug ? Maybe there is another way to do but that's how i do with this kind of problem.


-----Message d'origine-----
De : [hidden email] [mailto:[hidden email]] De la part de hel-o
Envoyé : vendredi 24 juillet 2009 08:05
À : [hidden email]
Objet : Re: [xwiki-users] Cannot import default xar


Hi,

still no import and no idea why.

Any help?

Thanks
hel.


hel-o wrote:

>
>
> thats what i've done first.
>
> I tried to import the xar also in my local installation. Same result.
> Tried step by step with hold on every error in firebug:
>
> When i upload the xar it stopps with the following error:
>
>                                                  1 function onclick(event)
> {
> updateAttachName is not defined 2 return updateAttachName(this.form, "Do
> you want to replace the      filename with");
>                                                  3 }
>
> But the file the upload is done and the file displayed.
>
> When i click on the uploaded file it stopps with the following error:
>
>                 74 function getXmlValue(tag, xml)
>                 75 {
> xml is null 76 var nodes = xml.getElementsByTagName(tag);
>                 77 if (nodes.length > 0 && nodes[0].firstChild)
>                 78 return nodes[0].firstChild.data;
>                 79 else
>                 80 return "";
>
> and nothing happens.
>
> Can there be any connection with the switch to utf8?
> I also notized that there was no data base update.
>
> Thanks
> hel.
>
>


-----
semantic-web.hel.at
[hidden email]

--
View this message in context: http://n2.nabble.com/Cannot-import-default-xar-tp3283800p3314065.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
--------------------------------------------------------------------------------

This e-mail is intended only for the addressee named above. It does not bind the sender, except in the case of an existing written convention with the addressee. This e-mail may contain material that is confidential and privileged for the sole use of the intended recipient. Any review, reliance or distribution by others or forwarding without express permission is strictly prohibited and may be unlawful. If you are not the intended recipient, please contact the sender and delete all copies.

While reasonable precautions have been taken to ensure that this e-mail and any attachments are free from any computer virus or similar defect, no liability will be accepted in that respect. Anyone accessing this e-mail must take their own precautions as to security and virus protection.

KBL European Private Bankers S.A., 43 boulevard Royal L-2955 Luxembourg, R.C.S. Luxembourg B 6395, T (352) 47 97 1
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot import default xar

Sergiu Dumitriu-2
In reply to this post by hel-o
hel-o wrote:
> Hi,
>
> still no import and no idea why.

Can you install firebug and capture the XHR request + response triggered
when clicking the xar name, then send it by mail.

--
Sergiu Dumitriu
http://purl.org/net/sergiu/
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot import default xar

hel-o
Hi,

finally found it.

It was an configuration error i made!. Don't remember why, but set the following parameter in xwiki.cfg:

#-# The name of the webapp to use in the generated URLs. The right value is taken from the request URL, so setting this
#-# is not recommended in most cases. If set, the value should contain a trailing /, but not a leading one. For example:
#-# xwiki.webapppath=xwiki/
xwiki.webapppath=/
#-# The default servlet mapping name to use in the generated URLs. The right value is taken from the request URL,
#-# preserving the requested servlet mapping, so setting this is not recommended in most cases. If set, the value should
#-# contain a trailing /, but not a leading one. For example:
#-# xwiki.servletpath=bin/
xwiki.servletpath=bin/
#-# The fallback servlet mapping name to use in the generated URLs. Unlike xwiki.servletpath, this is the value used when
#-# the correct setting could not be determined from the request URL. A good way to use this setting is to achieve short
#-# URLs, see http://platform.xwiki.org/xwiki/bin/Main/ShortURLs
xwiki.defaultservletpath=bin/

Changed all back to default values and it works again.

Thanks
hel.

Sergiu Dumitriu-2 wrote
hel-o wrote:
> Hi,
>
> still no import and no idea why.

Can you install firebug and capture the XHR request + response triggered
when clicking the xar name, then send it by mail.

--
Sergiu Dumitriu
http://purl.org/net/sergiu/
_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
semantic-web.hel.at
hel@hel.at