Quantcast

Clean Install Distribution Wizard

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Clean Install Distribution Wizard

Jesse Bright
I have a clean .deb install but when I access xwiki for the first time the distribution wizard has no skin. The header velocity macro shows the raw velocity code instead.  I can proceed but then this issue persists in the wiki created. Many features, especially on the admin screen are not accessible because all the macros indicate that they failed. Cause [Null]. Any thoughts on what would cause this on a blank install?

Regards,

Jesse

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Clean Install Distribution Wizard

Thomas Mortagne
Administrator
This is https://jira.xwiki.org/browse/XWIKI-14003. Looks like I fixed
it in 9.0~1 package and put put it back in 9.0~2 while fixing
something else...

Let's do a 9.0~3.

In the meantime the fix in to replace in /etc/xwiki.cfg file the empty property:

xwiki.plugins=

with:

xwiki.plugins=\
  com.xpn.xwiki.monitor.api.MonitorPlugin,\
  com.xpn.xwiki.plugin.skinx.JsSkinExtensionPlugin,\
  com.xpn.xwiki.plugin.skinx.JsSkinFileExtensionPlugin,\
  com.xpn.xwiki.plugin.skinx.JsResourceSkinExtensionPlugin,\
  com.xpn.xwiki.plugin.skinx.CssSkinExtensionPlugin,\
  com.xpn.xwiki.plugin.skinx.CssSkinFileExtensionPlugin,\
  com.xpn.xwiki.plugin.skinx.CssResourceSkinExtensionPlugin,\
  com.xpn.xwiki.plugin.skinx.LinkExtensionPlugin,\
  com.xpn.xwiki.plugin.feed.FeedPlugin,\
  com.xpn.xwiki.plugin.mail.MailPlugin,\
  com.xpn.xwiki.plugin.packaging.PackagePlugin,\
  com.xpn.xwiki.plugin.svg.SVGPlugin,\
  com.xpn.xwiki.plugin.fileupload.FileUploadPlugin,\
  com.xpn.xwiki.plugin.image.ImagePlugin,\
  com.xpn.xwiki.plugin.diff.DiffPlugin,\
  com.xpn.xwiki.plugin.rightsmanager.RightsManagerPlugin,\
  com.xpn.xwiki.plugin.jodatime.JodaTimePlugin,\
  com.xpn.xwiki.plugin.scheduler.SchedulerPlugin,\
  com.xpn.xwiki.plugin.mailsender.MailSenderPlugin,\
  com.xpn.xwiki.plugin.activitystream.plugin.ActivityStreamPlugin, \
  com.xpn.xwiki.plugin.tag.TagPlugin,\
  com.xpn.xwiki.plugin.watchlist.WatchListPlugin,\
  com.xpn.xwiki.plugin.zipexplorer.ZipExplorerPlugin

On Sun, Feb 5, 2017 at 8:56 PM, Jesse Bright <[hidden email]> wrote:
> I have a clean .deb install but when I access xwiki for the first time the distribution wizard has no skin. The header velocity macro shows the raw velocity code instead.  I can proceed but then this issue persists in the wiki created. Many features, especially on the admin screen are not accessible because all the macros indicate that they failed. Cause [Null]. Any thoughts on what would cause this on a blank install?
>
> Regards,
>
> Jesse
>



--
Thomas Mortagne
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Clean Install Distribution Wizard

Thomas Mortagne
Administrator
9.0+3 Debian packages are ready.

On Mon, Feb 6, 2017 at 9:15 AM, Thomas Mortagne
<[hidden email]> wrote:

> This is https://jira.xwiki.org/browse/XWIKI-14003. Looks like I fixed
> it in 9.0~1 package and put put it back in 9.0~2 while fixing
> something else...
>
> Let's do a 9.0~3.
>
> In the meantime the fix in to replace in /etc/xwiki.cfg file the empty property:
>
> xwiki.plugins=
>
> with:
>
> xwiki.plugins=\
>   com.xpn.xwiki.monitor.api.MonitorPlugin,\
>   com.xpn.xwiki.plugin.skinx.JsSkinExtensionPlugin,\
>   com.xpn.xwiki.plugin.skinx.JsSkinFileExtensionPlugin,\
>   com.xpn.xwiki.plugin.skinx.JsResourceSkinExtensionPlugin,\
>   com.xpn.xwiki.plugin.skinx.CssSkinExtensionPlugin,\
>   com.xpn.xwiki.plugin.skinx.CssSkinFileExtensionPlugin,\
>   com.xpn.xwiki.plugin.skinx.CssResourceSkinExtensionPlugin,\
>   com.xpn.xwiki.plugin.skinx.LinkExtensionPlugin,\
>   com.xpn.xwiki.plugin.feed.FeedPlugin,\
>   com.xpn.xwiki.plugin.mail.MailPlugin,\
>   com.xpn.xwiki.plugin.packaging.PackagePlugin,\
>   com.xpn.xwiki.plugin.svg.SVGPlugin,\
>   com.xpn.xwiki.plugin.fileupload.FileUploadPlugin,\
>   com.xpn.xwiki.plugin.image.ImagePlugin,\
>   com.xpn.xwiki.plugin.diff.DiffPlugin,\
>   com.xpn.xwiki.plugin.rightsmanager.RightsManagerPlugin,\
>   com.xpn.xwiki.plugin.jodatime.JodaTimePlugin,\
>   com.xpn.xwiki.plugin.scheduler.SchedulerPlugin,\
>   com.xpn.xwiki.plugin.mailsender.MailSenderPlugin,\
>   com.xpn.xwiki.plugin.activitystream.plugin.ActivityStreamPlugin, \
>   com.xpn.xwiki.plugin.tag.TagPlugin,\
>   com.xpn.xwiki.plugin.watchlist.WatchListPlugin,\
>   com.xpn.xwiki.plugin.zipexplorer.ZipExplorerPlugin
>
> On Sun, Feb 5, 2017 at 8:56 PM, Jesse Bright <[hidden email]> wrote:
>> I have a clean .deb install but when I access xwiki for the first time the distribution wizard has no skin. The header velocity macro shows the raw velocity code instead.  I can proceed but then this issue persists in the wiki created. Many features, especially on the admin screen are not accessible because all the macros indicate that they failed. Cause [Null]. Any thoughts on what would cause this on a blank install?
>>
>> Regards,
>>
>> Jesse
>>
>
>
>
> --
> Thomas Mortagne



--
Thomas Mortagne
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Clean Install Distribution Wizard

Jesse Bright
Updated and everything is as expected. Thank you very much Thomas! I really appreciate the timely and helpful assistance.

Regards,

Jesse

> On Feb 6, 2017, at 12:54 AM, Thomas Mortagne <[hidden email]> wrote:
>
> 9.0+3 Debian packages are ready.
>
> On Mon, Feb 6, 2017 at 9:15 AM, Thomas Mortagne
> <[hidden email]> wrote:
>> This is https://jira.xwiki.org/browse/XWIKI-14003. Looks like I fixed
>> it in 9.0~1 package and put put it back in 9.0~2 while fixing
>> something else...
>>
>> Let's do a 9.0~3.
>>
>> In the meantime the fix in to replace in /etc/xwiki.cfg file the empty property:
>>
>> xwiki.plugins=
>>
>> with:
>>
>> xwiki.plugins=\
>>  com.xpn.xwiki.monitor.api.MonitorPlugin,\
>>  com.xpn.xwiki.plugin.skinx.JsSkinExtensionPlugin,\
>>  com.xpn.xwiki.plugin.skinx.JsSkinFileExtensionPlugin,\
>>  com.xpn.xwiki.plugin.skinx.JsResourceSkinExtensionPlugin,\
>>  com.xpn.xwiki.plugin.skinx.CssSkinExtensionPlugin,\
>>  com.xpn.xwiki.plugin.skinx.CssSkinFileExtensionPlugin,\
>>  com.xpn.xwiki.plugin.skinx.CssResourceSkinExtensionPlugin,\
>>  com.xpn.xwiki.plugin.skinx.LinkExtensionPlugin,\
>>  com.xpn.xwiki.plugin.feed.FeedPlugin,\
>>  com.xpn.xwiki.plugin.mail.MailPlugin,\
>>  com.xpn.xwiki.plugin.packaging.PackagePlugin,\
>>  com.xpn.xwiki.plugin.svg.SVGPlugin,\
>>  com.xpn.xwiki.plugin.fileupload.FileUploadPlugin,\
>>  com.xpn.xwiki.plugin.image.ImagePlugin,\
>>  com.xpn.xwiki.plugin.diff.DiffPlugin,\
>>  com.xpn.xwiki.plugin.rightsmanager.RightsManagerPlugin,\
>>  com.xpn.xwiki.plugin.jodatime.JodaTimePlugin,\
>>  com.xpn.xwiki.plugin.scheduler.SchedulerPlugin,\
>>  com.xpn.xwiki.plugin.mailsender.MailSenderPlugin,\
>>  com.xpn.xwiki.plugin.activitystream.plugin.ActivityStreamPlugin, \
>>  com.xpn.xwiki.plugin.tag.TagPlugin,\
>>  com.xpn.xwiki.plugin.watchlist.WatchListPlugin,\
>>  com.xpn.xwiki.plugin.zipexplorer.ZipExplorerPlugin
>>
>>> On Sun, Feb 5, 2017 at 8:56 PM, Jesse Bright <[hidden email]> wrote:
>>> I have a clean .deb install but when I access xwiki for the first time the distribution wizard has no skin. The header velocity macro shows the raw velocity code instead.  I can proceed but then this issue persists in the wiki created. Many features, especially on the admin screen are not accessible because all the macros indicate that they failed. Cause [Null]. Any thoughts on what would cause this on a blank install?
>>>
>>> Regards,
>>>
>>> Jesse
>>>
>>
>>
>>
>> --
>> Thomas Mortagne
>
>
>
> --
> Thomas Mortagne


Loading...