Quantcast

Configuration of XWiki registration message not visible to non-admin users

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Configuration of XWiki registration message not visible to non-admin users

Gilles Dubochet
Hi list,

This is my first post. Just starting with XWiki, and pretty excited about everything it can do.

I’m trying to configure the registration text (what unregistered users see when they create a new account on page XWikiRegister). I changed what I want in Administration:Registration (page heading and welcome message), as described in the XWiki help.

However, when an unregistered user goes to the registration page, they will not see my custom message, but a default message above the registration form (note absence of styling):
> Registration
> Sign up here so you can edit pages and participate in the wiki.
>

But… when I navigate to the registration page while logged in with my administrator account, I get the page with my customised page heading and welcome message. By navigate, I mean copy the link ".../xwiki/bin/register/XWiki/XWikiRegister" into my address bar.

And… when I navigate to the same page while logged in with a non-administrator account, I get an error ("You are not allowed to view this page or perform this action.”). Which is OK, I guess.

Can anyone point me towards what might be going on? My best guess is that it is a rights problem (I’ve been fighting with those). But I have no idea where to look.

My XWiki version is a hosted enterprise 8.4.4.

Thank you so much for your help!

Cheers,
Gilles
Loading...