Configuring Open Office server

classic Classic list List threaded Threaded
23 messages Options
12
Reply | Threaded
Open this post in threaded view
|

Re: Configuring Open Office server

Florin Ciubotaru
On 5/10/2010 12:34 PM, Ben Stuggler wrote:
> Just to share a bug (I think it is) linked to OpenOffice server...
>    

> If I go on the administration page and select "OpenOffice Server" to start
> the server, I obtain "Inadequate privileges."
> But if I go to the same page by "Document Index", I can start the server
> without error message.
> I think it's maybe some rights problem but I can't figure what it is.
>    
Yes, this is known. The issue is caused by the programming rights
requirement. This will require only admin rights in the future.

Thanks,
Florin Ciubotaru


_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Configuring Open Office server

Ben Stuggler
Florin Ciubotaru wrote
On 5/10/2010 12:34 PM, Ben Stuggler wrote:
> Just to share a bug (I think it is) linked to OpenOffice server...
>    

> If I go on the administration page and select "OpenOffice Server" to start
> the server, I obtain "Inadequate privileges."
> But if I go to the same page by "Document Index", I can start the server
> without error message.
> I think it's maybe some rights problem but I can't figure what it is.
>    
Yes, this is known. The issue is caused by the programming rights
requirement. This will require only admin rights in the future.

Thanks,
Florin Ciubotaru


_______________________________________________
users mailing list
users@xwiki.org
http://lists.xwiki.org/mailman/listinfo/users
Ok, I have added however the PR for the target user, but it does'nt change anything.

thanks anyway

Ben

Reply | Threaded
Open this post in threaded view
|

Re: Configuring Open Office server

Florin Ciubotaru
On 5/10/2010 12:51 PM, Ben Stuggler wrote:

>
> Florin Ciubotaru wrote:
>    
>> On 5/10/2010 12:34 PM, Ben Stuggler wrote:
>>      
>>> Just to share a bug (I think it is) linked to OpenOffice server...
>>>
>>>        
>>      
>>> If I go on the administration page and select "OpenOffice Server" to
>>> start
>>> the server, I obtain "Inadequate privileges."
>>> But if I go to the same page by "Document Index", I can start the server
>>> without error message.
>>> I think it's maybe some rights problem but I can't figure what it is.
>>>
>>>        
>> Yes, this is known. The issue is caused by the programming rights
>> requirement. This will require only admin rights in the future.
>>
>> Thanks,
>> Florin Ciubotaru
>>
>>
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>>
>>      
> Ok, I have added however the PR for the target user, but it does'nt change
> anything.
>    
Programming rights are actually checked for the current page. Basically
a page has programming rights when when it was last saved by a user
having PR, certifying the page to run its scripts. This is a bit
confusing for the users.
In the case of office importer you will need to re-save the script pages
and probably the admin page too, but it is know to be inconsistent and
you will need to redo the operation if you have the "Inadequate rights"
message again. PR are causing some inconveniences which is why we are
going to reduce the number of pages that require them.
> thanks anyway
>
> Ben
>
>
>    

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
12