Error saving pages using XWord

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Error saving pages using XWord

Loris Conedera
Hi All,
I need to give my users the possibility to edit XWiki Pages using
XWord but doing some tests I get some errors.
I'm using XE 2.4.3 and Microsoft Office 2007.
When i create a new page and upload it, XWord works fine but when I
try to edit an existing page I get errors while saving the document.
Any idea about this problem?
I can't see errors on xwiki.log file...
Thanks!

Loris
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Error saving pages using XWord

Florin Ciubotaru
Hi,

Not sure if this is a server side or client side error.
What servlet container are you using? Can you check the errors reported to
stdout?
I would also need to know what error does XWord display. XWord stores more
detailed error messages in the windows logging system. You can check that
using event viewer.

Regards,
Florin Ciubotaru

On Mon, Oct 18, 2010 at 3:40 PM, Loris Conedera <[hidden email]>wrote:

> Hi All,
> I need to give my users the possibility to edit XWiki Pages using
> XWord but doing some tests I get some errors.
> I'm using XE 2.4.3 and Microsoft Office 2007.
> When i create a new page and upload it, XWord works fine but when I
> try to edit an existing page I get errors while saving the document.
> Any idea about this problem?
> I can't see errors on xwiki.log file...
> Thanks!
>
> Loris
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Error saving pages using XWord

Loris Conedera
Hi,
Here you can find the error that i find in Event viewer, it seems to
be a server error. I'm using Tomcat 6 and i don't find errors on
stdout.
Thanks,

Loris

Tipo evento: Errore
Origine evento: XWiki
Categoria evento: Nessuno
ID evento: 0
Data: 19/10/2010
Ora: 16.11.37
Utente: N/D
Computer: AGOPC075344
Descrizione:
Source:   System
Type:     System.Net.WebException
Message:  The remote server returned an error: (500) Internal Server Error.
Help link
Exception data:


Stack trace:
   at System.Net.WebClient.UploadDataInternal(Uri address, String
method, Byte[] data, WebRequest& request)
   at System.Net.WebClient.UploadString(Uri address, String method, String data)
   at System.Net.WebClient.UploadString(String address, String method,
String data)
   at XWiki.Clients.XWikiXMLRPCClient.UpdateObject(String
pageFullName, String className, Int32 objectIndex, NameValueCollection
fieldsValues)
   at ContentFiltering.StyleSheetExtensions.SSXManager.UploadStyleSheetExtensions()
   at XWord.AddinActions.SaveToXwiki()
   at XWord.AddinActions.SaveToServer()
   at XWord.XWikiRibbon.btnSavePage_Click(Object sender,
RibbonControlEventArgs e)

2010/10/18 Florin Ciubotaru <[hidden email]>:

> Hi,
>
> Not sure if this is a server side or client side error.
> What servlet container are you using? Can you check the errors reported to
> stdout?
> I would also need to know what error does XWord display. XWord stores more
> detailed error messages in the windows logging system. You can check that
> using event viewer.
>
> Regards,
> Florin Ciubotaru
>
> On Mon, Oct 18, 2010 at 3:40 PM, Loris Conedera <[hidden email]>wrote:
>
>> Hi All,
>> I need to give my users the possibility to edit XWiki Pages using
>> XWord but doing some tests I get some errors.
>> I'm using XE 2.4.3 and Microsoft Office 2007.
>> When i create a new page and upload it, XWord works fine but when I
>> try to edit an existing page I get errors while saving the document.
>> Any idea about this problem?
>> I can't see errors on xwiki.log file...
>> Thanks!
>>
>> Loris
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Error saving pages using XWord

Florin Ciubotaru
Hi,

I see where the error comes from. A server error log should also exist. You
need to create a jira issue and follow up o the progress on:
http://jira.xwiki.org/jira/browse/XOFFICE

Thanks,
Florin Ciubotaru

<http://jira.xwiki.org/jira/browse/XOFFICE>

On Tue, Oct 19, 2010 at 5:21 PM, Loris Conedera <[hidden email]>wrote:

> Hi,
> Here you can find the error that i find in Event viewer, it seems to
> be a server error. I'm using Tomcat 6 and i don't find errors on
> stdout.
> Thanks,
>
> Loris
>
> Tipo evento:    Errore
> Origine evento: XWiki
> Categoria evento:       Nessuno
> ID evento:      0
> Data:           19/10/2010
> Ora:            16.11.37
> Utente:         N/D
> Computer:       AGOPC075344
> Descrizione:
> Source:   System
> Type:     System.Net.WebException
> Message:  The remote server returned an error: (500) Internal Server Error.
> Help link
> Exception data:
>
>
> Stack trace:
>   at System.Net.WebClient.UploadDataInternal(Uri address, String
> method, Byte[] data, WebRequest& request)
>   at System.Net.WebClient.UploadString(Uri address, String method, String
> data)
>   at System.Net.WebClient.UploadString(String address, String method,
> String data)
>   at XWiki.Clients.XWikiXMLRPCClient.UpdateObject(String
> pageFullName, String className, Int32 objectIndex, NameValueCollection
> fieldsValues)
>   at
> ContentFiltering.StyleSheetExtensions.SSXManager.UploadStyleSheetExtensions()
>   at XWord.AddinActions.SaveToXwiki()
>   at XWord.AddinActions.SaveToServer()
>   at XWord.XWikiRibbon.btnSavePage_Click(Object sender,
> RibbonControlEventArgs e)
>
> 2010/10/18 Florin Ciubotaru <[hidden email]>:
> > Hi,
> >
> > Not sure if this is a server side or client side error.
> > What servlet container are you using? Can you check the errors reported
> to
> > stdout?
> > I would also need to know what error does XWord display. XWord stores
> more
> > detailed error messages in the windows logging system. You can check that
> > using event viewer.
> >
> > Regards,
> > Florin Ciubotaru
> >
> > On Mon, Oct 18, 2010 at 3:40 PM, Loris Conedera <[hidden email]
> >wrote:
> >
> >> Hi All,
> >> I need to give my users the possibility to edit XWiki Pages using
> >> XWord but doing some tests I get some errors.
> >> I'm using XE 2.4.3 and Microsoft Office 2007.
> >> When i create a new page and upload it, XWord works fine but when I
> >> try to edit an existing page I get errors while saving the document.
> >> Any idea about this problem?
> >> I can't see errors on xwiki.log file...
> >> Thanks!
> >>
> >> Loris
> >> _______________________________________________
> >> users mailing list
> >> [hidden email]
> >> http://lists.xwiki.org/mailman/listinfo/users
> >>
> > _______________________________________________
> > users mailing list
> > [hidden email]
> > http://lists.xwiki.org/mailman/listinfo/users
> >
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users