Help with Navigation Menu Wiki Macro

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Help with Navigation Menu Wiki Macro

pinkerp
I am using the Nav Menu Wiki Macro to create some menus - and it's
working - but not completely.

I have the following issues:

In a horizontal menu, the 1st and 2nd levels appear correctly.  When I
add a 3rd level, it displays overtop of existing text, rather than
'popping out'.

*Main1

** Sub1

*** Sub1Sub1

**Sub2

***Sub2Sub1

*Main2

 

In a vertical menu, the submenu items appear to the side, but below the
level of the related main menu item, making it difficult to move the
mouse to the submenu to select links there.

 

I have tried adding line spaces, etc.. but this doesn't affect the
display.

I did check online for existing solutions - and found this thread
detailing a similar issue from late 2012/ early 2013.  No solutions were
offered.

http://xwiki.475771.n2.nabble.com/Navigation-Menu-Wiki-Macro-td7582112.h
tml#a7582455 (see Hamster's post of Nov 16, 2012 2:06 and following)

The poster suggests that the issue is in the JavaScript code.

 

Any help here would be appreciated.

 

Paul Pinkerton

KnowledgeNow Project Lead

[hidden email] <mailto:[hidden email]>

 

Association of Community Legal Clinics of Ontario

416-847-1418 or 1-866-965-1416x 5177

www.aclco.org <http://www.aclco.org>  

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Help with Navigation Menu Wiki Macro

Hamster
Not that I know...

But if you are running on a more recent version of XWiki, you should try this extension:Menu Application