Improvement: LDAP authentification with virtual wikis

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Improvement: LDAP authentification with virtual wikis

Xavier MOGHRABI
Hi XWiki developers,

I'm using LDAP to authentificate users for several virtual wikis. I'm using a
single LDAP a base for all the wikis. The problem I had is that when a user
logged on a wiki he was only added on the wiki he logged even if my
authentification is unique. So that's difficult to manage the access rights
if I have to look for the user page.

So, when we use virtual wikis and LDAP authentification, I propose that users
should be added in the wiki where the LDAP has been configured:
- 1st case if the authentification has been configured in the preferences of
the Main Wiki or in the xwiki.cfg file, the users should be added in the Main
Wiki.
-2nd case if the authentification has been configured in the preferences of a
Virtual Wiki, the users should be added in the Virtual Wiki on which the user
is logging.

By the way, to prevent access right problem, after having creating the user
XWiki should flush the cache.

Here is attached a patch that I've tested on my wikis with the 1st case only
that should do this.

Regards.

--
Xavier MOGHRABI - Consortium ObjectWeb
Email : xavier.moghrabi at objectweb.org
Phone : +33 4 76 61 52 35


--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws

patch_ldap.txt (2K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Working off line

Youcef Bey
Hi all,

I have a real need to know whether there are a possibility to edit document
existing on XWiki in external editor. And after that, transfering it on
XWiki by taking in consideration different change and version management.

Thank you in advance.

Best regards,
----------------------------------------------------------------------------
-------------
Youcef Bey,
Graduate School of Advanced Studies,





--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Language switch cause a PB

Youcef Bey
In reply to this post by Xavier MOGHRABI
Hi All,

I have a problem when I switch fom language to other.

The problem is as following:

This happen when I defined a new principale page. By using French language,
I have defined a new principale page, and after that, when I have switch to
English, the the principale page do not exist. Then I found other page.

It seems strange. I have tried to find where is problem but without any
success.

Have you any idea on how to solve this problem?

All my thanks in advance.
----------------------------------------------------------------------------
------------
Youcef Bey,
Graduate School of Advanced Studies,





--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws