Installation from .deb packages

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Installation from .deb packages

Timo Dachs-Wegmann
Hello all,

I have an issue installing the .deb packages from the maven repositories.

The installation of xwiki-enterprise-tomcat8-mysql (and all other mysql installations) has a dependency to the old "mysql-server" package from the old versions of debian.
It was replaced/removed in debian Jessie.

It would be great if you could fix the dependency so the automatic installation works as it should. :)

Kind regards,

Timo Dachs-Wegmann
-IT-


Reply | Threaded
Open this post in threaded view
|

Re: Installation from .deb packages

Thomas Mortagne
Administrator
On Tue, May 2, 2017 at 11:42 AM, Timo Dachs-Wegmann
<[hidden email]> wrote:
> Hello all,
>
> I have an issue installing the .deb packages from the maven repositories.
>
> The installation of xwiki-enterprise-tomcat8-mysql (and all other mysql installations) has a dependency to the old "mysql-server" package from the old versions of debian.
> It was replaced/removed in debian Jessie.

I'm surprised you are the first one to report that and Ubuntu does not
complain about this. What is the new package name ?

>
> It would be great if you could fix the dependency so the automatic installation works as it should. :)
>
> Kind regards,
>
> Timo Dachs-Wegmann
> -IT-
>
>



--
Thomas Mortagne
Reply | Threaded
Open this post in threaded view
|

Re: Installation from .deb packages

Timo Dachs-Wegmann

On Tue, May 2, 2017 at 11:42 AM, Timo Dachs-Wegmann <[hidden email]> wrote:
> Hello all,
>
> I have an issue installing the .deb packages from the maven repositories.
>
> The installation of xwiki-enterprise-tomcat8-mysql (and all other mysql installations) has a dependency to the old "mysql-server" package from the old versions of debian.
> It was replaced/removed in debian Jessie.

I'm surprised you are the first one to report that and Ubuntu does not complain about this. What is the new package name ?

So am I... Well, when I try to install it, it says that the package got replaced by: "mariadb-server-10.1"

But I don't know if that’s true :/

Maybe I'm getting something wrong but it doesn't work for me. Can someone confirm this?

>
> It would be great if you could fix the dependency so the automatic
> installation works as it should. :)
>
> Kind regards,
>
> Timo Dachs-Wegmann
> -IT-
>
>



--
Thomas Mortagne



Reply | Threaded
Open this post in threaded view
|

Re: Installation from .deb packages

Thomas Mortagne
Administrator
The current dependencies in the package are:

xwiki-enterprise-common (= [[version]]), mysql-server, libmysql-java
(>= 5.1.4), dbconfig-common

having something like "mysql-server | mariadb-server" (i.e. need
either mysql-server or mariadb-server) is easy, just want to be what
is the right package.

On Tue, May 2, 2017 at 12:32 PM, Timo Dachs-Wegmann
<[hidden email]> wrote:

>
> On Tue, May 2, 2017 at 11:42 AM, Timo Dachs-Wegmann <[hidden email]> wrote:
>> Hello all,
>>
>> I have an issue installing the .deb packages from the maven repositories.
>>
>> The installation of xwiki-enterprise-tomcat8-mysql (and all other mysql installations) has a dependency to the old "mysql-server" package from the old versions of debian.
>> It was replaced/removed in debian Jessie.
>
> I'm surprised you are the first one to report that and Ubuntu does not complain about this. What is the new package name ?
>
> So am I... Well, when I try to install it, it says that the package got replaced by: "mariadb-server-10.1"
>
> But I don't know if that’s true :/
>
> Maybe I'm getting something wrong but it doesn't work for me. Can someone confirm this?
>
>>
>> It would be great if you could fix the dependency so the automatic
>> installation works as it should. :)
>>
>> Kind regards,
>>
>> Timo Dachs-Wegmann
>> -IT-
>>
>>
>
>
>
> --
> Thomas Mortagne
>
>
>



--
Thomas Mortagne
Reply | Threaded
Open this post in threaded view
|

Re: Installation from .deb packages

Timo Dachs-Wegmann
Well, I don't know which one is needed. But there is a package called "default-mysql-server" maybe it's the one we are looking for here.

I have no time to test it now. But if you've trouble finding the right one, I try to find it sometime this week.

> The current dependencies in the package are:
>
> xwiki-enterprise-common (= [[version]]), mysql-server, libmysql-java (>= 5.1.4), dbconfig-common
>
> having something like "mysql-server | mariadb-server" (i.e. need either mysql-server or mariadb-server) is easy, just want to be what is the right package.
>
>On Tue, May 2, 2017 at 12:32 PM, Timo Dachs-Wegmann <[hidden email]> wrote:
>>
>> On Tue, May 2, 2017 at 11:42 AM, Timo Dachs-Wegmann <[hidden email]> wrote:
>>> Hello all,
>>>
>>>I have an issue installing the .deb packages from the maven repositories.
>>>
>>> The installation of xwiki-enterprise-tomcat8-mysql (and all other mysql installations) has a dependency to the old "mysql-server" package from the old versions of debian.
>>> It was replaced/removed in debian Jessie.
>>
>> I'm surprised you are the first one to report that and Ubuntu does not complain about this. What is the new package name ?
>>
>> So am I... Well, when I try to install it, it says that the package got replaced by: "mariadb-server-10.1"
>>
>> But I don't know if that’s true :/
>>
>> Maybe I'm getting something wrong but it doesn't work for me. Can someone confirm this?
>>
>>>
>>> It would be great if you could fix the dependency so the automatic
>>> installation works as it should. :)
>>>
>>> Kind regards,
>>>
>>> Timo Dachs-Wegmann
>>> -IT-
>>>
>>>
>>
>>
>>
>> --
>> Thomas Mortagne
>>
>>
>>



--
Thomas Mortagne



Reply | Threaded
Open this post in threaded view
|

Re: Installation from .deb packages

Thomas Mortagne
Administrator
I just looked at https://packages.debian.org and from what I
understand the package mysql-server exist in jessie and the package
default-mysql-server is only included in jessie-backports.

However stretch does not contain any package mysql-server, are you
sure you are on Jessie ?

Anyway I will use the following to be safe: "mysql-server |
default-mysql-server | mariadb-server".

On Tue, May 2, 2017 at 12:46 PM, Timo Dachs-Wegmann
<[hidden email]> wrote:

> Well, I don't know which one is needed. But there is a package called "default-mysql-server" maybe it's the one we are looking for here.
>
> I have no time to test it now. But if you've trouble finding the right one, I try to find it sometime this week.
>
>> The current dependencies in the package are:
>>
>> xwiki-enterprise-common (= [[version]]), mysql-server, libmysql-java (>= 5.1.4), dbconfig-common
>>
>> having something like "mysql-server | mariadb-server" (i.e. need either mysql-server or mariadb-server) is easy, just want to be what is the right package.
>>
>>On Tue, May 2, 2017 at 12:32 PM, Timo Dachs-Wegmann <[hidden email]> wrote:
>>>
>>> On Tue, May 2, 2017 at 11:42 AM, Timo Dachs-Wegmann <[hidden email]> wrote:
>>>> Hello all,
>>>>
>>>>I have an issue installing the .deb packages from the maven repositories.
>>>>
>>>> The installation of xwiki-enterprise-tomcat8-mysql (and all other mysql installations) has a dependency to the old "mysql-server" package from the old versions of debian.
>>>> It was replaced/removed in debian Jessie.
>>>
>>> I'm surprised you are the first one to report that and Ubuntu does not complain about this. What is the new package name ?
>>>
>>> So am I... Well, when I try to install it, it says that the package got replaced by: "mariadb-server-10.1"
>>>
>>> But I don't know if that’s true :/
>>>
>>> Maybe I'm getting something wrong but it doesn't work for me. Can someone confirm this?
>>>
>>>>
>>>> It would be great if you could fix the dependency so the automatic
>>>> installation works as it should. :)
>>>>
>>>> Kind regards,
>>>>
>>>> Timo Dachs-Wegmann
>>>> -IT-
>>>>
>>>>
>>>
>>>
>>>
>>> --
>>> Thomas Mortagne
>>>
>>>
>>>
>
>
>
> --
> Thomas Mortagne
>
>
>



--
Thomas Mortagne