LDAP service is not available after update from 6.4.2 to 7.1.2

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

LDAP service is not available after update from 6.4.2 to 7.1.2

aleksey-s
Hi,

After update from 6.4.2 to 7.1.2 we faced with message in LDAP settings:

But it work, I can access to xwiki with my LDAP login and password.
I changed logging level for com.xpn.xwiki.user.impl.LDAP.XWikiLDAPAuthServiceImpl in debug mode and see in log:
DEBUG u.i.L.XWikiLDAPAuthServiceImpl - LDAP authentication succeed with principal [XWiki.aleksey-s]

xwiki.cfg for 6.4.2 and 7.1.2 identical.


We  tested  rollback  xwiki to 6.4.2 and message "LDAP service is not available. Please verify your installation." disappeared..

Why the message "LDAP service is not available. Please verify your installation" appeared on 7.1.2 ?
Reply | Threaded
Open this post in threaded view
|

Re: LDAP service is not available after update from 6.4.2 to 7.1.2

Thomas Mortagne
Administrator
On Tue, Sep 8, 2015 at 3:45 PM, aleksey-s <[hidden email]> wrote:

> Hi,
>
> After update from 6.4.2 to 7.1.2 we faced with message in LDAP settings:
>
> But it work, I can access to xwiki with my LDAP login and password.
> I changed logging level for
> com.xpn.xwiki.user.impl.LDAP.XWikiLDAPAuthServiceImpl in debug mode and see
> in log:
> DEBUG u.i.L.XWikiLDAPAuthServiceImpl - LDAP authentication succeed with
> principal [XWiki.aleksey-s]
>
> xwiki.cfg for 6.4.2 and 7.1.2 identical.
>
>
> We  tested  rollback  xwiki to 6.4.2 and message "LDAP service is not
> available. Please verify your installation." disappeared..
>
> Why the message "LDAP service is not available. Please verify your
> installation" appeared on 7.1.2 ?

Are you sure you have the same thing in the new xwiki.cfg ? Nothing
really changed in LDAP between 6.4.2 and 7.1.2 so all I can think of
is xwiki.cfg file not properly migrated.

>
>
>
> --
> View this message in context: http://xwiki.475771.n2.nabble.com/LDAP-service-is-not-available-after-update-from-6-4-2-to-7-1-2-tp7595928.html
> Sent from the XWiki- Users mailing list archive at Nabble.com.
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users



--
Thomas Mortagne
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: LDAP service is not available after update from 6.4.2 to 7.1.2

aleksey-s
Hi!

Yes. To make sure I copied xwiki.cfg from old to new version again and restart xwiki.

In xwiki.cfg in LDAP section uncommented  only next strings

xwiki.authentication.authclass=com.xpn.xwiki.user.impl.LDAP.XWikiLDAPAuthServiceImpl
xwiki.authentication.ldap.server=127.0.0.1
xwiki.authentication.ldap.port=389
xwiki.authentication.ldap.bind_DN=cn={0},department=USER,department=INFORMATIK,department=1230,o=MP
xwiki.authentication.ldap.bind_pass={1}
xwiki.authentication.ldap.base_DN=
xwiki.authentication.ldap.fields_mapping=last_name=sn,first_name=givenName,email=mail
xwiki.authentication.ldap.update_user=1
xwiki.authentication.ldap.trylocal=1

But in XWikiPreferences some parameters not match to xwiki.cfg (ldap server and etc). It was on old version too.
Reply | Threaded
Open this post in threaded view
|

Re: LDAP service is not available after update from 6.4.2 to 7.1.2

Thomas Mortagne
Administrator
As far as I know "LDAP service is not available" error message is only
displayed in LDAP UI extension and indicate that it cannot find the
service that is supposed to be located in xwiki-platform-ldap-api
("XWiki Platform - LDAP - API" extension) jar. Either you installed it
by hand last time and forgot to put it in the new install or you
installed it as extension and forgot to keep your permanent directory
when you upgraded.

On Wed, Sep 9, 2015 at 9:24 AM, aleksey-s <[hidden email]> wrote:

> Hi!
>
> Yes. To make sure I copied xwiki.cfg from old to new version again and
> restart xwiki.
>
> In xwiki.cfg in LDAP section uncommented  only next strings
>
> xwiki.authentication.authclass=com.xpn.xwiki.user.impl.LDAP.XWikiLDAPAuthServiceImpl
> xwiki.authentication.ldap.server=127.0.0.1
> xwiki.authentication.ldap.port=389
> xwiki.authentication.ldap.bind_DN=cn={0},department=USER,department=INFORMATIK,department=1230,o=MP
> xwiki.authentication.ldap.bind_pass={1}
> xwiki.authentication.ldap.base_DN=
> xwiki.authentication.ldap.fields_mapping=last_name=sn,first_name=givenName,email=mail
> xwiki.authentication.ldap.update_user=1
> xwiki.authentication.ldap.trylocal=1
>
> But in XWikiPreferences some parameters not match to xwiki.cfg (ldap server
> and etc). It was on old version too.
>
>
>
>
> --
> View this message in context: http://xwiki.475771.n2.nabble.com/LDAP-service-is-not-available-after-update-from-6-4-2-to-7-1-2-tp7595928p7595937.html
> Sent from the XWiki- Users mailing list archive at Nabble.com.
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users



--
Thomas Mortagne
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: LDAP service is not available after update from 6.4.2 to 7.1.2

aleksey-s
Thank you! It is our situation, we installed "XWiki Platform - LDAP - API" in extension manager on new version and error message disappeared.