Problem upgrading from 5.4.4 to 6.1m2

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem upgrading from 5.4.4 to 6.1m2

mctoz
Well I really only intended to go from 5.4.4 to 5.4.5 but one thing let to another so I decided to go with the latest milestone release.  It all appears to be working OK, but I'm getting an error during the migration phase, where is says that some of the existing 5.4.4 UI pages/packages are "not valid"...so the migration fails to complete properly. (When I restart the container I get presented with the migration gui again).

My own wiki content appears to be OK, but now I'm not sure about the system pages.

Are there any know issues with the migrator? Any way to bypass this validity check and force it anyway?

Cheers,MT

Reply | Threaded
Open this post in threaded view
|

Re: Problem upgrading from 5.4.4 to 6.1m2

Thomas Mortagne
Administrator
Note that a "milestone" is not intended to be stable so upgrading to
it is really not the est idea unless you really want to test it before
the release. Among other things this specific milestone may have an
issue when installing the UI extension. The last stable version is
6.0.1.

Now for the issue you have I really don't see what you mean exactly.
Where do you get "not valid" ? Getting a warning in the log saying
that the UI extension is not valid is perfectly normal, your UI is not
valid since it was for the previous version, that's why you are
upgrading it. The warning also contain the reason: the UI requires
[5.4.4] version.

On Wed, Jun 18, 2014 at 2:04 PM, mctoz <[hidden email]> wrote:

> Well I really only intended to go from 5.4.4 to 5.4.5 but one thing let to
> another so I decided to go with the latest milestone release.  It all
> appears to be working OK, but I'm getting an error during the migration
> phase, where is says that some of the existing 5.4.4 UI pages/packages are
> "not valid"...so the migration fails to complete properly. (When I restart
> the container I get presented with the migration gui again).
>
> My own wiki content appears to be OK, but now I'm not sure about the system
> pages.
>
> Are there any know issues with the migrator? Any way to bypass this validity
> check and force it anyway?
>
> Cheers,MT
>
>
>
>
>
> --
> View this message in context: http://xwiki.475771.n2.nabble.com/Problem-upgrading-from-5-4-4-to-6-1m2-tp7591094.html
> Sent from the XWiki- Users mailing list archive at Nabble.com.
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users



--
Thomas Mortagne
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users