Special Characters in Titel

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Special Characters in Titel

hel-o
Hi,

I inserted Text "Text" in the title field of a page. When i edit the page again the "Text" part disappears.
Tried other special characters (; @) and everything seems to work normal. So its only the " character that makes problems.

(XWiki 1.8.4, syntax 2.0, language: german)

Is there a way to have heading levels 3 or above also used as titel when the title field is empty?

Thanks
hel.



semantic-web.hel.at
hel@hel.at
Reply | Threaded
Open this post in threaded view
|

Re: Special Characters in Titel

Sergiu Dumitriu-2
hel-o wrote:
> Hi,
>
> I inserted Text "Text" in the title field of a page. When i edit the page
> again the "Text" part disappears.
> Tried other special characters (; @) and everything seems to work normal. So
> its only the " character that makes problems.
>
> (XWiki 1.8.4, syntax 2.0, language: german)

This was fixed recently, 1.9 will behave correctly.

> Is there a way to have heading levels 3 or above also used as titel when the
> title field is empty?

Not unless you change the java code and recompile xwiki-core.
--
Sergiu Dumitriu
http://purl.org/net/sergiu/
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Special Characters in Titel

hel-o
Sergiu Dumitriu-2 wrote
hel-o wrote:
> Hi,
>
> I inserted Text "Text" in the title field of a page. When i edit the page
> again the "Text" part disappears.
> Tried other special characters (; @) and everything seems to work normal. So
> its only the " character that makes problems.
>
> (XWiki 1.8.4, syntax 2.0, language: german)

This was fixed recently, 1.9 will behave correctly.
Great!

Sergiu Dumitriu-2 wrote
> Is there a way to have heading levels 3 or above also used as titel when the
> title field is empty?

Not unless you change the java code and recompile xwiki-core.
Would be great to add that to the preferences.

Thanks
hel.
semantic-web.hel.at
hel@hel.at
Reply | Threaded
Open this post in threaded view
|

Re: Special Characters in Titel

Niels Mayer
In reply to this post by Sergiu Dumitriu-2
On Thu, Jun 4, 2009 at 8:56 AM, Sergiu Dumitriu <[hidden email]> wrote:

> hel-o wrote:
> > I inserted Text "Text" in the title field of a page. When i edit the page
> > again the "Text" part disappears.
> > Tried other special characters (; @) and everything seems to work normal.
> So
> > its only the " character that makes problems.
>
> This was fixed recently, 1.9 will behave correctly.
>

If this bug was fixed, perhaps
http://jira.xwiki.org/jira/browse/XE-376should be updated?
XE-376 claimed it will be fixed at 2.0M1, so I was eagerly awaiting to 2.0
(Also reported as http://jira.xwiki.org/jira/browse/XE-336 )

*XWiki Enterprise <http://jira.xwiki.org/jira/browse/XE>*

>  characters entered as document title must be escaped or a cascade of bugs
> occur Created: 30/Jan/09 21:25   Updated: 19/May/09 14:45   *Component/s:* XWiki
> Enterprise Documents<http://jira.xwiki.org/jira/browse/XE/component/10387;jsessionid=D6C044B2762429BB47D3AB22E4F9BE71>
> *Affects Version/s:* 1.8 M1  *Fix Version/s:* 2.0 M1<http://jira.xwiki.org/jira/browse/XE/fixforversion/11077;jsessionid=D6C044B2762429BB47D3AB22E4F9BE71>
>   *Environment:*   « Hide <http://jira.xwiki.org/jira/browse/XE-376>
>  1.8M1
> Linux 2.6.27.12-170.2.5.fc10.x86_64 #1 SMP Wed Jan 21 01:33:24 EST 2009
> x86_64 x86_64 x86_64 GNU/Linux
> Apache Tomcat
> Sun Java(TM) SE Runtime Environment (build 1.6.0_11-b03)
> Sun Java HotSpot(TM) 64-Bit Server VM (build 11.0-b16, mixed mode)
>   Show » <http://jira.xwiki.org/jira/browse/XE-376>
>  1.8M1 Linux 2.6.27.12-170.2.5.fc10.x86_64 #1 SMP Wed Jan 21 01:33:24 EST
> 2009 x86_64 x86_64 x86_64 GNU/Linux Apache Tomcat Sun Java(TM) SE Runtime
> Environment (build 1.6.0_11-b03) Sun Java HotSpot(TM) 64-Bit Server VM
> (build 11.0-b16, mixed mode)
>    *Issue Links:*<http://jira.xwiki.org/jira/secure/ManageLinks.jspa?id=23479>
> *Duplicate*
>       This issue *is duplicated by*:     XE-336
> <http://jira.xwiki.org/jira/browse/XE-336;jsessionid=D6C044B2762429BB47D3AB22E4F9BE71>Creating pages with "__" in the Name gives Error   [image:
> Minor]  [image: Closed]
>  *keywords:* titles escape quote
>
>    *Description*  « Hide <http://jira.xwiki.org/jira/browse/XE-376>   Lets say I create a new document
> http://nielsmayer.com/xwiki/bin/edit/Timeline/foobar
>
>    - for Title, enter "this title has "quoted" words in it"
>    - click "save and view"
>    - the breadcrumbs show correct: "Timeline: this title has "quoted"
>    words in it" ; it also displays correct in browser title-bar.
>    - Click "Edit" on that document (
>    http://nielsmayer.com/xwiki/bin/edit/Timeline/foobar )
>    - Note the title is now "this title has " : the part after first
>    entered '"' is truncated
>    - Note that other scipts that use the title now fail, e.g.
>    http://nielsmayer.com/xwiki/bin/view/Timeline/TL1?action=xml&xpage=rdf(XML Parsing Error: not well-formed)
>    - Removing the '"' character from the title fixes the failing scripts,
>    and the title is preserved between saves and views.
>
> I was unable to use any combination of &quote; %22 or other means by which
> i thought i could escape a quote that needed to be in a title.
>
> Note that using those replacements worked, they just didn't display quotes,
> just the original codes. Backquoting was ignored...
>
>
>   *All<http://jira.xwiki.org/jira/browse/XE-376;jsessionid=D6C044B2762429BB47D3AB22E4F9BE71?page=com.atlassian.jira.plugin.system.issuetabpanels%3Aall-tabpanel>
> *    *Comments*    *Change History<http://jira.xwiki.org/jira/browse/XE-376;jsessionid=D6C044B2762429BB47D3AB22E4F9BE71?page=com.atlassian.jira.plugin.system.issuetabpanels%3Achangehistory-tabpanel>
> *      Sort Order: [image: Ascending order - Click to sort in descending
> order]<http://jira.xwiki.org/jira/browse/XE-376;jsessionid=D6C044B2762429BB47D3AB22E4F9BE71?actionOrder=desc>   [
> Permlink<http://jira.xwiki.org/jira/browse/XE-376?focusedCommentId=35475&page=com.atlassian.jira.plugin.system.issuetabpanels%3Acomment-tabpanel#action_35475>| «
> Hide <http://jira.xwiki.org/jira/browse/XE-376> ]
>  Niels Mayer, http://nielsmayer.com<http://jira.xwiki.org/jira/secure/ViewProfile.jspa?name=nielsmayer>added a comment - 31/Jan/09
> 03:28 - edited
> Note that using two single quotes together like this '' looks just like a "
> in proportional spacing. That's what I did here:
> http://nielsmayer.com/xwiki/bin/view/Timeline/WebHome
> perhaps that is a reasonable workaround for this problem. convert all "
> into ''
>    [ Show » <http://jira.xwiki.org/jira/browse/XE-376> ]
>  Niels Mayer, http://nielsmayer.com<http://jira.xwiki.org/jira/secure/ViewProfile.jspa?name=nielsmayer>added a comment - 31/Jan/09
> 03:28 - edited Note that using two single quotes together like this ''
> looks just like a " in proportional spacing. That's what I did here:
> http://nielsmayer.com/xwiki/bin/view/Timeline/WebHome perhaps that is a
> reasonable workaround for this problem. convert all " into ''
>
   *Description*     Lets say I create a new document
http://nielsmayer.com/xwiki/bin/edit/Timeline/foobar

   - for Title, enter "this title has "quoted" words in it"
   - click "save and view"
   - the breadcrumbs show correct: "Timeline: this title has "quoted" words
   in it" ; it also displays correct in browser title-bar.
   - Click "Edit" on that document (
   http://nielsmayer.com/xwiki/bin/edit/Timeline/foobar )
   - Note the title is now "this title has " : the part after first entered
   '"' is truncated
   - Note that other scipts that use the title now fail, e.g.
   http://nielsmayer.com/xwiki/bin/view/Timeline/TL1?action=xml&xpage=rdf(XML
Parsing Error: not well-formed)
   - Removing the '"' character from the title fixes the failing scripts,
   and the title is preserved between saves and views.

I was unable to use any combination of &quote; %22 or other means by which i
thought i could escape a quote that needed to be in a title. Note that using
those replacements worked, they just didn't display quotes, just the
original codes. Backquoting was ignored...
Show » <http://jira.xwiki.org/jira/browse/XE-376>


Niels
http://nielsmayer.com
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Special Characters in Titel

Sergiu Dumitriu-2
Niels Mayer wrote:

> On Thu, Jun 4, 2009 at 8:56 AM, Sergiu Dumitriu <[hidden email]> wrote:
>
>> hel-o wrote:
>>> I inserted Text "Text" in the title field of a page. When i edit the page
>>> again the "Text" part disappears.
>>> Tried other special characters (; @) and everything seems to work normal.
>> So
>>> its only the " character that makes problems.
>> This was fixed recently, 1.9 will behave correctly.
>>
>
> If this bug was fixed, perhaps
> http://jira.xwiki.org/jira/browse/XE-376should be updated?
> XE-376 claimed it will be fixed at 2.0M1, so I was eagerly awaiting to 2.0
> (Also reported as http://jira.xwiki.org/jira/browse/XE-336 )

XE-376 and XE-336 are more generic. The problem solved is about quotes
only. I'll have to look again to see how the __ problem can be solved.

--
Sergiu Dumitriu
http://purl.org/net/sergiu/
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users