Trouble with Backup - HELP

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Trouble with Backup - HELP

cburleso

So, I am having trouble figuring out how to use the new backup feature. Can someone throw me a bone?


Here is what I have done:

1. Upack the latest Groovy binaries to C:\groovy-1.0-jsr-03 (download from Groovy site)
2. Set GROOVY_HOME env variable to GROOVY_HOME that directory (C:\groovy-1.0-jsr-03)
3. add C:\groovy-1.0-jsr-03\bin to your PATH environment variable.
4. Put C:\Tomcat 5.5\webapps\xwiki\WEB-INF\lib\xwiki.jar; on CLASSPATH

5. Test on cmd: Type groovyConsole to make sure groovy works

5. Copy libs from xwiki  "backup" into lib folder of xwiki/web-inf
6. copy "hibernate.cfg.xml"  from backup to xwiki/web-inf/classes
7. copy import.groovy and export.groovy to webapps/xwiki/

Then, when I type the following on the CMD line, I get an error (see below)

C:\Documents and Settings\Administrator>cd C:\Tomcat 5.5\webapps\xwiki

C:\Tomcat 5.5\webapps\xwiki>groovy export.groovy
General error during class generation: No such class: XWikiContext in constructor call for class: xwiki.export.export. At [7:11] export.groovy

1 Error

The XWiki war I am using is from a build I did last night off of all the latest code from the Trunk branch. But why is my XWikiContext not recognized? I have even put xwiki.jar on the classpath.


??????


==================================
Cody Burleson




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws