WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

classic Classic list List threaded Threaded
22 messages Options
12
Reply | Threaded
Open this post in threaded view
|

WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

markblokpoel
Dear xwiki-community,

Thank you for helping me sofar, getting my XWiki up and running. This weekend I noticed that I could not login from my home computer. Here's what I've found out:

Loggin in from a computer within the same network works; logging in from a different network fails, resulting in the following error in xwiki.log:

2010-12-06 11:26:24,663 [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] WARN  xwiki.MyPersistentLoginManager  - Login cookie validation hash mismatch! Cookies have been tampered with

I have the following authentication settings in my xwiki.cfg:

xwiki.authentication.validationKey=<set to random string>
xwiki.authentication.encryptionKey=<set to random string>

xwiki.authentication.cookiepath=/xwiki
xwiki.authentication.logoutpage=(/|/[^/]+/|/wiki/[^/]+/)logout/*
xwiki.authentication.unauthorized_code=200

I'm running XWiki 2.6 on Tomcat6. Thanks for the help.

Best wishes,
Mark
Reply | Threaded
Open this post in threaded view
|

Re: WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

markblokpoel
Some extra information, it seems the users get's logged in:

2010-12-06 14:12:17,659 [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] INFO  xwiki.MyFormAuthenticator       - User XWiki.MarkBlokpoel has been logged-in

However soon after it logs the following:
2010-12-06 14:11:35,134 [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] WARN  xwiki.MyPersistentLoginManager  - Login cookie validation hash mismatch! Cookies have been tampered with
2010-12-06 14:11:35,141 [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] INFO  xwiki.MyPersistentLoginManager  - Login cookie is being deleted!

Maybe this helps to clarify what is happening.. Thanks.

Best,
Mark
Reply | Threaded
Open this post in threaded view
|

Re: WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

Ricardo Rodríguez
Hi, Mark

markblokpoel wrote:

> Some extra information, it seems the users get's logged in:
>
> 2010-12-06 14:12:17,659
> [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin]
> [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] INFO
> xwiki.MyFormAuthenticator       - User XWiki.MarkBlokpoel has been logged-in
> 2010-12-06 14:12:17,803
> [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin]
> [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] INFO
> xwiki.XWikiRightServiceImpl     - Access has been denied for
> (XWiki.XWikiGuest,XWiki.XWikiLogin,edit): global level (restricting right
> was found)
> 2010-12-06 14:12:17,815
> [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin]
> [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] INFO
> xwiki.XWikiRightServiceImpl     - Access has been denied for
> (XWiki.XWikiGuest,XWiki.XWikiLogin,admin): global level (restricting right
> was found)
> 2010-12-06 14:12:17,828
> [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin]
> [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] INFO
> xwiki.XWikiRightServiceImpl     - Access has been denied for
> (XWiki.XWikiGuest,XWiki.XWikiLogin,comment): global level (restricting right
> was found)
>
> However soon after it logs the following:
> 2010-12-06 14:11:35,134
> [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin]
> [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] WARN
> xwiki.MyPersistentLoginManager  - Login cookie validation hash mismatch!
> Cookies have been tampered with
> 2010-12-06 14:11:35,141
> [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin]
> [http://tcs.dcc.ru.nl/xwiki/bin/loginsubmit/XWiki/XWikiLogin] INFO
> xwiki.MyPersistentLoginManager  - Login cookie is being deleted!
>
> Maybe this helps to clarify what is happening.. Thanks.
>
> Best,
> Mark
>  

As far as I see, you have tweaked with the access rights of your
installation. It seems to me that somehow you are preventing access to
all and every user. Have you tried to access with the superadmin user?
Does it work?

Check this...

http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Configuration

If it was working before and no changes in the application server and/or
XWiki installation have been done, some misconfiguration of access
rights is the only thing I can figure out that could prevent you login
into your system.

HTH

--
Ricardo Rodríguez
CTO
eBioTIC.
Life Sciences, Data Modeling and Information Management Systems

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

markblokpoel
Hi Ricardo,

Thank you for your reply.

I setup/tested the xwiki at work (same network as the xwiki server). At that time everything was working perfectly, even more everything is still working perfectly when I use the xwiki from work. I just can't login from other places outside my work network. I tried the superadmin account, it also doesn't work from outside.. but does work on the same network.

This thing has me baffled.. Maybe I'll try a re-deployement of the wiki this afternoon and see if that works.

Best,
Mark

--
Radboud University Nijmegen
Reply | Threaded
Open this post in threaded view
|

Re: WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

Ricardo Rodríguez
Hi!

markblokpoel wrote:

> Hi Ricardo,
>
> Thank you for your reply.
>
> When I was setting up xwiki I was at work (same network as the xwiki
> server). At that time everything was working perfectly, even more everything
> is still working perfectly when I use the xwiki from work. I just can't
> login from other places outside my work network. I tried the superadmin
> account, it also doesn't work from outside.. but does work on the same
> network.
>
> This thing has me baffled.. Maybe I'll try a re-deployement of the wiki this
> afternoon and see if that works.
>
> Best,
> Mark
>
> --
> Radboud University Nijmegen
>  

But, have you ever been able to login from the outside world? If not,
thus, I'm not able to find an answer other than something in the
protection of your network is interfering the login process.

I've found this:

http://jira.xwiki.org/jira/browse/XWIKI-1071

It is not the same symptom, but at least it shows that things will go
wrong when a firework rejects cookies.

Another shot: are you using the same box when accessing from outside the
network where the server is installed? Are you sure cookies are enabled?
Yeap, this is too basic, but usually fail when checking this simple things!

Cheers,

Ricardo

--
Ricardo Rodríguez
CTO
eBioTIC.
Life Sciences, Data Modeling and Information Management Systems

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

Nevzat Guler
Hi Ricardo, Mark and company,

I discovered that, there are specific computers I can
connect from. Mark, can you try some other computer you have not used
before and see
if that connects? I still don't know what the issue is though..
Best regards, - Nevzat



On Tue, Dec 7, 2010 at 2:58 PM, Ricardo Rodriguez [eBioTIC.] <
[hidden email]> wrote:

> Hi!
>
> markblokpoel wrote:
> > Hi Ricardo,
> >
> > Thank you for your reply.
> >
> > When I was setting up xwiki I was at work (same network as the xwiki
> > server). At that time everything was working perfectly, even more
> everything
> > is still working perfectly when I use the xwiki from work. I just can't
> > login from other places outside my work network. I tried the superadmin
> > account, it also doesn't work from outside.. but does work on the same
> > network.
> >
> > This thing has me baffled.. Maybe I'll try a re-deployement of the wiki
> this
> > afternoon and see if that works.
> >
> > Best,
> > Mark
> >
> > --
> > Radboud University Nijmegen
> >
>
> But, have you ever been able to login from the outside world? If not,
> thus, I'm not able to find an answer other than something in the
> protection of your network is interfering the login process.
>
> I've found this:
>
> http://jira.xwiki.org/jira/browse/XWIKI-1071
>
> It is not the same symptom, but at least it shows that things will go
> wrong when a firework rejects cookies.
>
> Another shot: are you using the same box when accessing from outside the
> network where the server is installed? Are you sure cookies are enabled?
> Yeap, this is too basic, but usually fail when checking this simple things!
>
> Cheers,
>
> Ricardo
>
> --
> Ricardo Rodríguez
> CTO
> eBioTIC.
> Life Sciences, Data Modeling and Information Management Systems
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>



--
"Thinkers think and doers do. But until the thinkers do and the doers think,
progress will be just another word in the already overburdened vocabulary of
the talkers who talk."
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

Ricardo Rodríguez
Hi guys!

Nevzat Guler wrote:
> Hi Ricardo, Mark and company,
>
> I discovered that, there are specific computers I can
> connect from. Mark, can you try some other computer you have not used
> before and see
> if that connects? I still don't know what the issue is though..
> Best regards, - Nevzat
>
>  

I'm completely lost with this issue. Mark, Nevzat, are you both working
at the same location? Nevzat is running the server in troubles. Is this
correct? If yes, Mark, are you trying to login into the same server?
Well, I don't know if I could be of any help, but here two proposals:

1. Create an account for me and I try to login into your server from
several locations looking for a path.
2. I'll create an account for you in a couple of XWiki installations
here and you will try lo login into it both from the boxes able to login
into the server in troubles and those which are not able to log into it.
We'll record S.O. and internet browser on each of them.
3. Are you able to login into XWiki.org from any of those boxes?

HTH!

>
> On Tue, Dec 7, 2010 at 2:58 PM, Ricardo Rodriguez [eBioTIC.] <
> [hidden email]> wrote:
>
>  
>> Hi!
>>
>> markblokpoel wrote:
>>    
>>> Hi Ricardo,
>>>
>>> Thank you for your reply.
>>>
>>> When I was setting up xwiki I was at work (same network as the xwiki
>>> server). At that time everything was working perfectly, even more
>>>      
>> everything
>>    
>>> is still working perfectly when I use the xwiki from work. I just can't
>>> login from other places outside my work network. I tried the superadmin
>>> account, it also doesn't work from outside.. but does work on the same
>>> network.
>>>
>>> This thing has me baffled.. Maybe I'll try a re-deployement of the wiki
>>>      
>> this
>>    
>>> afternoon and see if that works.
>>>
>>> Best,
>>> Mark
>>>
>>> --
>>> Radboud University Nijmegen
>>>
>>>      
>> But, have you ever been able to login from the outside world? If not,
>> thus, I'm not able to find an answer other than something in the
>> protection of your network is interfering the login process.
>>
>> I've found this:
>>
>> http://jira.xwiki.org/jira/browse/XWIKI-1071
>>
>> It is not the same symptom, but at least it shows that things will go
>> wrong when a firework rejects cookies.
>>
>> Another shot: are you using the same box when accessing from outside the
>> network where the server is installed? Are you sure cookies are enabled?
>> Yeap, this is too basic, but usually fail when checking this simple things!
>>
>> Cheers,
>>
>> Ricardo
>>
>> --
>> Ricardo Rodríguez
>> CTO
>> eBioTIC.
>> Life Sciences, Data Modeling and Information Management Systems
>>
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>>    
>
>
>
>  

--
Ricardo Rodríguez
CTO
eBioTIC.
Life Sciences, Data Modeling and Information Management Systems

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

Nevzat Guler
Ricardo,
Mark and me are completely independent. Since only specific computers have
this problem, at least for my case, I think this is not (at least only) an
XWiki issue. For now, we can wait until  this problem occurs for more people
to understand the root of the problem. Unfortunately creating a guest
account is not possible because of other complications..
Best regards, - Nevzat

On Sat, Dec 11, 2010 at 5:05 PM, Ricardo Rodriguez [eBioTIC.] <
[hidden email]> wrote:

> Hi guys!
>
> Nevzat Guler wrote:
> > Hi Ricardo, Mark and company,
> >
> > I discovered that, there are specific computers I can
> > connect from. Mark, can you try some other computer you have not used
> > before and see
> > if that connects? I still don't know what the issue is though..
> > Best regards, - Nevzat
> >
> >
>
> I'm completely lost with this issue. Mark, Nevzat, are you both working
> at the same location? Nevzat is running the server in troubles. Is this
> correct? If yes, Mark, are you trying to login into the same server?
> Well, I don't know if I could be of any help, but here two proposals:
>
> 1. Create an account for me and I try to login into your server from
> several locations looking for a path.
> 2. I'll create an account for you in a couple of XWiki installations
> here and you will try lo login into it both from the boxes able to login
> into the server in troubles and those which are not able to log into it.
> We'll record S.O. and internet browser on each of them.
> 3. Are you able to login into XWiki.org from any of those boxes?
>
> HTH!
> >
> > On Tue, Dec 7, 2010 at 2:58 PM, Ricardo Rodriguez [eBioTIC.] <
> > [hidden email]> wrote:
> >
> >
> >> Hi!
> >>
> >> markblokpoel wrote:
> >>
> >>> Hi Ricardo,
> >>>
> >>> Thank you for your reply.
> >>>
> >>> When I was setting up xwiki I was at work (same network as the xwiki
> >>> server). At that time everything was working perfectly, even more
> >>>
> >> everything
> >>
> >>> is still working perfectly when I use the xwiki from work. I just can't
> >>> login from other places outside my work network. I tried the superadmin
> >>> account, it also doesn't work from outside.. but does work on the same
> >>> network.
> >>>
> >>> This thing has me baffled.. Maybe I'll try a re-deployement of the wiki
> >>>
> >> this
> >>
> >>> afternoon and see if that works.
> >>>
> >>> Best,
> >>> Mark
> >>>
> >>> --
> >>> Radboud University Nijmegen
> >>>
> >>>
> >> But, have you ever been able to login from the outside world? If not,
> >> thus, I'm not able to find an answer other than something in the
> >> protection of your network is interfering the login process.
> >>
> >> I've found this:
> >>
> >> http://jira.xwiki.org/jira/browse/XWIKI-1071
> >>
> >> It is not the same symptom, but at least it shows that things will go
> >> wrong when a firework rejects cookies.
> >>
> >> Another shot: are you using the same box when accessing from outside the
> >> network where the server is installed? Are you sure cookies are enabled?
> >> Yeap, this is too basic, but usually fail when checking this simple
> things!
> >>
> >> Cheers,
> >>
> >> Ricardo
> >>
> >> --
> >> Ricardo Rodríguez
> >> CTO
> >> eBioTIC.
> >> Life Sciences, Data Modeling and Information Management Systems
> >>
> >> _______________________________________________
> >> users mailing list
> >> [hidden email]
> >> http://lists.xwiki.org/mailman/listinfo/users
> >>
> >>
> >
> >
> >
> >
>
> --
> Ricardo Rodríguez
> CTO
> eBioTIC.
> Life Sciences, Data Modeling and Information Management Systems
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>



--
"Thinkers think and doers do. But until the thinkers do and the doers think,
progress will be just another word in the already overburdened vocabulary of
the talkers who talk."
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

Andreas Schaefer
Hi

I ran into the same problem and it was persistent on all computers using Safari. Using Firefox I was able to log in. Hopefully this hint helps.

-Andy

On Dec 13, 2010, at 12:03 PM, Nevzat Guler wrote:

> Ricardo,
> Mark and me are completely independent. Since only specific computers have
> this problem, at least for my case, I think this is not (at least only) an
> XWiki issue. For now, we can wait until  this problem occurs for more people
> to understand the root of the problem. Unfortunately creating a guest
> account is not possible because of other complications..
> Best regards, - Nevzat
>
> On Sat, Dec 11, 2010 at 5:05 PM, Ricardo Rodriguez [eBioTIC.] <
> [hidden email]> wrote:
>
>> Hi guys!
>>
>> Nevzat Guler wrote:
>>> Hi Ricardo, Mark and company,
>>>
>>> I discovered that, there are specific computers I can
>>> connect from. Mark, can you try some other computer you have not used
>>> before and see
>>> if that connects? I still don't know what the issue is though..
>>> Best regards, - Nevzat
>>>
>>>
>>
>> I'm completely lost with this issue. Mark, Nevzat, are you both working
>> at the same location? Nevzat is running the server in troubles. Is this
>> correct? If yes, Mark, are you trying to login into the same server?
>> Well, I don't know if I could be of any help, but here two proposals:
>>
>> 1. Create an account for me and I try to login into your server from
>> several locations looking for a path.
>> 2. I'll create an account for you in a couple of XWiki installations
>> here and you will try lo login into it both from the boxes able to login
>> into the server in troubles and those which are not able to log into it.
>> We'll record S.O. and internet browser on each of them.
>> 3. Are you able to login into XWiki.org from any of those boxes?
>>
>> HTH!
>>>
>>> On Tue, Dec 7, 2010 at 2:58 PM, Ricardo Rodriguez [eBioTIC.] <
>>> [hidden email]> wrote:
>>>
>>>
>>>> Hi!
>>>>
>>>> markblokpoel wrote:
>>>>
>>>>> Hi Ricardo,
>>>>>
>>>>> Thank you for your reply.
>>>>>
>>>>> When I was setting up xwiki I was at work (same network as the xwiki
>>>>> server). At that time everything was working perfectly, even more
>>>>>
>>>> everything
>>>>
>>>>> is still working perfectly when I use the xwiki from work. I just can't
>>>>> login from other places outside my work network. I tried the superadmin
>>>>> account, it also doesn't work from outside.. but does work on the same
>>>>> network.
>>>>>
>>>>> This thing has me baffled.. Maybe I'll try a re-deployement of the wiki
>>>>>
>>>> this
>>>>
>>>>> afternoon and see if that works.
>>>>>
>>>>> Best,
>>>>> Mark
>>>>>
>>>>> --
>>>>> Radboud University Nijmegen
>>>>>
>>>>>
>>>> But, have you ever been able to login from the outside world? If not,
>>>> thus, I'm not able to find an answer other than something in the
>>>> protection of your network is interfering the login process.
>>>>
>>>> I've found this:
>>>>
>>>> http://jira.xwiki.org/jira/browse/XWIKI-1071
>>>>
>>>> It is not the same symptom, but at least it shows that things will go
>>>> wrong when a firework rejects cookies.
>>>>
>>>> Another shot: are you using the same box when accessing from outside the
>>>> network where the server is installed? Are you sure cookies are enabled?
>>>> Yeap, this is too basic, but usually fail when checking this simple
>> things!
>>>>
>>>> Cheers,
>>>>
>>>> Ricardo
>>>>
>>>> --
>>>> Ricardo Rodríguez
>>>> CTO
>>>> eBioTIC.
>>>> Life Sciences, Data Modeling and Information Management Systems
>>>>
>>>> _______________________________________________
>>>> users mailing list
>>>> [hidden email]
>>>> http://lists.xwiki.org/mailman/listinfo/users
>>>>
>>>>
>>>
>>>
>>>
>>>
>>
>> --
>> Ricardo Rodríguez
>> CTO
>> eBioTIC.
>> Life Sciences, Data Modeling and Information Management Systems
>>
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>
>
>
> --
> "Thinkers think and doers do. But until the thinkers do and the doers think,
> progress will be just another word in the already overburdened vocabulary of
> the talkers who talk."
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

markblokpoel
Hi Andy,

Sorry for not replying sooner, I have not been able to get back to our wiki project for a while.

I can confirm your finding and can also login using Firefox and Chrome (both for OS X), but not with Safari. Safari only works from certain locations.

I have noticed that the (dns)domainname of the server is socsci.ru.nl, which is the same as the machines from which I can login using Safari. Might this suggest that validating the cookie hashes can go wrong on (dns)domainname? Can other you guys check whether they have the same thing going on?

Best,
Mark
Reply | Threaded
Open this post in threaded view
|

Re: WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

markblokpoel

Hello all,

After fiddling around some more, I'm a bit more convinced this problem is
Safari specific. Can someone else comment on this? I'm not sure on how to
debug this further, because I cannot compare the cookies that reach the
servlet. Help is greatly appreciated. :)

Best,

Mark

--
View this message in context: http://xwiki.475771.n2.nabble.com/WARN-xwiki-MyPersistentLoginManager-Login-cookie-validation-hash-mismatch-Cookies-have-been-tamperedh-tp5807284p5906365.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WARN xwiki.MyPersistentLoginManager - Login cookie validation hash mismatch! Cookies have been tampered with

markblokpoel
In reply to this post by markblokpoel
Hello all,

After fiddling around some more, I'm a bit more convinced this problem is Safari specific. Can someone else comment on this? I'm not sure on how to debug this further, because I cannot compare the cookies that reach the servlet. Help is greatly appreciated. :)

Best,

Mark
Reply | Threaded
Open this post in threaded view
|

Cannot log in using Safari

markblokpoel
Sorry for double posting my previous message, at first staying pending for two days..

Since a new version of XWiki came out (2.7) I thought I'd see if this issue still arises, and alas it does. I still cannot log on to xwiki in Safari (5 nor iOS) from different domainspaces. I am very curious if other people are experiencing this problem, as I would like xwiki to work in the browsers my teammembers already use. Because as it is, we cannot use xwiki and are hard-pressing finding alternative solutions to our digital collaboration needs.

Please as me if more information on my configuration, etc is required (in addition to the information already in this thread), I will be more than happy to supply.

Best,
Mark
Reply | Threaded
Open this post in threaded view
|

Re: Cannot log in using Safari

markblokpoel
Reply | Threaded
Open this post in threaded view
|

Re: Cannot log in using Safari

markblokpoel
Dear Xwiki community,

This is my final attempt to ask for help. Even after all the problems I had installing Xwiki, I am still enthused to work with your software, even more so because I see the vigilance of the community thinking of new ways to improve the development and features of Xwiki. However, it pains me that my issue is not taken seriously.

I believe I have a very common setup (Ubuntu+Apache+Tomcat+MySQL) for opensource web-software, and cannot seem to get Xwiki to work. Besides myself you can read in this thread that others have experienced the same problems concerning logging in with Safari. I am not scared nor lazy of getting my hands dirty, but without some guidance from experienced users/developers I am afraid I am stuck..

Please let me know how, together, we can get to the bottom of this. Thank you.

Best regards,
Mark

Reply | Threaded
Open this post in threaded view
|

Re: Cannot log in using Safari

Ecaterina Moraru (Valica)
Hi Mark,

I tried yesterday and I can't log in either. Can you make a JIRA issue about
this?
Chrome browser (same engine as Safari) has no problem with the logging so it
must be something minor that we can fix (plus is was working until this
version).
Right now everybody is busy with 3 releases so we will look at this issue
soon.

Thanks,
Caty

On Wed, Jan 19, 2011 at 11:17, markblokpoel <[hidden email]> wrote:

>
> Dear Xwiki community,
>
> This is my final attempt to ask for help. Even after all the problems I had
> installing Xwiki, I am still enthused to work with your software, even more
> so because I see the vigilance of the community thinking of new ways to
> improve the development and features of Xwiki. However, it pains me that my
> issue is not taken seriously.
>
> I believe I have a very common setup (Ubuntu+Apache+Tomcat+MySQL) for
> opensource web-software, and cannot seem to get Xwiki to work. Besides
> myself you can read in this thread that others have experienced the same
> problems concerning logging in with Safari. I am not scared nor lazy of
> getting my hands dirty, but without some guidance from experienced
> users/developers I am afraid I am stuck..
>
> Please let me know how, together, we can get to the bottom of this. Thank
> you.
>
> Best regards,
> Mark
>
>
> --
> View this message in context:
> http://xwiki.475771.n2.nabble.com/WARN-xwiki-MyPersistentLoginManager-Login-cookie-validation-hash-mismatch-Cookies-have-been-tamperedh-tp5807284p5938816.html
> Sent from the XWiki- Users mailing list archive at Nabble.com.
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot log in using Safari

markblokpoel
Hi Caty,

Thank you very much for your reply. I have filed a bug report at: http://jira.xwiki.org/jira/browse/XE-808, is that correct? Good luck with the release for version 3, and I'm looking forward to fixing this bug.

Best,
Mark
Reply | Threaded
Open this post in threaded view
|

Re: Cannot log in using Safari

Ecaterina Moraru (Valica)
Hi,

The bug is filled correct.

Thanks,
Caty

On Wed, Jan 19, 2011 at 11:42, markblokpoel <[hidden email]> wrote:

>
> Hi Caty,
>
> Thank you very much for your reply. I have filed a bug report at:
> http://jira.xwiki.org/jira/browse/XE-808, is that correct? Good luck with
> the release for version 3, and I'm looking forward to fixing this bug.
>
> Best,
> Mark
> --
> View this message in context:
> http://xwiki.475771.n2.nabble.com/WARN-xwiki-MyPersistentLoginManager-Login-cookie-validation-hash-mismatch-Cookies-have-been-tamperedh-tp5807284p5938896.html
> Sent from the XWiki- Users mailing list archive at Nabble.com.
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot log in using Safari

Ecaterina Moraru (Valica)
Hi Mark,

Until someone will fix it, I found a way to get logged in.

When you press "Log-in" you will be redirected to
http://localhost:8080/xwiki/bin/login/XWiki/XWikiLogin?xredirect=http%3A%2F%2Flocalhost%3A8080%2Fxwiki%2Fbin%2Fview%2FMain%2F

remove the xredirect param and let just
http://localhost:8080/xwiki/bin/login/XWiki/XWikiLogin

enter user:Admin, pass:admin and CHECK "Remember me on this computer"
and you will be able to login.

Hope this helps,
Caty

On Wed, Jan 19, 2011 at 11:52, Ecaterina Moraru (Valica)
<[hidden email]>wrote:

> Hi,
>
> The bug is filled correct.
>
> Thanks,
> Caty
>
>
> On Wed, Jan 19, 2011 at 11:42, markblokpoel <[hidden email]>wrote:
>
>>
>> Hi Caty,
>>
>> Thank you very much for your reply. I have filed a bug report at:
>> http://jira.xwiki.org/jira/browse/XE-808, is that correct? Good luck with
>> the release for version 3, and I'm looking forward to fixing this bug.
>>
>> Best,
>> Mark
>> --
>> View this message in context:
>> http://xwiki.475771.n2.nabble.com/WARN-xwiki-MyPersistentLoginManager-Login-cookie-validation-hash-mismatch-Cookies-have-been-tamperedh-tp5807284p5938896.html
>> Sent from the XWiki- Users mailing list archive at Nabble.com.
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Cannot log in using Safari

Sergiu Dumitriu-2
In reply to this post by markblokpoel
On Wed, Jan 19, 2011 at 10:17, markblokpoel <[hidden email]> wrote:

>
> Dear Xwiki community,
>
> This is my final attempt to ask for help. Even after all the problems I had
> installing Xwiki, I am still enthused to work with your software, even more
> so because I see the vigilance of the community thinking of new ways to
> improve the development and features of Xwiki. However, it pains me that my
> issue is not taken seriously.
>
> I believe I have a very common setup (Ubuntu+Apache+Tomcat+MySQL) for
> opensource web-software, and cannot seem to get Xwiki to work. Besides
> myself you can read in this thread that others have experienced the same
> problems concerning logging in with Safari. I am not scared nor lazy of
> getting my hands dirty, but without some guidance from experienced
> users/developers I am afraid I am stuck..
>
> Please let me know how, together, we can get to the bottom of this. Thank
> you.


I think I fixed the issue (to appear in the next releases). Could you
check if it works by downloading a snapshot build from
http://maven.xwiki.org/snapshots/org/xwiki/enterprise/xwiki-enterprise-jetty-hsqldb/
and see if login works with and without "remember me" checked?

--
http://purl.org/net/sergiu
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
12