WYSIWYG 2.0 - why rel="__blank"

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

WYSIWYG 2.0 - why rel="__blank"

Reto Hotz
Hi,

I created an external link with the new wysiwyg editor (1.8.3). After
that, I switch to wiki editor and the link looks like this:

[[link>>xwiki:Sandbox.WebHome||rel="__blank"]]

But rel="__blank" is not defined in the Syntax 2.0 (according to
http://platform.xwiki.org/xwiki/bin/view/Main/XWikiSyntax).

Shouldn't it be
[[link>>xwiki:Sandbox.WebHome||target="_blank"]] ?


Thanks
Reto
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WYSIWYG 2.0 - why rel="__blank"

vmassol
Administrator
Hi Reto,

On May 19, 2009, at 8:30 AM, Reto Hotz wrote:

> Hi,
>
> I created an external link with the new wysiwyg editor (1.8.3). After
> that, I switch to wiki editor and the link looks like this:
>
> [[link>>xwiki:Sandbox.WebHome||rel="__blank"]]
>
> But rel="__blank" is not defined in the Syntax 2.0 (according to
> http://platform.xwiki.org/xwiki/bin/view/Main/XWikiSyntax).
>
> Shouldn't it be
> [[link>>xwiki:Sandbox.WebHome||target="_blank"]] ?

target is not a valid XHTML attribute and since we generate valid  
XHMTL we couldn't use it. The XHTML way is to use "rel" and have a  
javascript that adds the bit to open the link in a new page.

The double underscore is simply to differentiate the rel value from  
any other valid value (I don't remember exactly the details).

is it not working?

Thanks
-Vincent

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WYSIWYG 2.0 - why rel="__blank"

Reto Hotz
Hi Vincent,

Vincent Massol wrote:
> target is not a valid XHTML attribute and since we generate valid  
> XHMTL we couldn't use it. The XHTML way is to use "rel" and have a  
> javascript that adds the bit to open the link in a new page.

I understand that target is not a valid xhtml attribute.
But I still don't get it. What has this to do with the generated xwiki
code? Why does the wysiwyg editor not generate the same xwiki code as
described in the Syntax?

Either both should have rel="__blank" or both should have target="_blank"


Another example: When I use it the other way around:
1. I create the link in xwiki editor (with target="_blank")
2. then I switch to WYSYWIG editor and edit this link --> The WYSIWYG
editor loses the "Open link in new window" checkbox and I have to check
it again.

> is it not working?

It is working fine. But it's confusing me. :)

Greetings
Reto

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WYSIWYG 2.0 - why rel="__blank"

hel-o
Hi,

Reto Hotz wrote
Another example: When I use it the other way around:
1. I create the link in xwiki editor (with target="_blank")
2. then I switch to WYSYWIG editor and edit this link --> The WYSIWYG
editor loses the "Open link in new window" checkbox and I have to check
it again.
And when you take a look at the wiki code then you get:

[[link>>xwiki:Sandbox.WebHome||rel="__blank" target="_blank"]]

But you are right, the XWiki Syntax page should be changed.

hel.

semantic-web.hel.at
hel@hel.at
Reply | Threaded
Open this post in threaded view
|

Re: WYSIWYG 2.0 - why rel="__blank"

vmassol
Administrator

On May 19, 2009, at 9:40 AM, hel-o wrote:

>
> Hi,
>
>
> Reto Hotz wrote:
>>
>>
>> Another example: When I use it the other way around:
>> 1. I create the link in xwiki editor (with target="_blank")
>> 2. then I switch to WYSYWIG editor and edit this link --> The WYSIWYG
>> editor loses the "Open link in new window" checkbox and I have to  
>> check
>> it again.
>>
>>
>
> And when you take a look at the wiki code then you get:
>
> [[link>>xwiki:Sandbox.WebHome||rel="__blank" target="_blank"]]
>
> But you are right, the XWiki Syntax page should be changed.

Fixed.

Thanks
-Vincent

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WYSIWYG 2.0 - why rel="__blank"

Reto Hotz
Hi,

Vincent Massol wrote:
> Fixed.

I'm fine with that. Thanks for the clarification.

Greetings
Reto

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users