WYSIWYG editor not loading after upgrade to 8.2.1

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

WYSIWYG editor not loading after upgrade to 8.2.1

simmsj
I upgraded from 8.1 to 8.2.1 this afternoon and the WYSIWYG editor just spins and never loads. I ran into this issue earlier and it was an issue using NGINX as an SSL reverse proxy which was resolved by changing the NGINX config (http://lists.xwiki.org/pipermail/users/2016-July/033360.html). The NGINX config wasn't changed during the upgrade so this seems to be something else. I've checked the logs and nothing stands out as being related.

I do get this in my JavaScript console:
[Autosave feature] Required class missing: XWiki.actionButtons.AjaxSaveAndContinue
require.min.js?r=1:34

GET https://wiki.sprague.local/webjars/wiki%3Axwiki/xwiki-platform-tree-webjar/8.1/require-config.min.js?evaluate=true
g.load @ require.min.js?r=1:34
load @ require.min.js?r=1:29
load @ require.min.js?r=1:17
fetch @ require.min.js?r=1:17
check @ require.min.js?r=1:17
enable @ require.min.js?r=1:23
enable @ require.min.js?r=1:27
(anonymous function) @ require.min.js?r=1:22
(anonymous function) @ require.min.js?r=1:7
y @ require.min.js?r=1:6
enable @ require.min.js?r=1:21
init @ require.min.js?r=1:16
(anonymous function) @ require.min.js?r=1:26
require.min.js?r=1:7

Uncaught Error: Script error for "/webjars/wiki%3Axwiki/xwiki-platform-tree-webjar/8.1/require-config.min.js?evaluate=true"
http://requirejs.org/docs/errors.html#scripterror
F @ require.min.js?r=1:7
onScriptError @ require.min.js?r=1:30

Is this a known issue or are there any recommendations for resolving this?

Thanks,
Jared
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WYSIWYG editor not loading after upgrade to 8.2.1

Julio Brum
May have no relation to your problem, but I had a very strange problem with the version 7.4.4 editor. The editor did not load for some users (just spins). For each user with problem: With Google Chrome, edited any page, typed F12. Strange solution, but it worked. I did not try to understand why it solved the problem...
But your problem should be another...
Best regards,
Julio

      De: Jared Simms <[hidden email]>
 Para: "[hidden email]" <[hidden email]>
 Enviadas: Segunda-feira, 26 de Setembro de 2016 18:47
 Assunto: [xwiki-users] WYSIWYG editor not loading after upgrade to 8.2.1
   
I upgraded from 8.1 to 8.2.1 this afternoon and the WYSIWYG editor just spins and never loads. I ran into this issue earlier and it was an issue using NGINX as an SSL reverse proxy which was resolved by changing the NGINX config (http://lists.xwiki.org/pipermail/users/2016-July/033360.html). The NGINX config wasn't changed during the upgrade so this seems to be something else. I've checked the logs and nothing stands out as being related.

I do get this in my JavaScript console:
[Autosave feature] Required class missing: XWiki.actionButtons.AjaxSaveAndContinue
require.min.js?r=1:34

GET https://wiki.sprague.local/webjars/wiki%3Axwiki/xwiki-platform-tree-webjar/8.1/require-config.min.js?evaluate=true
g.load @ require.min.js?r=1:34
load @ require.min.js?r=1:29
load @ require.min.js?r=1:17
fetch @ require.min.js?r=1:17
check @ require.min.js?r=1:17
enable @ require.min.js?r=1:23
enable @ require.min.js?r=1:27
(anonymous function) @ require.min.js?r=1:22
(anonymous function) @ require.min.js?r=1:7
y @ require.min.js?r=1:6
enable @ require.min.js?r=1:21
init @ require.min.js?r=1:16
(anonymous function) @ require.min.js?r=1:26
require.min.js?r=1:7

Uncaught Error: Script error for "/webjars/wiki%3Axwiki/xwiki-platform-tree-webjar/8.1/require-config.min.js?evaluate=true"
http://requirejs.org/docs/errors.html#scripterror
F @ require.min.js?r=1:7
onScriptError @ require.min.js?r=1:30

Is this a known issue or are there any recommendations for resolving this?

Thanks,
Jared
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users


   
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WYSIWYG editor not loading after upgrade to 8.2.1

Marius Dumitru Florea
In reply to this post by simmsj
Have you tried to clear your browser's cache? autosave.js has been modified
between XWiki 8.1 and 8.2.1 and you may have the older version cached in
your browser. I know, asking your users to clear the browser cache is not
nice, we have this issue to fix http://jira.xwiki.org/browse/XWIKI-6073 .

Hope this helps,
Marius

On Tue, Sep 27, 2016 at 12:47 AM, Jared Simms <[hidden email]> wrote:

> I upgraded from 8.1 to 8.2.1 this afternoon and the WYSIWYG editor just
> spins and never loads. I ran into this issue earlier and it was an issue
> using NGINX as an SSL reverse proxy which was resolved by changing the
> NGINX config (http://lists.xwiki.org/pipermail/users/2016-July/033360.html).
> The NGINX config wasn't changed during the upgrade so this seems to be
> something else. I've checked the logs and nothing stands out as being
> related.
>
> I do get this in my JavaScript console:
> [Autosave feature] Required class missing: XWiki.actionButtons.AjaxSaveAn
> dContinue
> require.min.js?r=1:34
>
> GET https://wiki.sprague.local/webjars/wiki%3Axwiki/xwiki-platfo
> rm-tree-webjar/8.1/require-config.min.js?evaluate=true
> g.load @ require.min.js?r=1:34
> load @ require.min.js?r=1:29
> load @ require.min.js?r=1:17
> fetch @ require.min.js?r=1:17
> check @ require.min.js?r=1:17
> enable @ require.min.js?r=1:23
> enable @ require.min.js?r=1:27
> (anonymous function) @ require.min.js?r=1:22
> (anonymous function) @ require.min.js?r=1:7
> y @ require.min.js?r=1:6
> enable @ require.min.js?r=1:21
> init @ require.min.js?r=1:16
> (anonymous function) @ require.min.js?r=1:26
> require.min.js?r=1:7
>
> Uncaught Error: Script error for "/webjars/wiki%3Axwiki/xwiki-p
> latform-tree-webjar/8.1/require-config.min.js?evaluate=true"
> http://requirejs.org/docs/errors.html#scripterror
> F @ require.min.js?r=1:7
> onScriptError @ require.min.js?r=1:30
>
> Is this a known issue or are there any recommendations for resolving this?
>
> Thanks,
> Jared
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: WYSIWYG editor not loading after upgrade to 8.2.1

simmsj
Clearing the browser cache worked. The fix isn't ideal, but I upgraded a clone and there's no urgency to upgrade the production instance so I can wait for the issue to be resolved.

Thanks for the help.

 - Jared
Reply | Threaded
Open this post in threaded view
|

Re: WYSIWYG editor not loading after upgrade to 8.2.1

mahomed
We had this issue with almost every upgrade. Just getting users to press F5 when they get the spinning editor has usually solved it.


Kind regards,




Mahomed Hussein
Custodian Data Centre
Email: [hidden email]
http://www.CustodianDC.com

-----Original Message-----
From: users [mailto:[hidden email]] On Behalf Of simmsj
Sent: 27 September 2016 13:50
To: [hidden email]
Subject: Re: [xwiki-users] WYSIWYG editor not loading after upgrade to 8.2.1

Clearing the browser cache worked. The fix isn't ideal, but I upgraded a clone and there's no urgency to upgrade the production instance so I can wait for the issue to be resolved.

Thanks for the help.

 - Jared



--
View this message in context: http://xwiki.475771.n2.nabble.com/WYSIWYG-editor-not-loading-after-upgrade-to-8-2-1-tp7601398p7601410.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users