Wiki page seems to have two parents?

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Wiki page seems to have two parents?

Hamster
To all,

Something strange is going on with one page in our Wiki. The page has been created by importing a Word document (.docx), but after the import, the page seems to have two parents.

The page shows up in the "WebHome" of the space, but also under the "parent page" where the document was created in the first place. Furthermore, when editing the page and looking at the "parent" property, it seems to be empty (or refering to itself).

Has anyone encountered this before?

Also, when I delete the page it will be "moved" to the recycle bin, but permanently deleting the page from the recycle bin creates a new blank page with the same name...
Reply | Threaded
Open this post in threaded view
|

Re: Wiki page seems to have two parents?

Marius Dumitru Florea
On Thu, Jul 17, 2014 at 9:49 AM, Hamster <[hidden email]> wrote:
> To all,
>
> Something strange is going on with one page in our Wiki. The page has been
> created by importing a Word document (.docx), but after the import, the page
> seems to have two parents.
>
> The page shows up in the "WebHome" of the space, but also under the "parent
> page" where the document was created in the first place.

> Furthermore, when
> editing the page and looking at the "parent" property, it seems to be empty
> (or refering to itself).

If the parent text input field is empty then it means the page has not
parent. As for what the space home page and the "parent page" are
displaying, you need to check those pages, see their code. They don't
use the parent field for sure. The space home page may simply list all
pages from that space. For the "parent page", I've no idea.

>
> Has anyone encountered this before?
>
> Also, when I delete the page it will be "moved" to the recycle bin, but
> permanently deleting the page from the recycle bin creates a new blank page
> with the same name...
>
>
>
> --
> View this message in context: http://xwiki.475771.n2.nabble.com/Wiki-page-seems-to-have-two-parents-tp7591348.html
> Sent from the XWiki- Users mailing list archive at Nabble.com.
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Wiki page seems to have two parents?

Hamster
Hi Marius,

Thanks for your reply.

Even if I set the page parent to something else, that change is not saved, and the page then refers to itself as its parent.

And what about the "permanent delete" issue? If I delete a page, you will get a page saying that the page has been moved to the recyclebin. That page offer two options, (1) restore or (2) remove. If I select option 2, the page should be removed permanently, but instead a new blank page is created.

Any insight into this matter is appreciated, as I have no clue what is going on!

Thanks.
Reply | Threaded
Open this post in threaded view
|

Re: Wiki page seems to have two parents?

jerem
Hi,


2014-08-12 14:28 GMT+02:00 Hamster <[hidden email]>:

> Hi Marius,
>
> Thanks for your reply.
>
> Even if I set the page parent to something else, that change is not saved,
> and the page then refers to itself as its parent.
>
> And what about the "permanent delete" issue? If I delete a page, you will
> get a page saying that the page has been moved to the recyclebin. That page
> offer two options, (1) restore or (2) remove. If I select option 2, the
> page
> should be removed permanently, but instead a new blank page is created.
>

Normally in this case, you stay on the same page url, so on a page that
does not exist anymore.
So you should normally be proposed with a page saying "The requested
document could not be found. You can edit this page
<http://r-wikiggs.gemalto.com/xwiki/bin/create/Main/TOTOTO> to create it"
This is not a blank page, until you click on "edit this page" then save it.
If there really is a blank page created after you removed it, then it is
weird ...


>
> Any insight into this matter is appreciated, as I have no clue what is
> going
> on!
>
> Thanks.
>
>
>
> --
> View this message in context:
> http://xwiki.475771.n2.nabble.com/Wiki-page-seems-to-have-two-parents-tp7591348p7591639.html
> Sent from the XWiki- Users mailing list archive at Nabble.com.
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Wiki page seems to have two parents?

Hamster
In that case, I am in the "weird section" :-)

Here's what I am doing:

1) Create a new page, type some text, hit "Save & View". The page is created in the correct space, with the correct parent.
2) I edit the page, use "Import"-->"Office Document" and import a small docx document. The import is succesful, but as soon as the import is done, the parent of the page is "erased".
3) If I delete the page, it will be moved to the recycle bin, I then have the option to "restore" or "delete". I hit "delete" --> I will get a warning that this can't be undone (which is what I expect), but if I hit "ok", I don't get the "The requested document could not be found. You can edit this page XXX to create it", but XWiki creates a new blank page instead.

So something weird is going on when using the Import Office Document (in the WYSIWYG editor).
Reply | Threaded
Open this post in threaded view
|

Re: Wiki page seems to have two parents?

Roman Muntyanu
It's rather that there are 2 translations of the page with different parents.
I've been experiencing similar issue.

http://jira.xwiki.org/browse/XWIKI-6205

-----Original Message-----
From: users [mailto:[hidden email]] On Behalf Of Hamster
Sent: Wednesday, August 13, 2014 10:11 AM
To: [hidden email]
Subject: Re: [xwiki-users] Wiki page seems to have two parents?

In that case, I am in the "weird section" :-)

Here's what I am doing:

1) Create a new page, type some text, hit "Save & View". The page is created in the correct space, with the correct parent.
2) I edit the page, use "Import"-->"Office Document" and import a small docx document. The import is succesful, but as soon as the import is done, the parent of the page is "erased".
3) If I delete the page, it will be moved to the recycle bin, I then have the option to "restore" or "delete". I hit "delete" --> I will get a warning that this can't be undone (which is what I expect), but if I hit "ok", I don't get the "The requested document could not be found. You can edit this page XXX to create it", but XWiki creates a new blank page instead.

So something weird is going on when using the Import Office Document (in the WYSIWYG editor).




--
View this message in context: http://xwiki.475771.n2.nabble.com/Wiki-page-seems-to-have-two-parents-tp7591348p7591644.html
Sent from the XWiki- Users mailing list archive at Nabble.com.
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Wiki page seems to have two parents?

Hamster
Reply | Threaded
Open this post in threaded view
|

Re: Wiki page seems to have two parents?

Hamster
Any comments/insight from the devs on these issues?
Reply | Threaded
Open this post in threaded view
|

Re: Wiki page seems to have two parents?

Marius Dumitru Florea
Export the page as XAR and look inside the package. If it has more
than one XML file then it means the page has translations. Look inside
each XML file for the "language" and "defaultLanguage" fields. For
translations, the "language" should be the translation language
(should match the file name suffix) and the "defaultLanguage" should
be default language of the wiki when that page was created (probably
"en"). For the original document, the "language" field should be
empty, while the "defaultTranslation" field should have the value that
appears in the rest of the translations.

Hope this helps,
Marius

On Tue, Aug 19, 2014 at 2:37 PM, Hamster <[hidden email]> wrote:

> Any comments/insight from the devs on these issues?
>
>
>
> --
> View this message in context: http://xwiki.475771.n2.nabble.com/Wiki-page-seems-to-have-two-parents-tp7591348p7591749.html
> Sent from the XWiki- Users mailing list archive at Nabble.com.
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Wiki page seems to have two parents?

Marius Dumitru Florea
Check also the "title" field for all the XML files in the XAR package.

On Wed, Aug 20, 2014 at 4:24 PM, Marius Dumitru Florea
<[hidden email]> wrote:

> Export the page as XAR and look inside the package. If it has more
> than one XML file then it means the page has translations. Look inside
> each XML file for the "language" and "defaultLanguage" fields. For
> translations, the "language" should be the translation language
> (should match the file name suffix) and the "defaultLanguage" should
> be default language of the wiki when that page was created (probably
> "en"). For the original document, the "language" field should be
> empty, while the "defaultTranslation" field should have the value that
> appears in the rest of the translations.
>
> Hope this helps,
> Marius
>
> On Tue, Aug 19, 2014 at 2:37 PM, Hamster <[hidden email]> wrote:
>> Any comments/insight from the devs on these issues?
>>
>>
>>
>> --
>> View this message in context: http://xwiki.475771.n2.nabble.com/Wiki-page-seems-to-have-two-parents-tp7591348p7591749.html
>> Sent from the XWiki- Users mailing list archive at Nabble.com.
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users