XWiki 6, Java 7 and Red-Hat

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

XWiki 6, Java 7 and Red-Hat

jerem
Dear community,

I tried to migrate a test xwiki instance to 6.x on my red-hat linux server,
and encountered a (fatal) issue: as it requires java 7, in turn, it
requires RHEL >= 5.5 (and I'm on an old RHEL 4.6) due to glibc (thank you,
java...).
Upgrading red-hat on this server is not an option for now, even if it's way
too old I agree, so I hope I'll be able to do this upgrade one day ... :/

But my point is, do you think interesting to add this information in
installation guide somewhere ? [1]
Maybe there's a better place, or maybe it's not needed at all I don't
know... There's already info about java 7 obviously, I'm talking about
specific impact for red-hat.

WDYT ?

Best regards,
Jeremie


[1] - http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Installation
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: XWiki 6, Java 7 and Red-Hat

vmassol
Administrator
Hi Jeremie,

On 31 Oct 2014 at 16:34:03, Jeremie BOUSQUET ([hidden email](mailto:[hidden email])) wrote:

> Dear community,
>  
> I tried to migrate a test xwiki instance to 6.x on my red-hat linux server,
> and encountered a (fatal) issue: as it requires java 7, in turn, it
> requires RHEL >= 5.5 (and I'm on an old RHEL 4.6) due to glibc (thank you,
> java...).
> Upgrading red-hat on this server is not an option for now, even if it's way
> too old I agree, so I hope I'll be able to do this upgrade one day ... :/

I hope too :)

> But my point is, do you think interesting to add this information in
> installation guide somewhere ? [1]
> Maybe there's a better place, or maybe it's not needed at all I don't
> know... There's already info about java 7 obviously, I'm talking about
> specific impact for red-hat.
>  
> WDYT ?

As you say it’s already listed implicitly by the mention of Java 7. I think there can be thousands of reasons people wouldn’t be able to install Java 7 (including the fact that their admin operation team doesn’t want to use it, that it doesn’t work on such OS and such version, etc). I’d say that it should be in the documentation of Java 7 or the document of RHEL instead ;)

I’m 100% against putting that information somewhere if you think it’s useful but I wouldn’t put it directly in the Prerequisites section at http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Installation#HPrerequisites since it can quickly becoming large and with little interest for 99% of people.

What we did, was to have specific installation sections for Servlet Containers and for Databases since they require specific knowledges for XWiki. We could imagine doing that for OSes but I’m not sure what we would put in there, since we don’t have that much information and by large the OS should have nothing to do with XWiki since XWiki runs on Java and the JVM isolates from the underlying OS.

I think that personally I wouldn’t put that information, similar that I wouldn’t put information about how Servlet Containers work because that information goes beyond XWiki. Requiring Java7 should be enough I think.

WDYT?

Thanks
-Vincent

> Best regards,
> Jeremie
>  
>  
> [1] - http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Installation

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users