XWiki Backup trouble - Part 2 (Getting there)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

XWiki Backup trouble - Part 2 (Getting there)

cburleso

Unbelievable what I had to go through to get some of the backup system to work on Windows!

The classpath in the env.sh file is so long that when you convert it to a Windows .bat file, Windows doesn't even accept it! I had to copy all my libraries into C:\lib just to get the classpath line short enough.

I executed the export script (groovy export).

The utility created a db folder with files in it, so it seems to work (I guess).

Except for the following error in my xwiki.log file:

17:26:53,428  WARN main  Configurator:configure:126 - No configuration found. Configuring ehcache from ehcache-failsafe.xml found in the classpath: jar:file:/C:/lib/ehcache-1.1.jar!/ehcache-failsafe.xml

A few questions now:

1. Does anyone know why I am getting this ehcache-failsafe warning?
2. Does backup's export/import handle the binary attachments?
3. If I backup from one wiki and import in another, am I overwriting the wiki or appending to it?
4. Is there a plan to incorporate the backup feature into the XWiki user interface (because all of this special configuration on Windows is quite troublesome)?

==================================
Cody Burleson




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws