XWord Server URL ?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

XWord Server URL ?

Simon Glet
Hi,

I have installed XOffice 1.1 M1 to edit files on my XWiki 2.1.1.

My previous XOffice tests were done against a stand alone jetty setup.
The Server URL was just a simple http://localhost:8090. Now that I
have deployed XWiki on Tomcat 6.0 I can't seem to figure out the
Server URL to enter in XWord. For now I use the URL
http://localhost:8090/xwiki-enterprise-web-2.1.1 in my browser to
login.

What am I missing ?

Thanks
Simon Glet
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: XWord Server URL ?

Valdis Vītoliņš
Tomcat port number usually is 8180.
Check /usr/share/tomcatx.x/conf/server.xml or /etc/tomcatx.x/server.xml
(or find file server.xml)
and then look for ..HTTP/1.1 Connector on port.. number.

Valdis

> Hi,
>
> I have installed XOffice 1.1 M1 to edit files on my XWiki 2.1.1.
>
> My previous XOffice tests were done against a stand alone jetty setup.
> The Server URL was just a simple http://localhost:8090. Now that I
> have deployed XWiki on Tomcat 6.0 I can't seem to figure out the
> Server URL to enter in XWord. For now I use the URL
> http://localhost:8090/xwiki-enterprise-web-2.1.1 in my browser to
> login.
>
> What am I missing ?
>
> Thanks
> Simon Glet
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users


_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: XWord Server URL ?

Florin Ciubotaru
In reply to this post by Simon Glet
Hi Simon,

XOffice 1.1 M1 is designed to work with XWiki 2.2 M1 or newer. You
should be able to login, but you'll only get basic content when saving
to the wiki.
Your url looks fine, you should not have problems unless you changed the
Xml-Rpc servlet mapping or you are using the wrong port, but I guess
that's not the case.
Can you look into the XWiki and XOffice(event viewer) logs for more details?

Florin Ciubotaru

On 2/12/2010 5:14 PM, Simon Glet wrote:

> Hi,
>
> I have installed XOffice 1.1 M1 to edit files on my XWiki 2.1.1.
>
> My previous XOffice tests were done against a stand alone jetty setup.
> The Server URL was just a simple http://localhost:8090. Now that I
> have deployed XWiki on Tomcat 6.0 I can't seem to figure out the
> Server URL to enter in XWord. For now I use the URL
> http://localhost:8090/xwiki-enterprise-web-2.1.1 in my browser to
> login.
>
> What am I missing ?
>
> Thanks
> Simon Glet
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
>    

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: XWord Server URL ?

Simon Glet
Valdis :
XWiki is reachable in a browser at port 8090. I still checked in the
server.xml file and http is on the same 8090 port.

Florin :
I removed that version and installed 1.0.0.98 and got the same
problem. No login and the error in the event viewer is :

"
Event Type: Error
Event Source: XWiki
Event Category: None
Event ID: 0
Date: 12/02/2010
Time: 12:38:48 PM
User: N/A
Computer: LOG-SIMON
Description:
Login to server http://127.0.0.1:8090/xwiki-enterprise-web-2.1.1 failed
"
I tried other urls like "http://127.0.0.1:8090" or
"http://127.0.0.1:8090/xwiki-enterprise-web-2.1.1/bin/login/XWiki/XWikiLogin"
with the same result.

Next week, I will install a packet sniffer and check out what is going
on. I have the feeling that the plugin isn't reaching the right port.

Thanks
Simon Glet



On Fri, Feb 12, 2010 at 10:51 AM, Florin Ciubotaru
<[hidden email]> wrote:

> Hi Simon,
>
> XOffice 1.1 M1 is designed to work with XWiki 2.2 M1 or newer. You
> should be able to login, but you'll only get basic content when saving
> to the wiki.
> Your url looks fine, you should not have problems unless you changed the
> Xml-Rpc servlet mapping or you are using the wrong port, but I guess
> that's not the case.
> Can you look into the XWiki and XOffice(event viewer) logs for more details?
>
> Florin Ciubotaru
>
> On 2/12/2010 5:14 PM, Simon Glet wrote:
>> Hi,
>>
>> I have installed XOffice 1.1 M1 to edit files on my XWiki 2.1.1.
>>
>> My previous XOffice tests were done against a stand alone jetty setup.
>> The Server URL was just a simple http://localhost:8090. Now that I
>> have deployed XWiki on Tomcat 6.0 I can't seem to figure out the
>> Server URL to enter in XWord. For now I use the URL
>> http://localhost:8090/xwiki-enterprise-web-2.1.1 in my browser to
>> login.
>>
>> What am I missing ?
>>
>> Thanks
>> Simon Glet
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>>
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: XWord Server URL ?

Paul Libbrecht
Simon,

my tomcats always defaulted to 8080 but server.xml and the log-line  
with "HTTP/1.1 Connector" should tell you the truth.
Can it be, however, that you have nothing in the root webapp?
Normal tomcats I've setup don't have anything.

To look for |oaded contexts, you should at either localhost.log or  
catalina.out where it's named "Context".
I would first unzip the war in a directory called xwiki.

paul


On 12-févr.-10, at 18:52, Simon Glet wrote:

> Valdis :
> XWiki is reachable in a browser at port 8090. I still checked in the
> server.xml file and http is on the same 8090 port.
>
> Florin :
> I removed that version and installed 1.0.0.98 and got the same
> problem. No login and the error in the event viewer is :
>
> "
> Event Type: Error
> Event Source: XWiki
> Event Category: None
> Event ID: 0
> Date: 12/02/2010
> Time: 12:38:48 PM
> User: N/A
> Computer: LOG-SIMON
> Description:
> Login to server http://127.0.0.1:8090/xwiki-enterprise-web-2.1.1 
> failed
> "
> I tried other urls like "http://127.0.0.1:8090" or
> "http://127.0.0.1:8090/xwiki-enterprise-web-2.1.1/bin/login/XWiki/XWikiLogin 
> "
> with the same result.
>
> Next week, I will install a packet sniffer and check out what is going
> on. I have the feeling that the plugin isn't reaching the right port.
>
> Thanks
> Simon Glet
>
>
>
> On Fri, Feb 12, 2010 at 10:51 AM, Florin Ciubotaru
> <[hidden email]> wrote:
>> Hi Simon,
>>
>> XOffice 1.1 M1 is designed to work with XWiki 2.2 M1 or newer. You
>> should be able to login, but you'll only get basic content when  
>> saving
>> to the wiki.
>> Your url looks fine, you should not have problems unless you  
>> changed the
>> Xml-Rpc servlet mapping or you are using the wrong port, but I guess
>> that's not the case.
>> Can you look into the XWiki and XOffice(event viewer) logs for more  
>> details?
>>
>> Florin Ciubotaru
>>
>> On 2/12/2010 5:14 PM, Simon Glet wrote:
>>> Hi,
>>>
>>> I have installed XOffice 1.1 M1 to edit files on my XWiki 2.1.1.
>>>
>>> My previous XOffice tests were done against a stand alone jetty  
>>> setup.
>>> The Server URL was just a simple http://localhost:8090. Now that I
>>> have deployed XWiki on Tomcat 6.0 I can't seem to figure out the
>>> Server URL to enter in XWord. For now I use the URL
>>> http://localhost:8090/xwiki-enterprise-web-2.1.1 in my browser to
>>> login.
>>>
>>> What am I missing ?
>>>
>>> Thanks
>>> Simon Glet
>>> _______________________________________________
>>> users mailing list
>>> [hidden email]
>>> http://lists.xwiki.org/mailman/listinfo/users
>>>
>>>
>>
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: XWord Server URL ?

Simon Glet
In reply to this post by Simon Glet
Hi,

I have installed the packet sniffer (Wireshark) but windows doesn't
allow a tcpdump on the loopback (127.0.0.1). So for now I can't "see"
was is going on. I will have to use XOffice from another machine...

Best Regards
Simon Glet

On Fri, Feb 12, 2010 at 12:52 PM, Simon Glet <[hidden email]> wrote:

> Valdis :
> XWiki is reachable in a browser at port 8090. I still checked in the
> server.xml file and http is on the same 8090 port.
>
> Florin :
> I removed that version and installed 1.0.0.98 and got the same
> problem. No login and the error in the event viewer is :
>
> "
> Event Type:     Error
> Event Source:   XWiki
> Event Category: None
> Event ID:       0
> Date:           12/02/2010
> Time:           12:38:48 PM
> User:           N/A
> Computer:       LOG-SIMON
> Description:
> Login to server http://127.0.0.1:8090/xwiki-enterprise-web-2.1.1 failed
> "
> I tried other urls like "http://127.0.0.1:8090" or
> "http://127.0.0.1:8090/xwiki-enterprise-web-2.1.1/bin/login/XWiki/XWikiLogin"
> with the same result.
>
> Next week, I will install a packet sniffer and check out what is going
> on. I have the feeling that the plugin isn't reaching the right port.
>
> Thanks
> Simon Glet
>
>
>
> On Fri, Feb 12, 2010 at 10:51 AM, Florin Ciubotaru
> <[hidden email]> wrote:
>> Hi Simon,
>>
>> XOffice 1.1 M1 is designed to work with XWiki 2.2 M1 or newer. You
>> should be able to login, but you'll only get basic content when saving
>> to the wiki.
>> Your url looks fine, you should not have problems unless you changed the
>> Xml-Rpc servlet mapping or you are using the wrong port, but I guess
>> that's not the case.
>> Can you look into the XWiki and XOffice(event viewer) logs for more details?
>>
>> Florin Ciubotaru
>>
>> On 2/12/2010 5:14 PM, Simon Glet wrote:
>>> Hi,
>>>
>>> I have installed XOffice 1.1 M1 to edit files on my XWiki 2.1.1.
>>>
>>> My previous XOffice tests were done against a stand alone jetty setup.
>>> The Server URL was just a simple http://localhost:8090. Now that I
>>> have deployed XWiki on Tomcat 6.0 I can't seem to figure out the
>>> Server URL to enter in XWord. For now I use the URL
>>> http://localhost:8090/xwiki-enterprise-web-2.1.1 in my browser to
>>> login.
>>>
>>> What am I missing ?
>>>
>>> Thanks
>>> Simon Glet
>>> _______________________________________________
>>> users mailing list
>>> [hidden email]
>>> http://lists.xwiki.org/mailman/listinfo/users
>>>
>>>
>>
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users