Xwiki Entrerprise Scheduler

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Xwiki Entrerprise Scheduler

Esbach, Brandon
Xwiki Entrerprise Scheduler

Something odd with this..
I've got different schedules setup per virtual wiki.  One of the notifications it sends includes links to documents - this works fine most times, but every so often it seems to get mixed up (using getExternalURL from the document object to get the url to send).

For example, on virtual wiki "private.xwiki.host.com", the link sometimes goes to the user as "public.xwiki.host.com".

I can use string replacement to fix it up, so I can work around the link - but this raises an important question (for me anyway):

If it's getting confused at getExternalURL, is it possible that the scheduler is going to get confused about where to look for documents (so if the scheduler is setup on wiki "public", would it potentially look at "private" instead)?


_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: Xwiki Entrerprise Scheduler

Sergiu Dumitriu-2
Esbach, Brandon wrote:

> Something odd with this..
> I've got different schedules setup per virtual wiki.  One of the
> notifications it sends includes links to documents - this works fine
> most times, but every so often it seems to get mixed up (using
> getExternalURL from the document object to get the url to send).
>
> For example, on virtual wiki "private.xwiki.host.com", the link
> sometimes goes to the user as "public.xwiki.host.com".
>
> I can use string replacement to fix it up, so I can work around the link
> - but this raises an important question (for me anyway):
>
> If it's getting confused at getExternalURL, is it possible that the
> scheduler is going to get confused about where to look for documents (so
> if the scheduler is setup on wiki "public", would it potentially look at
> "private" instead)?
>

Probably a multithreading issue. What version of XE/scheduler are you using?
--
Sergiu Dumitriu
http://purl.org/net/sergiu/
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users