Xwiki multilanguage options

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Xwiki multilanguage options

Sr Nieve
Hi everyone!:

I need help with my xwiki implementation. I try to include a multilanguage
options, CA, ES, EN. But I can´t find the way to reference a wikicontent to
a languate.

Some detalils below:

Xwiki version: 9.2.

I followed
http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Configuration#HLanguagesettings
thread but the system continuous with the same problem. Onlye retrieve one
language (default).

I really apreciate any comments on how to revolve it asap.

King regards.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xwiki multilanguage options

Thomas Mortagne
Administrator
To access a page is a specific language you need to add "?language=es"
to the URL.

in XWiki syntax it gives something like

    [[MyPage||queryString="language=es"]]

On Thu, Mar 30, 2017 at 11:39 AM, Sr Nieve <[hidden email]> wrote:

> Hi everyone!:
>
> I need help with my xwiki implementation. I try to include a multilanguage
> options, CA, ES, EN. But I can´t find the way to reference a wikicontent to
> a languate.
>
> Some detalils below:
>
> Xwiki version: 9.2.
>
> I followed
> http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Configuration#HLanguagesettings
> thread but the system continuous with the same problem. Onlye retrieve one
> language (default).
>
> I really apreciate any comments on how to revolve it asap.
>
> King regards.



--
Thomas Mortagne
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xwiki multilanguage options

Sr Nieve
Hi Thomas Mortagne :)
The main problem is people that uses it are health professional and should
give any better clue to change it. Is there any way by the interface to
implement those changes?

2017-03-30 11:55 GMT+02:00 Thomas Mortagne <[hidden email]>:

> To access a page is a specific language you need to add "?language=es"
> to the URL.
>
> in XWiki syntax it gives something like
>
>     [[MyPage||queryString="language=es"]]
>
> On Thu, Mar 30, 2017 at 11:39 AM, Sr Nieve <[hidden email]> wrote:
> > Hi everyone!:
> >
> > I need help with my xwiki implementation. I try to include a
> multilanguage
> > options, CA, ES, EN. But I can´t find the way to reference a wikicontent
> to
> > a languate.
> >
> > Some detalils below:
> >
> > Xwiki version: 9.2.
> >
> > I followed
> > http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Configuration#
> HLanguagesettings
> > thread but the system continuous with the same problem. Onlye retrieve
> one
> > language (default).
> >
> > I really apreciate any comments on how to revolve it asap.
> >
> > King regards.
>
>
>
> --
> Thomas Mortagne
>
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xwiki multilanguage options

Thomas Mortagne
Administrator
I don't think there is any way in standard WYSIWYG to explicitly
indicate which language of a document you want to target in your link
no (except indicated a custom query string).

On Thu, Mar 30, 2017 at 12:16 PM, Sr Nieve <[hidden email]> wrote:

> Hi Thomas Mortagne :)
> The main problem is people that uses it are health professional and should
> give any better clue to change it. Is there any way by the interface to
> implement those changes?
>
> 2017-03-30 11:55 GMT+02:00 Thomas Mortagne <[hidden email]>:
>
>> To access a page is a specific language you need to add "?language=es"
>> to the URL.
>>
>> in XWiki syntax it gives something like
>>
>>     [[MyPage||queryString="language=es"]]
>>
>> On Thu, Mar 30, 2017 at 11:39 AM, Sr Nieve <[hidden email]> wrote:
>> > Hi everyone!:
>> >
>> > I need help with my xwiki implementation. I try to include a
>> multilanguage
>> > options, CA, ES, EN. But I can´t find the way to reference a wikicontent
>> to
>> > a languate.
>> >
>> > Some detalils below:
>> >
>> > Xwiki version: 9.2.
>> >
>> > I followed
>> > http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Configuration#
>> HLanguagesettings
>> > thread but the system continuous with the same problem. Onlye retrieve
>> one
>> > language (default).
>> >
>> > I really apreciate any comments on how to revolve it asap.
>> >
>> > King regards.
>>
>>
>>
>> --
>> Thomas Mortagne
>>



--
Thomas Mortagne
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Xwiki multilanguage options

vmassol
Administrator
In reply to this post by Sr Nieve
Hi,

> On 30 Mar 2017, at 12:16, Sr Nieve <[hidden email]> wrote:
>
> Hi Thomas Mortagne :)
> The main problem is people that uses it are health professional and should
> give any better clue to change it. Is there any way by the interface to
> implement those changes?

This is the way it works as a user:

When you go to a page you’ll see it in the language of your browser. You can use the Drawer menu (top right) to force another language.

When you do so the URL will contain the language query strong.

So if you need to share that page with someone for that language all you need is to copy/paste the URL.

Is your question only about creating content with links pointing to another page for a given language?

And if so, do you need this feature in WYSIWYG? The WYSIWYG editor will offer you the possibility to add query string information but it doesn’t know about languages explicitly so in the Link dialog box there’s no control to choose a language ATM.

Thanks
-Vincent

> 2017-03-30 11:55 GMT+02:00 Thomas Mortagne <[hidden email]>:
>
>> To access a page is a specific language you need to add "?language=es"
>> to the URL.
>>
>> in XWiki syntax it gives something like
>>
>>    [[MyPage||queryString="language=es"]]
>>
>> On Thu, Mar 30, 2017 at 11:39 AM, Sr Nieve <[hidden email]> wrote:
>>> Hi everyone!:
>>>
>>> I need help with my xwiki implementation. I try to include a
>> multilanguage
>>> options, CA, ES, EN. But I can´t find the way to reference a wikicontent
>> to
>>> a languate.
>>>
>>> Some detalils below:
>>>
>>> Xwiki version: 9.2.
>>>
>>> I followed
>>> http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Configuration#
>> HLanguagesettings
>>> thread but the system continuous with the same problem. Onlye retrieve
>> one
>>> language (default).
>>>
>>> I really apreciate any comments on how to revolve it asap.
>>>
>>> King regards.
>>
>>
>>
>> --
>> Thomas Mortagne
>>

Loading...