attaching and accessing PNG files

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

attaching and accessing PNG files

rrodrigueznt
Hi all,

I've been seen this for some time now, but I'd no time to test it a bit
until today.

Even though PNG files attach correctly, they fail to be accessed both by
the {image:} macro and the direct link to the attechment.

Please, look at this page...

http://playground.myxwiki.org/xwiki/bin/view/R/coreSlice

This work...

http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/coreSlice.jpg

This other doesn't...

http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/coreSlice.png

The browser keeps "thinking" but the image doesn't show up.

PNG and JPG images have been generated in a MacBook Pro by using
Preview. I get the same behavior using Firefox, Safari and OmniWeb.

Please, any idea? Thanks!

Best,

Ricardo

--
Ricardo Rodríguez
Your EPEC Network ICT Team

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

Guillaume Lerouge
Hi Ricardo,

On Mon, Jul 27, 2009 at 6:55 PM, [Ricardo Rodriguez] Your EPEC Network ICT
Team <[hidden email]> wrote:

> Hi all,
>
> I've been seen this for some time now, but I'd no time to test it a bit
> until today.
>
> Even though PNG files attach correctly, they fail to be accessed both by
> the {image:} macro and the direct link to the attechment.
>
> Please, look at this page...
>
> http://playground.myxwiki.org/xwiki/bin/view/R/coreSlice
>
> This work...
>
> http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/coreSlice.jpg
>
> This other doesn't...
>
> http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/coreSlice.png
>
> The browser keeps "thinking" but the image doesn't show up.
>
> PNG and JPG images have been generated in a MacBook Pro by using
> Preview. I get the same behavior using Firefox, Safari and OmniWeb.
>
> Please, any idea? Thanks!


Well, I can see both images just fine in Safari 4... Are you sure this
doesn't come from your configuration?


> Best,
>
> Ricardo
>
> --
> Ricardo Rodríguez
> Your EPEC Network ICT Team
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>



--
Guillaume Lerouge
Product Manager - XWiki
Skype: wikibc
Twitter: glerouge
http://guillaumelerouge.com/
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

Thomas Mortagne
Administrator
In reply to this post by rrodrigueznt
On Mon, Jul 27, 2009 at 18:55, [Ricardo Rodriguez] Your EPEC Network
ICT Team<[hidden email]> wrote:

> Hi all,
>
> I've been seen this for some time now, but I'd no time to test it a bit
> until today.
>
> Even though PNG files attach correctly, they fail to be accessed both by
> the {image:} macro and the direct link to the attechment.
>
> Please, look at this page...
>
> http://playground.myxwiki.org/xwiki/bin/view/R/coreSlice
>
> This work...
>
> http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/coreSlice.jpg
>
> This other doesn't...
>
> http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/coreSlice.png

Both your links are working fine for me (FF 3.5 on Ubuntu).

>
> The browser keeps "thinking" but the image doesn't show up.
>
> PNG and JPG images have been generated in a MacBook Pro by using
> Preview. I get the same behavior using Firefox, Safari and OmniWeb.
>
> Please, any idea? Thanks!
>
> Best,
>
> Ricardo
>
> --
> Ricardo Rodríguez
> Your EPEC Network ICT Team
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>



--
Thomas Mortagne
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

rrodrigueznt
In reply to this post by Guillaume Lerouge
Hi, Guillaume!

Guillaume Lerouge wrote:
> Well, I can see both images just fine in Safari 4... Are you sure this
> doesn't come from your configuration?

Well, those are good news for XWiki! But I am not able which settings in
my configuration could affect to png file attached to XWiki pages.
Please, could you figure it out?

In any case, note that the page must show four times the same image.
Here the code...

http://tinyurl.com/nuy6mj

And here what I am seen when accessing the site with Firefox and Safari...

http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/troublesWithPngFiles.jpg

(jpg file, no problem at all!)

Thanks for any idea!

Cheers,

Ricardo


--
Ricardo Rodríguez
Your EPEC Network ICT Team

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

rrodrigueznt
In reply to this post by Thomas Mortagne
Thanks for testing!

Thomas Mortagne wrote:
>
>
> Both your links are working fine for me (FF 3.5 on Ubuntu).
>
>  
Any idea about why could stack here? Thanks.

--
Ricardo Rodríguez
Your EPEC Network ICT Team

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

Dignan, Patrick
In reply to this post by rrodrigueznt
On Jul 27, 2009, at 1:15 PM, [Ricardo Rodriguez] Your EPEC Network ICT  
Team wrote:

> Hi, Guillaume!
>
> Guillaume Lerouge wrote:
>> Well, I can see both images just fine in Safari 4... Are you sure  
>> this
>> doesn't come from your configuration?
>
> Well, those are good news for XWiki! But I am not able which  
> settings in
> my configuration could affect to png file attached to XWiki pages.
> Please, could you figure it out?
>
> In any case, note that the page must show four times the same image.
> Here the code...
>
> http://tinyurl.com/nuy6mj
>
> And here what I am seen when accessing the site with Firefox and  
> Safari...
>
> http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/troublesWithPngFiles.jpg
>
> (jpg file, no problem at all!)
>
> Thanks for any idea!
>
> Cheers,
>
> Ricardo
>
>
> --
> Ricardo Rodríguez
> Your EPEC Network ICT Team
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users

If you are trying to view it on Internet Explorer, I know in the past  
there have been some issues with Internet Explorer and .png files in  
general.  Perhaps it is related to that and not XWiki specific?

Regards,

Patrick Dignan
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

Thomas Mortagne
Administrator
In reply to this post by rrodrigueznt
On Mon, Jul 27, 2009 at 19:15, [Ricardo Rodriguez] Your EPEC Network
ICT Team<[hidden email]> wrote:

> Hi, Guillaume!
>
> Guillaume Lerouge wrote:
>> Well, I can see both images just fine in Safari 4... Are you sure this
>> doesn't come from your configuration?
>
> Well, those are good news for XWiki! But I am not able which settings in
> my configuration could affect to png file attached to XWiki pages.
> Please, could you figure it out?
>
> In any case, note that the page must show four times the same image.
> Here the code...
>
> http://tinyurl.com/nuy6mj

Why do you have mixed XWiki 1.0 ({image:coreSlice.png}) and 2.0 syntax
([[image:coreSlice.png]]) ? It's not possible that this can print 4
images, you will get two in 1.0 and  two in 2.0.

>
> And here what I am seen when accessing the site with Firefox and Safari...
>
> http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/troublesWithPngFiles.jpg
>
> (jpg file, no problem at all!)
>
> Thanks for any idea!
>
> Cheers,
>
> Ricardo
>
>
> --
> Ricardo Rodríguez
> Your EPEC Network ICT Team
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>



--
Thomas Mortagne
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

Thomas Mortagne
Administrator
On Mon, Jul 27, 2009 at 19:30, Thomas Mortagne<[hidden email]> wrote:

> On Mon, Jul 27, 2009 at 19:15, [Ricardo Rodriguez] Your EPEC Network
> ICT Team<[hidden email]> wrote:
>> Hi, Guillaume!
>>
>> Guillaume Lerouge wrote:
>>> Well, I can see both images just fine in Safari 4... Are you sure this
>>> doesn't come from your configuration?
>>
>> Well, those are good news for XWiki! But I am not able which settings in
>> my configuration could affect to png file attached to XWiki pages.
>> Please, could you figure it out?
>>
>> In any case, note that the page must show four times the same image.
>> Here the code...
>>
>> http://tinyurl.com/nuy6mj
>
> Why do you have mixed XWiki 1.0 ({image:coreSlice.png}) and 2.0 syntax
> ([[image:coreSlice.png]]) ? It's not possible that this can print 4
> images, you will get two in 1.0 and  two in 2.0.

Actually it should work since "image:coreSlice.png" alone is XWiki 2.0 syntax.

>
>>
>> And here what I am seen when accessing the site with Firefox and Safari...
>>
>> http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/troublesWithPngFiles.jpg
>>
>> (jpg file, no problem at all!)
>>
>> Thanks for any idea!
>>
>> Cheers,
>>
>> Ricardo
>>
>>
>> --
>> Ricardo Rodríguez
>> Your EPEC Network ICT Team
>>
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>
>
>
> --
> Thomas Mortagne
>



--
Thomas Mortagne
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

Thomas Mortagne
Administrator
On Mon, Jul 27, 2009 at 19:32, Thomas Mortagne<[hidden email]> wrote:

> On Mon, Jul 27, 2009 at 19:30, Thomas Mortagne<[hidden email]> wrote:
>> On Mon, Jul 27, 2009 at 19:15, [Ricardo Rodriguez] Your EPEC Network
>> ICT Team<[hidden email]> wrote:
>>> Hi, Guillaume!
>>>
>>> Guillaume Lerouge wrote:
>>>> Well, I can see both images just fine in Safari 4... Are you sure this
>>>> doesn't come from your configuration?
>>>
>>> Well, those are good news for XWiki! But I am not able which settings in
>>> my configuration could affect to png file attached to XWiki pages.
>>> Please, could you figure it out?
>>>
>>> In any case, note that the page must show four times the same image.
>>> Here the code...
>>>
>>> http://tinyurl.com/nuy6mj
>>
>> Why do you have mixed XWiki 1.0 ({image:coreSlice.png}) and 2.0 syntax
>> ([[image:coreSlice.png]]) ? It's not possible that this can print 4
>> images, you will get two in 1.0 and  two in 2.0.
>
> Actually it should work since "image:coreSlice.png" alone is XWiki 2.0 syntax.
>
>>
>>>
>>> And here what I am seen when accessing the site with Firefox and Safari...
>>>
>>> http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/troublesWithPngFiles.jpg
>>>

Which html does it produce ?

>>> (jpg file, no problem at all!)
>>>
>>> Thanks for any idea!
>>>
>>> Cheers,
>>>
>>> Ricardo
>>>
>>>
>>> --
>>> Ricardo Rodríguez
>>> Your EPEC Network ICT Team
>>>
>>> _______________________________________________
>>> users mailing list
>>> [hidden email]
>>> http://lists.xwiki.org/mailman/listinfo/users
>>>
>>
>>
>>
>> --
>> Thomas Mortagne
>>
>
>
>
> --
> Thomas Mortagne
>



--
Thomas Mortagne
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

rrodrigueznt
In reply to this post by Thomas Mortagne
Hi, Thomas,

Thomas Mortagne wrote:
>
>
> Why do you have mixed XWiki 1.0 ({image:coreSlice.png}) and 2.0 syntax
> ([[image:coreSlice.png]]) ? It's not possible that this can print 4
> images, you will get two in 1.0 and  two in 2.0.
It was just a test. Here another one by using 1.0 syntax. The code...

http://playground.myxwiki.org/xwiki/bin/view/R/coreSlice?viewer=code&showlinenumbers=0

I only see one picture, the one in jpg format.

Here what I am seeing using Firefox...

http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/troublesWithPngFiles02.jpg

Note the name of the png file on the top-left corner of the shown
picture (the one in jpg format).

Thanks!

--
Ricardo Rodríguez
Your EPEC Network ICT Team

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

rrodrigueznt
In reply to this post by Dignan, Patrick


Patrick Dignan wrote:
>
> If you are trying to view it on Internet Explorer, I know in the past  
> there have been some issues with Internet Explorer and .png files in  
> general.  Perhaps it is related to that and not XWiki specific?
>  
Hi, Patrick. I do remember that issue, but now IE is not involved so
far. Please, if you have it installed, could you try the links? Thanks!

Ricardo

--
Ricardo Rodríguez
Your EPEC Network ICT Team

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

rrodrigueznt
In reply to this post by Thomas Mortagne


Thomas Mortagne wrote:
> Which html does it produce ?
>
>  
Here the code...

http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/coreSlice.htm

Cheers,

Ricardo

--
Ricardo Rodríguez
Your EPEC Network ICT Team

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

Thomas Mortagne
Administrator
On Mon, Jul 27, 2009 at 20:14, [Ricardo Rodriguez] Your EPEC Network
ICT Team<[hidden email]> wrote:
>
>
> Thomas Mortagne wrote:
>> Which html does it produce ?
>>
>>
> Here the code...
>
> http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/coreSlice.htm

This link is printing 4 images to me, is this normal ?

>
> Cheers,
>
> Ricardo
>
> --
> Ricardo Rodríguez
> Your EPEC Network ICT Team
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>



--
Thomas Mortagne
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

Thomas Mortagne
Administrator
On Mon, Jul 27, 2009 at 21:38, Thomas Mortagne<[hidden email]> wrote:

> On Mon, Jul 27, 2009 at 20:14, [Ricardo Rodriguez] Your EPEC Network
> ICT Team<[hidden email]> wrote:
>>
>>
>> Thomas Mortagne wrote:
>>> Which html does it produce ?
>>>
>>>
>> Here the code...
>>
>> http://playground.myxwiki.org/xwiki/bin/download/R/coreSlice/coreSlice.htm
>
> This link is printing 4 images to me, is this normal ?

Maybe there is a cache issue, did you tried to force FF cache cleaning ?

>
>>
>> Cheers,
>>
>> Ricardo
>>
>> --
>> Ricardo Rodríguez
>> Your EPEC Network ICT Team
>>
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>
>
>
> --
> Thomas Mortagne
>



--
Thomas Mortagne
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: attaching and accessing PNG files

rrodrigueznt
Hi!

Thomas Mortagne wrote:
> Maybe there is a cache issue, did you tried to force FF cache cleaning ?
>
>  

Nope, I've not tried that. I've cleaned up FF cache, restarted the
browsers and... the problem has been solved in FF, Safari and OmniWeb!

But... why? And why does it only affect to png files? In any case,
thanks for your time and sorry for the noise.

Greetings,

Ricardo

--
Ricardo Rodríguez
Your EPEC Network ICT Team

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users