how to debug a picture not being scaled down?

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

how to debug a picture not being scaled down?

Paul Libbrecht-2

Hello fellow XWikiers,

I now have an XWiki 5.0.3 and an XWiki 5.1 where my picture never gets downsized.
e.g. /xwiki/bin/download/XWiki/polx/photo%2Dpasseport%2DPaul%2D2012%2D07.jpg?width=50&height=50&keepAspectRatio=true
has width 345 x 443 (the original).

How can I debug this?
The log does not seem to say and it seems not related to have an AWT thread at hand (the 5.1 is run with a graphics environment).

thanks in advance.

Paul
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: how to debug a picture not being scaled down?

Jérôme Velociter
Hi Paul,

You could place a breakpoint in the image plugin, in #downloadAttachment
[1] and see what gets executed ?

Jérôme

[1]
https://github.com/xwiki/xwiki-platform/blob/master/xwiki-platform-core/xwiki-platform-oldcore/src/main/java/com/xpn/xwiki/plugin/image/ImagePlugin.java#L191

On 07/17/2013 03:59 PM, Paul Libbrecht wrote:

> Hello fellow XWikiers,
>
> I now have an XWiki 5.0.3 and an XWiki 5.1 where my picture never gets downsized.
> e.g. /xwiki/bin/download/XWiki/polx/photo%2Dpasseport%2DPaul%2D2012%2D07.jpg?width=50&height=50&keepAspectRatio=true
> has width 345 x 443 (the original).
>
> How can I debug this?
> The log does not seem to say and it seems not related to have an AWT thread at hand (the 5.1 is run with a graphics environment).
>
> thanks in advance.
>
> Paul
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: how to debug a picture not being scaled down?

Paul Libbrecht-2
In reply to this post by Paul Libbrecht-2
Ping?
Any hint would be appreciated.

thanks in advance.

Paul


On 17 juil. 2013, at 15:59, Paul Libbrecht wrote:

>
> Hello fellow XWikiers,
>
> I now have an XWiki 5.0.3 and an XWiki 5.1 where my picture never gets downsized.
> e.g. /xwiki/bin/download/XWiki/polx/photo%2Dpasseport%2DPaul%2D2012%2D07.jpg?width=50&height=50&keepAspectRatio=true
> has width 345 x 443 (the original).
>
> How can I debug this?
> The log does not seem to say and it seems not related to have an AWT thread at hand (the 5.1 is run with a graphics environment).
>
> thanks in advance.
>
> Paul
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: how to debug a picture not being scaled down?

Edo Beutler-2
Hi Paul

Since we are still on an old XWiki version I don't know how much changed in
v5.x, but here are two hints on possible issues:
1. The image plugin had a bug in versioning where it could happen, that a
cached image would not get invalidated correctly. This is easy to check:
the image would be resized correctly if you use other resize dimensions.
2. The image can not be properly decoded and hence not resized. One (of
many) reasons for that: the image uses CMYK colour scheme (from print)
instead of the RGB expected by the image plugin. You can check that in any
decent graphics editing program.

Hope this helps
Edo


On Fri, Jul 19, 2013 at 1:39 PM, Paul Libbrecht <[hidden email]> wrote:

> Ping?
> Any hint would be appreciated.
>
> thanks in advance.
>
> Paul
>
>
> On 17 juil. 2013, at 15:59, Paul Libbrecht wrote:
>
> >
> > Hello fellow XWikiers,
> >
> > I now have an XWiki 5.0.3 and an XWiki 5.1 where my picture never gets
> downsized.
> > e.g.
> /xwiki/bin/download/XWiki/polx/photo%2Dpasseport%2DPaul%2D2012%2D07.jpg?width=50&height=50&keepAspectRatio=true
> > has width 345 x 443 (the original).
> >
> > How can I debug this?
> > The log does not seem to say and it seems not related to have an AWT
> thread at hand (the 5.1 is run with a graphics environment).
> >
> > thanks in advance.
> >
> > Paul
> > _______________________________________________
> > users mailing list
> > [hidden email]
> > http://lists.xwiki.org/mailman/listinfo/users
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: how to debug a picture not being scaled down?

AngeloG
In reply to this post by Paul Libbrecht-2
<quote author="Paul Libbrecht-2">
Ping?
Any hint would be appreciated.

thanks in advance.

Paul


On 17 juil. 2013, at 15:59, Paul Libbrecht wrote:

>
> Hello fellow XWikiers,
>
> I now have an XWiki 5.0.3 and an XWiki 5.1 where my picture never gets downsized.
> e.g. /xwiki/bin/download/XWiki/polx/photo%2Dpasseport%2DPaul%2D2012%2D07.jpg?width=50&height=50&keepAspectRatio=true
> has width 345 x 443 (the original).

Just an idea: how can you keep Aspect ratio and size 50x50 if the original is not a square?
Hope it helps
Angelo
Reply | Threaded
Open this post in threaded view
|

Re: how to debug a picture not being scaled down?

Paul Libbrecht-2
Angelo,

> Just an idea: how can you keep Aspect ratio and size 50x50 if the original
> is not a square?

in XWiki 3.5 this works wonderfully, it chooses something to fit the first size.
Of course it will not end up be square and thus one of the wishes is not satisfied, but it is not bigger than these two sizes.

> Since we are still on an old XWiki version I don't know how much changed in
> v5.x, but here are two hints on possible issues:
> 1. The image plugin had a bug in versioning where it could happen, that a
> cached image would not get invalidated correctly. This is easy to check:
> the image would be resized correctly if you use other resize dimensions.

And it does not.

> 2. The image can not be properly decoded and hence not resized. One (of
> many) reasons for that: the image uses CMYK colour scheme (from print)
> instead of the RGB expected by the image plugin. You can check that in any
> decent graphics editing program.


Also not the case: the result of identify:
200x256 200x256+0+0 8-bit sRGB 50.8KB 0.000u 0:00.000

The image plugin would be doing this?
Indeed it is configured:
        com.xpn.xwiki.plugin.image.ImagePlugin,\

It seems to be living inside xwiki-platform-legacy-oldcore-5.1.jar but maybe that plugin is disabled?

thanks for hints.

Paul
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: how to debug a picture not being scaled down?

Paul Libbrecht-2

On 19 juil. 2013, at 15:38, Paul Libbrecht wrote:

>> 2. The image can not be properly decoded and hence not resized. One (of
>> many) reasons for that: the image uses CMYK colour scheme (from print)
>> instead of the RGB expected by the image plugin. You can check that in any
>> decent graphics editing program.
>
>
> Also not the case: the result of identify:
> 200x256 200x256+0+0 8-bit sRGB 50.8KB 0.000u 0:00.000
>
> The image plugin would be doing this?
> Indeed it is configured:
> com.xpn.xwiki.plugin.image.ImagePlugin,\
>
> It seems to be living inside xwiki-platform-legacy-oldcore-5.1.jar but maybe that plugin is disabled?

Not disabled: in velocity xwiki.image gives me:
  com.xpn.xwiki.plugin.image.ImagePluginAPI@2fc98f55
Can it be the image plugin is not called?

Paul
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: how to debug a picture not being scaled down?

Edo Beutler-2
Yes, that's the plugin. If you found it configured in xwiki.cfg and got it
in velosity it's active. I suppose it's in oldcore because it's a plugin
and not a component and, afaik, it's not (yet) possible to do it in a
component since it intercepts the download action.
Every time you access a file using the download action
(/xwiki/bin/download/...) the downloadAttachment method in the plugin gets
called and the plugin checks the file.


On Fri, Jul 19, 2013 at 3:52 PM, Paul Libbrecht <[hidden email]> wrote:

>
> On 19 juil. 2013, at 15:38, Paul Libbrecht wrote:
>
> >> 2. The image can not be properly decoded and hence not resized. One (of
> >> many) reasons for that: the image uses CMYK colour scheme (from print)
> >> instead of the RGB expected by the image plugin. You can check that in
> any
> >> decent graphics editing program.
> >
> >
> > Also not the case: the result of identify:
> > 200x256 200x256+0+0 8-bit sRGB 50.8KB 0.000u 0:00.000
> >
> > The image plugin would be doing this?
> > Indeed it is configured:
> >       com.xpn.xwiki.plugin.image.ImagePlugin,\
> >
> > It seems to be living inside xwiki-platform-legacy-oldcore-5.1.jar but
> maybe that plugin is disabled?
>
> Not disabled: in velocity xwiki.image gives me:
>   com.xpn.xwiki.plugin.image.ImagePluginAPI@2fc98f55
> Can it be the image plugin is not called?
>
> Paul
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: how to debug a picture not being scaled down?

Paul Libbrecht-2
So that interception would fail?

How can I inspect that?

paul


On 19 juil. 2013, at 16:06, Edo Beutler wrote:

> Yes, that's the plugin. If you found it configured in xwiki.cfg and got it
> in velosity it's active. I suppose it's in oldcore because it's a plugin
> and not a component and, afaik, it's not (yet) possible to do it in a
> component since it intercepts the download action.
> Every time you access a file using the download action
> (/xwiki/bin/download/...) the downloadAttachment method in the plugin gets
> called and the plugin checks the file.
>
>
> On Fri, Jul 19, 2013 at 3:52 PM, Paul Libbrecht <[hidden email]> wrote:
>
>>
>> On 19 juil. 2013, at 15:38, Paul Libbrecht wrote:
>>
>>>> 2. The image can not be properly decoded and hence not resized. One (of
>>>> many) reasons for that: the image uses CMYK colour scheme (from print)
>>>> instead of the RGB expected by the image plugin. You can check that in
>> any
>>>> decent graphics editing program.
>>>
>>>
>>> Also not the case: the result of identify:
>>> 200x256 200x256+0+0 8-bit sRGB 50.8KB 0.000u 0:00.000
>>>
>>> The image plugin would be doing this?
>>> Indeed it is configured:
>>>      com.xpn.xwiki.plugin.image.ImagePlugin,\
>>>
>>> It seems to be living inside xwiki-platform-legacy-oldcore-5.1.jar but
>> maybe that plugin is disabled?
>>
>> Not disabled: in velocity xwiki.image gives me:
>>  com.xpn.xwiki.plugin.image.ImagePluginAPI@2fc98f55
>> Can it be the image plugin is not called?

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: how to debug a picture not being scaled down?

Edo Beutler-2
The easiest first step would be to increase the logging level for the image
plugin. Unfortunately there seem to be a lot of

try {

  ...
} catch (...) {
  // Ignore.
}

constructs in the code, so you will get only something logged if you are
lucky.
If you're unlucky you could add more logging and build the plugin jar
yourself. That way you can also add something like LOG.info("starting
downloadAttachment"); to see if the method gets called at all.

On Fri, Jul 19, 2013 at 4:10 PM, Paul Libbrecht <[hidden email]> wrote:

> So that interception would fail?
>
> How can I inspect that?
>
> paul
>
>
> On 19 juil. 2013, at 16:06, Edo Beutler wrote:
>
> > Yes, that's the plugin. If you found it configured in xwiki.cfg and got
> it
> > in velosity it's active. I suppose it's in oldcore because it's a plugin
> > and not a component and, afaik, it's not (yet) possible to do it in a
> > component since it intercepts the download action.
> > Every time you access a file using the download action
> > (/xwiki/bin/download/...) the downloadAttachment method in the plugin
> gets
> > called and the plugin checks the file.
> >
> >
> > On Fri, Jul 19, 2013 at 3:52 PM, Paul Libbrecht <[hidden email]>
> wrote:
> >
> >>
> >> On 19 juil. 2013, at 15:38, Paul Libbrecht wrote:
> >>
> >>>> 2. The image can not be properly decoded and hence not resized. One
> (of
> >>>> many) reasons for that: the image uses CMYK colour scheme (from print)
> >>>> instead of the RGB expected by the image plugin. You can check that in
> >> any
> >>>> decent graphics editing program.
> >>>
> >>>
> >>> Also not the case: the result of identify:
> >>> 200x256 200x256+0+0 8-bit sRGB 50.8KB 0.000u 0:00.000
> >>>
> >>> The image plugin would be doing this?
> >>> Indeed it is configured:
> >>>      com.xpn.xwiki.plugin.image.ImagePlugin,\
> >>>
> >>> It seems to be living inside xwiki-platform-legacy-oldcore-5.1.jar but
> >> maybe that plugin is disabled?
> >>
> >> Not disabled: in velocity xwiki.image gives me:
> >>  com.xpn.xwiki.plugin.image.ImagePluginAPI@2fc98f55
> >> Can it be the image plugin is not called?
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: how to debug a picture not being scaled down?

vmassol
Administrator

On Jul 19, 2013, at 5:43 PM, Edo Beutler <[hidden email]> wrote:

> The easiest first step would be to increase the logging level for the image
> plugin. Unfortunately there seem to be a lot of
>
> try {
>
>  ...
> } catch (...) {
>  // Ignore.
> }
>
> constructs in the code, so you will get only something logged if you are
> lucky.
> If you're unlucky you could add more logging and build the plugin jar
> yourself. That way you can also add something like LOG.info("starting
> downloadAttachment"); to see if the method gets called at all.

You could check http://dev.xwiki.org/xwiki/bin/view/Community/Debugging#HUsingByteman for that btw (which doesn't require modifying the code).

Thanks
-Vincent

> On Fri, Jul 19, 2013 at 4:10 PM, Paul Libbrecht <[hidden email]> wrote:
>
>> So that interception would fail?
>>
>> How can I inspect that?
>>
>> paul
>>
>>
>> On 19 juil. 2013, at 16:06, Edo Beutler wrote:
>>
>>> Yes, that's the plugin. If you found it configured in xwiki.cfg and got
>> it
>>> in velosity it's active. I suppose it's in oldcore because it's a plugin
>>> and not a component and, afaik, it's not (yet) possible to do it in a
>>> component since it intercepts the download action.
>>> Every time you access a file using the download action
>>> (/xwiki/bin/download/...) the downloadAttachment method in the plugin
>> gets
>>> called and the plugin checks the file.
>>>
>>>
>>> On Fri, Jul 19, 2013 at 3:52 PM, Paul Libbrecht <[hidden email]>
>> wrote:
>>>
>>>>
>>>> On 19 juil. 2013, at 15:38, Paul Libbrecht wrote:
>>>>
>>>>>> 2. The image can not be properly decoded and hence not resized. One
>> (of
>>>>>> many) reasons for that: the image uses CMYK colour scheme (from print)
>>>>>> instead of the RGB expected by the image plugin. You can check that in
>>>> any
>>>>>> decent graphics editing program.
>>>>>
>>>>>
>>>>> Also not the case: the result of identify:
>>>>> 200x256 200x256+0+0 8-bit sRGB 50.8KB 0.000u 0:00.000
>>>>>
>>>>> The image plugin would be doing this?
>>>>> Indeed it is configured:
>>>>>     com.xpn.xwiki.plugin.image.ImagePlugin,\
>>>>>
>>>>> It seems to be living inside xwiki-platform-legacy-oldcore-5.1.jar but
>>>> maybe that plugin is disabled?
>>>>
>>>> Not disabled: in velocity xwiki.image gives me:
>>>> com.xpn.xwiki.plugin.image.ImagePluginAPI@2fc98f55
>>>> Can it be the image plugin is not called?
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: how to debug a picture not being scaled down?

Paul Libbrecht-2
I've debugged the thing, using remote debugging, and it seems that it is properly processing through the image plugin but the latter is supposed to write into an attachment that is a clone of the image attachment and that seems to lead to the same path as the file.
For some reasons it is not written to (IOUtils.closeQuietly does not flush?).
And, because it's a clone, the same file is delivered as download.

I seem to suspect the file-ssytem-attachments.
Is xwiki.org not using the filesystem attachment?

This works well, with file-system-attachment, in xwiki 3.5 (e.g. in gpsnetwork.org).

thanks

Paul


On 19 juil. 2013, at 16:49, Vincent Massol wrote:

>
> On Jul 19, 2013, at 5:43 PM, Edo Beutler <[hidden email]> wrote:
>
>> The easiest first step would be to increase the logging level for the image
>> plugin. Unfortunately there seem to be a lot of
>>
>> try {
>>
>> ...
>> } catch (...) {
>> // Ignore.
>> }
>>
>> constructs in the code, so you will get only something logged if you are
>> lucky.
>> If you're unlucky you could add more logging and build the plugin jar
>> yourself. That way you can also add something like LOG.info("starting
>> downloadAttachment"); to see if the method gets called at all.
>
> You could check http://dev.xwiki.org/xwiki/bin/view/Community/Debugging#HUsingByteman for that btw (which doesn't require modifying the code).
>
> Thanks
> -Vincent
>
>> On Fri, Jul 19, 2013 at 4:10 PM, Paul Libbrecht <[hidden email]> wrote:
>>
>>> So that interception would fail?
>>>
>>> How can I inspect that?
>>>
>>> paul
>>>
>>>
>>> On 19 juil. 2013, at 16:06, Edo Beutler wrote:
>>>
>>>> Yes, that's the plugin. If you found it configured in xwiki.cfg and got
>>> it
>>>> in velosity it's active. I suppose it's in oldcore because it's a plugin
>>>> and not a component and, afaik, it's not (yet) possible to do it in a
>>>> component since it intercepts the download action.
>>>> Every time you access a file using the download action
>>>> (/xwiki/bin/download/...) the downloadAttachment method in the plugin
>>> gets
>>>> called and the plugin checks the file.
>>>>
>>>>
>>>> On Fri, Jul 19, 2013 at 3:52 PM, Paul Libbrecht <[hidden email]>
>>> wrote:
>>>>
>>>>>
>>>>> On 19 juil. 2013, at 15:38, Paul Libbrecht wrote:
>>>>>
>>>>>>> 2. The image can not be properly decoded and hence not resized. One
>>> (of
>>>>>>> many) reasons for that: the image uses CMYK colour scheme (from print)
>>>>>>> instead of the RGB expected by the image plugin. You can check that in
>>>>> any
>>>>>>> decent graphics editing program.
>>>>>>
>>>>>>
>>>>>> Also not the case: the result of identify:
>>>>>> 200x256 200x256+0+0 8-bit sRGB 50.8KB 0.000u 0:00.000
>>>>>>
>>>>>> The image plugin would be doing this?
>>>>>> Indeed it is configured:
>>>>>>    com.xpn.xwiki.plugin.image.ImagePlugin,\
>>>>>>
>>>>>> It seems to be living inside xwiki-platform-legacy-oldcore-5.1.jar but
>>>>> maybe that plugin is disabled?
>>>>>
>>>>> Not disabled: in velocity xwiki.image gives me:
>>>>> com.xpn.xwiki.plugin.image.ImagePluginAPI@2fc98f55
>>>>> Can it be the image plugin is not called?
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: how to debug a picture not being scaled down?

Paul Libbrecht-2
Because it worked flawlessly on XWiki 3.5, I crawled the difference between the ImagePlugin 3.5 and 5.1: just one apparently very reasonable change: no more reliance on byte-arrays but employ XWikiAttachments and stream  to these.

Suspecting this to be the cause, I put the package com/xpn/xwiki/plugin/image of xwiki 3.5 in the classes directory of my xwiki 5.1.
Since then, the pictures scale again.

I've opened http://jira.xwiki.org/browse/XWIKI-9387

paul



On 4 août 2013, at 16:45, Paul Libbrecht wrote:

> I've debugged the thing, using remote debugging, and it seems that it is properly processing through the image plugin but the latter is supposed to write into an attachment that is a clone of the image attachment and that seems to lead to the same path as the file.
> For some reasons it is not written to (IOUtils.closeQuietly does not flush?).
> And, because it's a clone, the same file is delivered as download.
>
> I seem to suspect the file-ssytem-attachments.
> Is xwiki.org not using the filesystem attachment?
>
> This works well, with file-system-attachment, in xwiki 3.5 (e.g. in gpsnetwork.org).
>
> thanks
>
> Paul
>
>
> On 19 juil. 2013, at 16:49, Vincent Massol wrote:
>
>>
>> On Jul 19, 2013, at 5:43 PM, Edo Beutler <[hidden email]> wrote:
>>
>>> The easiest first step would be to increase the logging level for the image
>>> plugin. Unfortunately there seem to be a lot of
>>>
>>> try {
>>>
>>> ...
>>> } catch (...) {
>>> // Ignore.
>>> }
>>>
>>> constructs in the code, so you will get only something logged if you are
>>> lucky.
>>> If you're unlucky you could add more logging and build the plugin jar
>>> yourself. That way you can also add something like LOG.info("starting
>>> downloadAttachment"); to see if the method gets called at all.
>>
>> You could check http://dev.xwiki.org/xwiki/bin/view/Community/Debugging#HUsingByteman for that btw (which doesn't require modifying the code).
>>
>> Thanks
>> -Vincent
>>
>>> On Fri, Jul 19, 2013 at 4:10 PM, Paul Libbrecht <[hidden email]> wrote:
>>>
>>>> So that interception would fail?
>>>>
>>>> How can I inspect that?
>>>>
>>>> paul
>>>>
>>>>
>>>> On 19 juil. 2013, at 16:06, Edo Beutler wrote:
>>>>
>>>>> Yes, that's the plugin. If you found it configured in xwiki.cfg and got
>>>> it
>>>>> in velosity it's active. I suppose it's in oldcore because it's a plugin
>>>>> and not a component and, afaik, it's not (yet) possible to do it in a
>>>>> component since it intercepts the download action.
>>>>> Every time you access a file using the download action
>>>>> (/xwiki/bin/download/...) the downloadAttachment method in the plugin
>>>> gets
>>>>> called and the plugin checks the file.
>>>>>
>>>>>
>>>>> On Fri, Jul 19, 2013 at 3:52 PM, Paul Libbrecht <[hidden email]>
>>>> wrote:
>>>>>
>>>>>>
>>>>>> On 19 juil. 2013, at 15:38, Paul Libbrecht wrote:
>>>>>>
>>>>>>>> 2. The image can not be properly decoded and hence not resized. One
>>>> (of
>>>>>>>> many) reasons for that: the image uses CMYK colour scheme (from print)
>>>>>>>> instead of the RGB expected by the image plugin. You can check that in
>>>>>> any
>>>>>>>> decent graphics editing program.
>>>>>>>
>>>>>>>
>>>>>>> Also not the case: the result of identify:
>>>>>>> 200x256 200x256+0+0 8-bit sRGB 50.8KB 0.000u 0:00.000
>>>>>>>
>>>>>>> The image plugin would be doing this?
>>>>>>> Indeed it is configured:
>>>>>>>   com.xpn.xwiki.plugin.image.ImagePlugin,\
>>>>>>>
>>>>>>> It seems to be living inside xwiki-platform-legacy-oldcore-5.1.jar but
>>>>>> maybe that plugin is disabled?
>>>>>>
>>>>>> Not disabled: in velocity xwiki.image gives me:
>>>>>> com.xpn.xwiki.plugin.image.ImagePluginAPI@2fc98f55
>>>>>> Can it be the image plugin is not called?
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users