localization string missing - xe.blog.code.title

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

localization string missing - xe.blog.code.title

rrodriguezIDIS
Hi everybody!!!

Please, allow me some small talk... I'm really happy to be here again once I've managed to get and start enjoying a brand new 6.2.4. XWiki installation!

Only a detail: after following the evolution of the 6.x branch and having installed the new 6.2.4 release, a string seems to keep lacking affecting the renderization of Blog.WebHome.

Here it is what I see not only here, but in a number of installations around the net...

http://atriumkm.idisantiago.es/bin/download/ICT/Images/blogLocalizationMissingVariable.png

I guess you get the same result by accessing directly this site...

http://idis1.idisantiago.es:8080/xwiki/bin/view/Blog/

Please, even though it is kind of a trivial problem not affecting, shouldn't it be fixed?

Thanks!

Ricardo

--
Ricardo Rodríguez
Research Management and Promotion Technician
Technical Secretariat
Health Research Institute of Santiago de Compostela (IDIS)
http://www.idisantiago.es

________________________________

Nota: A información contida nesta mensaxe e os seus posibles documentos adxuntos é privada e confidencial e está dirixida únicamente ó seu destinatario/a. Se vostede non é o/a destinatario/a orixinal desta mensaxe, por favor elimínea. A distribución ou copia desta mensaxe non está autorizada.

Nota: La información contenida en este mensaje y sus posibles documentos adjuntos es privada y confidencial y está dirigida únicamente a su destinatario/a. Si usted no es el/la destinatario/a original de este mensaje, por favor elimínelo. La distribución o copia de este mensaje no está autorizada.

See more languages: http://www.sergas.es/aviso_confidencialidad.htm
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
--
Ricardo Rodríguez
Research Management and Promotion Technician
Technical Secretariat
Health Research Institute of Santiago de Compostela (IDIS)
http://www.idisantiago.es
Reply | Threaded
Open this post in threaded view
|

Re: localization string missing - xe.blog.code.title

Marius Dumitru Florea
I don't have this problem. FYI, the Blog title comes from
Blog.BlogSheet which uses this code

#evaluate($!doc.getValue('title'))

and the value of the title property (Blog.BlogClass) from Blog.WebHome is

$services.localization.render('xe.blog.code.title')

I guess #evaluate() fails in your case. But it's not related to
missing translation. You would get 'xe.blog.code.title' displayed if
the translation was really missing.

Hope this helps,
Marius

On Tue, Nov 11, 2014 at 3:32 PM,
<[hidden email]> wrote:

> Hi everybody!!!
>
> Please, allow me some small talk... I'm really happy to be here again once I've managed to get and start enjoying a brand new 6.2.4. XWiki installation!
>
> Only a detail: after following the evolution of the 6.x branch and having installed the new 6.2.4 release, a string seems to keep lacking affecting the renderization of Blog.WebHome.
>
> Here it is what I see not only here, but in a number of installations around the net...
>
> http://atriumkm.idisantiago.es/bin/download/ICT/Images/blogLocalizationMissingVariable.png
>
> I guess you get the same result by accessing directly this site...
>
> http://idis1.idisantiago.es:8080/xwiki/bin/view/Blog/
>
> Please, even though it is kind of a trivial problem not affecting, shouldn't it be fixed?
>
> Thanks!
>
> Ricardo
>
> --
> Ricardo Rodríguez
> Research Management and Promotion Technician
> Technical Secretariat
> Health Research Institute of Santiago de Compostela (IDIS)
> http://www.idisantiago.es
>
> ________________________________
>
> Nota: A información contida nesta mensaxe e os seus posibles documentos adxuntos é privada e confidencial e está dirixida únicamente ó seu destinatario/a. Se vostede non é o/a destinatario/a orixinal desta mensaxe, por favor elimínea. A distribución ou copia desta mensaxe non está autorizada.
>
> Nota: La información contenida en este mensaje y sus posibles documentos adjuntos es privada y confidencial y está dirigida únicamente a su destinatario/a. Si usted no es el/la destinatario/a original de este mensaje, por favor elimínelo. La distribución o copia de este mensaje no está autorizada.
>
> See more languages: http://www.sergas.es/aviso_confidencialidad.htm
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: localization string missing - xe.blog.code.title

Valdis Vītoliņš
In reply to this post by rrodriguezIDIS
Probably you need to set object title value for .../Blog/WebHome
document. Note that this is not document title, but object title
open it in form/object editor.

Valdis

> Hi everybody!!!
>
> Please, allow me some small talk... I'm really happy to be here again once I've managed to get and start enjoying a brand new 6.2.4. XWiki installation!
>
> Only a detail: after following the evolution of the 6.x branch and having installed the new 6.2.4 release, a string seems to keep lacking affecting the renderization of Blog.WebHome.
>
> Here it is what I see not only here, but in a number of installations around the net...
>
> http://atriumkm.idisantiago.es/bin/download/ICT/Images/blogLocalizationMissingVariable.png
>
> I guess you get the same result by accessing directly this site...
>
> http://idis1.idisantiago.es:8080/xwiki/bin/view/Blog/
>
> Please, even though it is kind of a trivial problem not affecting, shouldn't it be fixed?
>
> Thanks!
>
> Ricardo
>
> --
> Ricardo Rodríguez
> Research Management and Promotion Technician
> Technical Secretariat
> Health Research Institute of Santiago de Compostela (IDIS)
> http://www.idisantiago.es
>
> ________________________________
>
> Nota: A información contida nesta mensaxe e os seus posibles documentos adxuntos é privada e confidencial e está dirixida únicamente ó seu destinatario/a. Se vostede non é o/a destinatario/a orixinal desta mensaxe, por favor elimínea. A distribución ou copia desta mensaxe non está autorizada.
>
> Nota: La información contenida en este mensaje y sus posibles documentos adjuntos es privada y confidencial y está dirigida únicamente a su destinatario/a. Si usted no es el/la destinatario/a original de este mensaje, por favor elimínelo. La distribución o copia de este mensaje no está autorizada.
>
> See more languages: http://www.sergas.es/aviso_confidencialidad.htm
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users


_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: localization string missing - xe.blog.code.title

Clemens Klein-Robbenhaar
In reply to this post by Marius Dumitru Florea
On 11/11/2014 02:54 PM, Marius Dumitru Florea wrote:

> I don't have this problem. FYI, the Blog title comes from
> Blog.BlogSheet which uses this code
>
> #evaluate($!doc.getValue('title'))
>
> and the value of the title property (Blog.BlogClass) from Blog.WebHome is
>
> $services.localization.render('xe.blog.code.title')
>
> I guess #evaluate() fails in your case. But it's not related to
> missing translation. You would get 'xe.blog.code.title' displayed if
> the translation was really missing.
>

I can reproduce it with a wiki upgraded from 5.4.x (forgot which x) to 6.2
The problem is that the "#evaluate(...)" is missing in the title

To fix this manually, edit this page:

  http://idis1.idisantiago.es:8080/xwiki/bin/view/Blog/BlogSheet

In the "title" input field it might just read:

  $doc.getValue("title")

replace this with:

  #evaluate($doc.getValue("title"))

and the issue should go away.


I have to admit that I am a bit clueless why this might happen;
but in my case I suspect I messed around with import/export too much
and overwrote the BlogSheet with the wrong version ...

Hope this helps, too ;)
Clemens

> Hope this helps,
> Marius
>
> On Tue, Nov 11, 2014 at 3:32 PM,
> <[hidden email]> wrote:
>> Hi everybody!!!
>>
>> Please, allow me some small talk... I'm really happy to be here again once I've managed to get and start enjoying a brand new 6.2.4. XWiki installation!
>>
>> Only a detail: after following the evolution of the 6.x branch and having installed the new 6.2.4 release, a string seems to keep lacking affecting the renderization of Blog.WebHome.
>>
>> Here it is what I see not only here, but in a number of installations around the net...
>>
>> http://atriumkm.idisantiago.es/bin/download/ICT/Images/blogLocalizationMissingVariable.png
>>
>> I guess you get the same result by accessing directly this site...
>>
>> http://idis1.idisantiago.es:8080/xwiki/bin/view/Blog/
>>
>> Please, even though it is kind of a trivial problem not affecting, shouldn't it be fixed?
>>
>> Thanks!
>>
>> Ricardo
>>
>> --
>> Ricardo Rodríguez
>> Research Management and Promotion Technician
>> Technical Secretariat
>> Health Research Institute of Santiago de Compostela (IDIS)
>> http://www.idisantiago.es
>>
>> ________________________________
>>
>> Nota: A información contida nesta mensaxe e os seus posibles documentos adxuntos é privada e confidencial e está dirixida únicamente ó seu destinatario/a. Se vostede non é o/a destinatario/a orixinal desta mensaxe, por favor elimínea. A distribución ou copia desta mensaxe non está autorizada.
>>
>> Nota: La información contenida en este mensaje y sus posibles documentos adjuntos es privada y confidencial y está dirigida únicamente a su destinatario/a. Si usted no es el/la destinatario/a original de este mensaje, por favor elimínelo. La distribución o copia de este mensaje no está autorizada.
>>
>> See more languages: http://www.sergas.es/aviso_confidencialidad.htm
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>



mit freundlichen Grüßen
Clemens Klein-Robbenhaar

--
Clemens Klein-Robbenhaar
Software Development
EsPresto AG
Breite Str. 30-31
10178 Berlin/Germany
Tel: +49.(0)30.90 226.763
Fax: +49.(0)30.90 226.760
[hidden email]

HRB 77554 B - Berlin-Charlottenburg
Vorstand: Maya Biersack, Peter Biersack
Vorsitzender des Aufsichtsrats: Dipl.-Wirtsch.-Ing. Winfried Weber
Zertifiziert nach ISO 9001:2008
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: localization string missing - xe.blog.code.title

rrodriguezIDIS
Hi! Please, allow me to top post: it will be easier to summarise.

Clemens's answer did the trick. Here you'll see how my Blog.BlogSheet looked before editing its title as Clemens suggested...

http://goo.gl/k4T6ub

Now, after an upgrade to 6.4 and after editing the title it looks good...

http://idis1.idisantiago.es:8080/xwiki/bin/view/Blog/

I also come from a 5.x release. And I also remain clueless about the origin of the issue: all upgrades have been done by overwriting all pages with the new staff.

Hope this helps to learn what could had been wrong!

Thanks and cheers!

Ricardo

--
Ricardo Rodríguez
Research Management and Promotion Technician
Technical Secretariat
Health Research Institute of Santiago de Compostela (IDIS)
http://www.idisantiago.es

________________________________________
De: users [[hidden email]] en nombre de Clemens Klein-Robbenhaar [[hidden email]]
Enviado: martes, 11 de noviembre de 2014 15:39
Para: [hidden email]
Asunto: Re: [xwiki-users] localization string missing - xe.blog.code.title

On 11/11/2014 02:54 PM, Marius Dumitru Florea wrote:

> I don't have this problem. FYI, the Blog title comes from
> Blog.BlogSheet which uses this code
>
> #evaluate($!doc.getValue('title'))
>
> and the value of the title property (Blog.BlogClass) from Blog.WebHome is
>
> $services.localization.render('xe.blog.code.title')
>
> I guess #evaluate() fails in your case. But it's not related to
> missing translation. You would get 'xe.blog.code.title' displayed if
> the translation was really missing.
>

I can reproduce it with a wiki upgraded from 5.4.x (forgot which x) to 6.2
The problem is that the "#evaluate(...)" is missing in the title

To fix this manually, edit this page:

  http://idis1.idisantiago.es:8080/xwiki/bin/view/Blog/BlogSheet

In the "title" input field it might just read:

  $doc.getValue("title")

replace this with:

  #evaluate($doc.getValue("title"))

and the issue should go away.


I have to admit that I am a bit clueless why this might happen;
but in my case I suspect I messed around with import/export too much
and overwrote the BlogSheet with the wrong version ...

Hope this helps, too ;)
Clemens

> Hope this helps,
> Marius
>
> On Tue, Nov 11, 2014 at 3:32 PM,
> <[hidden email]> wrote:
>> Hi everybody!!!
>>
>> Please, allow me some small talk... I'm really happy to be here again once I've managed to get and start enjoying a brand new 6.2.4. XWiki installation!
>>
>> Only a detail: after following the evolution of the 6.x branch and having installed the new 6.2.4 release, a string seems to keep lacking affecting the renderization of Blog.WebHome.
>>
>> Here it is what I see not only here, but in a number of installations around the net...
>>
>> http://atriumkm.idisantiago.es/bin/download/ICT/Images/blogLocalizationMissingVariable.png
>>
>> I guess you get the same result by accessing directly this site...
>>
>> http://idis1.idisantiago.es:8080/xwiki/bin/view/Blog/
>>
>> Please, even though it is kind of a trivial problem not affecting, shouldn't it be fixed?
>>
>> Thanks!
>>
>> Ricardo
>>
>> --
>> Ricardo Rodríguez
>> Research Management and Promotion Technician
>> Technical Secretariat
>> Health Research Institute of Santiago de Compostela (IDIS)
>> http://www.idisantiago.es
>>
>> ________________________________
>>
>> Nota: A información contida nesta mensaxe e os seus posibles documentos adxuntos é privada e confidencial e está dirixida únicamente ó seu destinatario/a. Se vostede non é o/a destinatario/a orixinal desta mensaxe, por favor elimínea. A distribución ou copia desta mensaxe non está autorizada.
>>
>> Nota: La información contenida en este mensaje y sus posibles documentos adjuntos es privada y confidencial y está dirigida únicamente a su destinatario/a. Si usted no es el/la destinatario/a original de este mensaje, por favor elimínelo. La distribución o copia de este mensaje no está autorizada.
>>
>> See more languages: http://www.sergas.es/aviso_confidencialidad.htm
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>



mit freundlichen Grüßen
Clemens Klein-Robbenhaar

--
Clemens Klein-Robbenhaar
Software Development
EsPresto AG
Breite Str. 30-31
10178 Berlin/Germany
Tel: +49.(0)30.90 226.763
Fax: +49.(0)30.90 226.760
[hidden email]

HRB 77554 B - Berlin-Charlottenburg
Vorstand: Maya Biersack, Peter Biersack
Vorsitzender des Aufsichtsrats: Dipl.-Wirtsch.-Ing. Winfried Weber
Zertifiziert nach ISO 9001:2008
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users

________________________________

Nota: A información contida nesta mensaxe e os seus posibles documentos adxuntos é privada e confidencial e está dirixida únicamente ó seu destinatario/a. Se vostede non é o/a destinatario/a orixinal desta mensaxe, por favor elimínea. A distribución ou copia desta mensaxe non está autorizada.

Nota: La información contenida en este mensaje y sus posibles documentos adjuntos es privada y confidencial y está dirigida únicamente a su destinatario/a. Si usted no es el/la destinatario/a original de este mensaje, por favor elimínelo. La distribución o copia de este mensaje no está autorizada.

See more languages: http://www.sergas.es/aviso_confidencialidad.htm
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
--
Ricardo Rodríguez
Research Management and Promotion Technician
Technical Secretariat
Health Research Institute of Santiago de Compostela (IDIS)
http://www.idisantiago.es
Reply | Threaded
Open this post in threaded view
|

Re: localization string missing - xe.blog.code.title

Clemens Klein-Robbenhaar
Hi Ricardo,

 after some testing I have been able to reproduce the issue from a "clean" installation, so I created a bug report for it:

http://jira.xwiki.org/browse/XWIKI-11450

I have to admit that I have no idea (yet) what causes the issue.

Thank you very much for reporting the issue - knowing that something is not right is the first step in fixing it :)

Clemens

> Hi! Please, allow me to top post: it will be easier to summarise.
>
> Clemens's answer did the trick. Here you'll see how my Blog.BlogSheet looked before editing its title as Clemens suggested...
>
> http://goo.gl/k4T6ub
>
> Now, after an upgrade to 6.4 and after editing the title it looks good...
>
> http://idis1.idisantiago.es:8080/xwiki/bin/view/Blog/
>
> I also come from a 5.x release. And I also remain clueless about the origin of the issue: all upgrades have been done by overwriting all pages with the new staff.
>
> Hope this helps to learn what could had been wrong!
>
> Thanks and cheers!
>
> Ricardo
>
> --
> Ricardo Rodríguez
> Research Management and Promotion Technician
> Technical Secretariat
> Health Research Institute of Santiago de Compostela (IDIS)
> http://www.idisantiago.es
>
> ________________________________________
> De: users [[hidden email]] en nombre de Clemens Klein-Robbenhaar [[hidden email]]
> Enviado: martes, 11 de noviembre de 2014 15:39
> Para: [hidden email]
> Asunto: Re: [xwiki-users] localization string missing - xe.blog.code.title
>
> On 11/11/2014 02:54 PM, Marius Dumitru Florea wrote:
>> I don't have this problem. FYI, the Blog title comes from
>> Blog.BlogSheet which uses this code
>>
>> #evaluate($!doc.getValue('title'))
>>
>> and the value of the title property (Blog.BlogClass) from Blog.WebHome is
>>
>> $services.localization.render('xe.blog.code.title')
>>
>> I guess #evaluate() fails in your case. But it's not related to
>> missing translation. You would get 'xe.blog.code.title' displayed if
>> the translation was really missing.
>>
>
> I can reproduce it with a wiki upgraded from 5.4.x (forgot which x) to 6.2
> The problem is that the "#evaluate(...)" is missing in the title
>
> To fix this manually, edit this page:
>
>   http://idis1.idisantiago.es:8080/xwiki/bin/view/Blog/BlogSheet
>
> In the "title" input field it might just read:
>
>   $doc.getValue("title")
>
> replace this with:
>
>   #evaluate($doc.getValue("title"))
>
> and the issue should go away.
>
>
> I have to admit that I am a bit clueless why this might happen;
> but in my case I suspect I messed around with import/export too much
> and overwrote the BlogSheet with the wrong version ...
>
> Hope this helps, too ;)
> Clemens
>
>> Hope this helps,
>> Marius
>>
>> On Tue, Nov 11, 2014 at 3:32 PM,
>> <[hidden email]> wrote:
>>> Hi everybody!!!
>>>
>>> Please, allow me some small talk... I'm really happy to be here again once I've managed to get and start enjoying a brand new 6.2.4. XWiki installation!
>>>
>>> Only a detail: after following the evolution of the 6.x branch and having installed the new 6.2.4 release, a string seems to keep lacking affecting the renderization of Blog.WebHome.
>>>
>>> Here it is what I see not only here, but in a number of installations around the net...
>>>
>>> http://atriumkm.idisantiago.es/bin/download/ICT/Images/blogLocalizationMissingVariable.png
>>>
>>> I guess you get the same result by accessing directly this site...
>>>
>>> http://idis1.idisantiago.es:8080/xwiki/bin/view/Blog/
>>>
>>> Please, even though it is kind of a trivial problem not affecting, shouldn't it be fixed?
>>>
>>> Thanks!
>>>
>>> Ricardo
>>>
>>> --
>>> Ricardo Rodríguez
>>> Research Management and Promotion Technician
>>> Technical Secretariat
>>> Health Research Institute of Santiago de Compostela (IDIS)
>>> http://www.idisantiago.es
>>>
>>> ________________________________
>>>
>>> Nota: A información contida nesta mensaxe e os seus posibles documentos adxuntos é privada e confidencial e está dirixida únicamente ó seu destinatario/a. Se vostede non é o/a destinatario/a orixinal desta mensaxe, por favor elimínea. A distribución ou copia desta mensaxe non está autorizada.
>>>
>>> Nota: La información contenida en este mensaje y sus posibles documentos adjuntos es privada y confidencial y está dirigida únicamente a su destinatario/a. Si usted no es el/la destinatario/a original de este mensaje, por favor elimínelo. La distribución o copia de este mensaje no está autorizada.
>>>
>>> See more languages: http://www.sergas.es/aviso_confidencialidad.htm
>>> _______________________________________________
>>> users mailing list
>>> [hidden email]
>>> http://lists.xwiki.org/mailman/listinfo/users
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>
>
>
> mit freundlichen Grüßen
> Clemens Klein-Robbenhaar
>
> --
> Clemens Klein-Robbenhaar
> Software Development
> EsPresto AG
> Breite Str. 30-31
> 10178 Berlin/Germany
> Tel: +49.(0)30.90 226.763
> Fax: +49.(0)30.90 226.760
> [hidden email]
>
> HRB 77554 B - Berlin-Charlottenburg
> Vorstand: Maya Biersack, Peter Biersack
> Vorsitzender des Aufsichtsrats: Dipl.-Wirtsch.-Ing. Winfried Weber
> Zertifiziert nach ISO 9001:2008
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
> ________________________________
>
> Nota: A información contida nesta mensaxe e os seus posibles documentos adxuntos é privada e confidencial e está dirixida únicamente ó seu destinatario/a. Se vostede non é o/a destinatario/a orixinal desta mensaxe, por favor elimínea. A distribución ou copia desta mensaxe non está autorizada.
>
> Nota: La información contenida en este mensaje y sus posibles documentos adjuntos es privada y confidencial y está dirigida únicamente a su destinatario/a. Si usted no es el/la destinatario/a original de este mensaje, por favor elimínelo. La distribución o copia de este mensaje no está autorizada.
>
> See more languages: http://www.sergas.es/aviso_confidencialidad.htm
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>



mit freundlichen Grüßen
Clemens Klein-Robbenhaar

--
Clemens Klein-Robbenhaar
Software Development
EsPresto AG
Breite Str. 30-31
10178 Berlin/Germany
Tel: +49.(0)30.90 226.763
Fax: +49.(0)30.90 226.760
[hidden email]

HRB 77554 B - Berlin-Charlottenburg
Vorstand: Maya Biersack, Peter Biersack
Vorsitzender des Aufsichtsrats: Dipl.-Wirtsch.-Ing. Winfried Weber
Zertifiziert nach ISO 9001:2008
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users