log

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

log

raffovi
Hi all,

how can I enable the LOG in xwiki.

Thanks

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [xwiki-devs] log

vmassol
Administrator
Hi Raffaele,

On Jan 23, 2008, at 12:19 PM, Raffaele Viola wrote:

> Hi all,
>
> how can I enable the LOG in xwiki.

1) Please don't crosspost on both lists.
2) Can you try finding the answer on xwiki.org? I'd like to ensure  
this information can be easily found. If you can't find it let us know  
how you searched for it so that we can improve how users can find it.

Thanks
-Vincent


_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [xwiki-devs] log

rrodrigueznt
Vincent Massol wrote:
> Hi Raffaele,
>  
> 2) Can you try finding the answer on xwiki.org? I'd like to ensure  
> this information can be easily found. If you can't find it let us know  
> how you searched for it so that we can improve how users can find it.

Hi Vicent,

By going to Documentation > Documentation for XWiki Enterprise >
Administrator's Guide > Logging you reach this document...

http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Logging

But, why logging or log4J doesn't find anything in Search?

--
Ricardo Rodríguez
Your EPEC Network ICT Team

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [xwiki-devs] log

vmassol
Administrator

On Jan 23, 2008, at 2:27 PM, [Ricardo Rodriguez] Your EPEC Network ICT  
Team wrote:

> Vincent Massol wrote:
>> Hi Raffaele,
>>
>> 2) Can you try finding the answer on xwiki.org? I'd like to ensure
>> this information can be easily found. If you can't find it let us  
>> know
>> how you searched for it so that we can improve how users can find it.
>
> Hi Vicent,
>
> By going to Documentation > Documentation for XWiki Enterprise >
> Administrator's Guide > Logging you reach this document...
>
> http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Logging
>
> But, why logging or log4J doesn't find anything in Search?

That's because the lucene search is not fully working right now... I'm  
aware of this and Thomas Mortagne is working on this. I know he tried  
to fix this last week but wasn't able to find the issue till now.  
Basically some pages are not correctly indexed somehow.

We really need to crack this issue. It's annoying me as well...

Thanks
-Vincent

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [xwiki-devs] log

vmassol
Administrator

On Jan 23, 2008, at 2:35 PM, Vincent Massol wrote:

>
> On Jan 23, 2008, at 2:27 PM, [Ricardo Rodriguez] Your EPEC Network ICT
> Team wrote:
>
>> Vincent Massol wrote:
>>> Hi Raffaele,
>>>
>>> 2) Can you try finding the answer on xwiki.org? I'd like to ensure
>>> this information can be easily found. If you can't find it let us
>>> know
>>> how you searched for it so that we can improve how users can find  
>>> it.
>>
>> Hi Vicent,
>>
>> By going to Documentation > Documentation for XWiki Enterprise >
>> Administrator's Guide > Logging you reach this document...
>>
>> http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Logging
>>
>> But, why logging or log4J doesn't find anything in Search?
>
> That's because the lucene search is not fully working right now... I'm
> aware of this and Thomas Mortagne is working on this. I know he tried
> to fix this last week but wasn't able to find the issue till now.
> Basically some pages are not correctly indexed somehow.
>
> We really need to crack this issue. It's annoying me as well...

You can track it here:
http://jira.xwiki.org/jira/browse/XWIKI-2027

-Vincent

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [xwiki-devs] log

rrodrigueznt
In reply to this post by vmassol
Vincent Massol wrote:

>
> That's because the lucene search is not fully working right now... I'm  
> aware of this and Thomas Mortagne is working on this. I know he tried  
> to fix this last week but wasn't able to find the issue till now.  
> Basically some pages are not correctly indexed somehow.
>
> We really need to crack this issue. It's annoying me as well...
>
> Thanks
> -Vincent

Pity I am not able to help with this bug! :-(

By the way, I am seeing some Lucene related messages in catalina.out
after upgrading to 1.2. My main concern now is to work out what I see
like a problem while creating new virtual wikis, but I will go back to
the Lucene messages ASAP and keep this thread posted.

Thanks,

--
Ricardo Rodríguez
Your EPEC Network ICT Team

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: [xwiki-devs] log

Víctor A. Rodríguez (Bit-Man)
In reply to this post by raffovi
Hi Raffaele,

Raffaele Viola wrote:
Hi all,

how can I enable the LOG in xwiki.

Basically xwiki uses log4j as logging facility (http://logging.apache.org/log4j/).
To know how to enable logging take a look at http://platform.xwiki.org/xwiki/bin/view/AdminGuide/Logging

Hope this helps.
-- 
Víctor A. Rodríguez (http://www.bit-man.com.ar)
El bit Fantasma (Bit-Man) - Algorithm junkie
Perl Mongers Capital Federal (http://cafe.pm.org/)
GNU/Linux User Group - FCEyN - UBA (http://glugcen.dc.uba.ar/)

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users