new wiki, no users

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

new wiki, no users

basil-4
I performed a raw install: installed xwiki version 0.9.840 fresh on a Fedora Core Linux box with mySQL 4.0.26 and Tomcat 5.02.  After I finally figured out how to install mySQL everything went smoothly.  My wiki is up and running, and I started using it and building pages.

But I noticed that everything I was doing is as the user: XWikiGuest.  I want to create user accounts, and disable editing for anonymous guests.  So, I click on "register" it takes me to a completely blank page.  Just exactly like the blank pages you have when you've got a page and haven't put anything on it yet.  So, I click on "edit this page" and it looks exactly like I'm editing a normal page - in fact it lets me edit the page.  But no way to register new users.

So, I go to the user's page:  xwiki/bin/view/XWiki/XWikiUsers and it is completely blank too.  Exactly like the above, I can edit it and do what I want on it, but no user stuff.  So, I go back to my main page and click on "log in" and I try out the Admin password that is advertised on the support site user: "Admin" password: "admin" - and no dice.  It grinds away for 1 split second and gives me back my log-in screen with the words I just typed in missing.  No errors, nothing about bad passwords, nothing.

I looked all over the documentation and couldn't find anything helpful.

Ever seen this problem before?  Is there something somewhere on the documentation site that I could paste into those two pages, using "edit page" to make them work?

Thanks
Kevin Miller



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: new wiki, no users

Ludovic Dubost

Hi Kevin,

It might be the database import didn't went well or the initial database
was not the right one..
Which database did you import ?

The right one is
http://forge.objectweb.org/project/download.php?group_id=170&file_id=4615

Ludovic

[hidden email] wrote:

> I performed a raw install: installed xwiki version 0.9.840 fresh on a Fedora Core Linux box with mySQL 4.0.26 and Tomcat 5.02.  After I finally figured out how to install mySQL everything went smoothly.  My wiki is up and running, and I started using it and building pages.
>
> But I noticed that everything I was doing is as the user: XWikiGuest.  I want to create user accounts, and disable editing for anonymous guests.  So, I click on "register" it takes me to a completely blank page.  Just exactly like the blank pages you have when you've got a page and haven't put anything on it yet.  So, I click on "edit this page" and it looks exactly like I'm editing a normal page - in fact it lets me edit the page.  But no way to register new users.
>
> So, I go to the user's page:  xwiki/bin/view/XWiki/XWikiUsers and it is completely blank too.  Exactly like the above, I can edit it and do what I want on it, but no user stuff.  So, I go back to my main page and click on "log in" and I try out the Admin password that is advertised on the support site user: "Admin" password: "admin" - and no dice.  It grinds away for 1 split second and gives me back my log-in screen with the words I just typed in missing.  No errors, nothing about bad passwords, nothing.
>
> I looked all over the documentation and couldn't find anything helpful.
>
> Ever seen this problem before?  Is there something somewhere on the documentation site that I could paste into those two pages, using "edit page" to make them work?
>
> Thanks
> Kevin Miller
>
>  
> ------------------------------------------------------------------------
>
>
> --
> You receive this message as a subscriber of the [hidden email] mailing list.
> To unsubscribe: mailto:[hidden email]
> For general help: mailto:[hidden email]?subject=help
> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>  

--
Ludovic Dubost
XPertNet: http://www.xpertnet.fr/
Blog: http://www.ludovic.org/blog/
XWiki: http://www.xwiki.com
Skype: ldubost AIM: nvludo Yahoo: ludovic




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws