permissions issue

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

permissions issue

pinkerp
I am struggling with a page permissions issue.  What am I doing wrong here?

I have done this before, but it doesn't seem to be working this time.

I have a SPACE that is only available to a specific GROUP.  That seems to be working just fine.
I have a PAGE in that SPACE that I only want a specific USER (in the GROUP) to be able to access.  

I set the permissions for the GROUP to deny on that PAGE and explicitly gave the USER permission.

The issue is that anyone in the GROUP can still ACCESS the PAGE.

Am I missing something?

Paul Pinkerton
KnowledgeNow Project Lead
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: permissions issue

vmassol
Administrator
 




On 12 Nov 2014 at 21:35:51, Paul Pinkerton (ACLCO) ([hidden email](mailto:[hidden email])) wrote:

> I am struggling with a page permissions issue. What am I doing wrong here?
>  
> I have done this before, but it doesn't seem to be working this time.
>  
> I have a SPACE that is only available to a specific GROUP. That seems to be working just fine.
> I have a PAGE in that SPACE that I only want a specific USER (in the GROUP) to be able to access.
>  
> I set the permissions for the GROUP to deny on that PAGE and explicitly gave the USER permission.
>  
> The issue is that anyone in the GROUP can still ACCESS the PAGE.
>  
> Am I missing something?

Normally just giving the view right to that page to that specific user is enough to prevent anyone else from viewing it, no need to use any deny right.

Thanks
-Vincent

>  
> Paul Pinkerton
> KnowledgeNow Project Lead

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: permissions issue

Clemens Klein-Robbenhaar
In reply to this post by pinkerp
On 11/12/2014 09:35 PM, Paul Pinkerton (ACLCO) wrote:

> I am struggling with a page permissions issue.  What am I doing wrong here?
>
> I have done this before, but it doesn't seem to be working this time.
>
> I have a SPACE that is only available to a specific GROUP.  That seems to be working just fine.
> I have a PAGE in that SPACE that I only want a specific USER (in the GROUP) to be able to access.  
>
> I set the permissions for the GROUP to deny on that PAGE and explicitly gave the USER permission.
>
> The issue is that anyone in the GROUP can still ACCESS the PAGE.
>
> Am I missing something?

Is there any chance this might be the same as http://jira.xwiki.org/browse/XWIKI-11355
"Sometimes rights changes don't apply without a server restart"

I.e. could you please try to restart the server and see if the permissions behave as expected afterwards?

If restarting helps, then it would be interesting to get as much information as possible, so the issue can be fixed.
(I just tried to reproduce but was not able to - maybe the problem is only triggered if the clicks happen in a very specific order)

Clemens
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users