xEclipse login problem

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

xEclipse login problem

Omar Morales
Hello there,

I asked the Admin of my system to create a space in xWiki, into which I can log in via my username & pswd through a browser. I cannot create a connection to the same space via xEclipse.

Any idea about how to cope with it?

Thanks,
Omar.-


"Error connecting to remote XWiki: 'Failed to create input stream: Server returned HTTP response code: 401 for URL:https://wiki.LLLLLLLL.HH/xwiki/bin/login/XWiki/XWikiLogin;jsessionid=9ABDC68E028A86AF510B64DDE1B313D6?srid=impUiQ5i'. Please check your settings."
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: xEclipse login problem

Eduard Moraru-2
Hello Omar,

What endpoint did you use to create the XEclipse connection?

If you used
"https://wiki.LLLLLLLL.HH/xwiki/bin/login/XWiki/XWikiLogin;jsessionid=9ABDC68E028A86AF510B64DDE1B313D6?srid=impUiQ5i"
then that could be your problem.

When creating a new XEclipse connection, the endpoint for the wiki is
the same, no matter what access you have.
So use: "https://wiki.LLLLLLLL.HH/xwiki/xmlrpc/confluence" as endpoint
and specify your user and password.

After creating this connection, you should be able to navigate to and
use the space where you have been granted access.

Thanks,
Eduard

On 03/29/2010 06:54 PM, Omar Morales wrote:

> Hello there,
>
> I asked the Admin of my system to create a space in xWiki, into which I can log in via my username&  pswd through a browser. I cannot create a connection to the same space via xEclipse.
>
> Any idea about how to cope with it?
>
> Thanks,
> Omar.-
>
>
> "Error connecting to remote XWiki: 'Failed to create input stream: Server returned HTTP response code: 401 for URL:https://wiki.LLLLLLLL.HH/xwiki/bin/login/XWiki/XWikiLogin;jsessionid=9ABDC68E028A86AF510B64DDE1B313D6?srid=impUiQ5i'. Please check your settings."
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
>    

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: xEclipse login problem

Omar Morales
Hello there!

I fixed the problem ... after a mate of mine explained to me the meaning of "xmlrpc" ...

Anyway thank you for the help.

Omar.-


p.s. and how about re-crafting the connector so that it is just necessary to input where the wiki is (e.g. wiki.LLLLLLLL.HH)?


On Apr 6, 2010, at 12:58 PM, Eduard Moraru wrote:

> Hello Omar,
>
> What endpoint did you use to create the XEclipse connection?
>
> If you used
> "https://wiki.LLLLLLLL.HH/xwiki/bin/login/XWiki/XWikiLogin;jsessionid=9ABDC68E028A86AF510B64DDE1B313D6?srid=impUiQ5i"
> then that could be your problem.
>
> When creating a new XEclipse connection, the endpoint for the wiki is
> the same, no matter what access you have.
> So use: "https://wiki.LLLLLLLL.HH/xwiki/xmlrpc/confluence" as endpoint
> and specify your user and password.
>
> After creating this connection, you should be able to navigate to and
> use the space where you have been granted access.
>
> Thanks,
> Eduard
>
> On 03/29/2010 06:54 PM, Omar Morales wrote:
>> Hello there,
>>
>> I asked the Admin of my system to create a space in xWiki, into which I can log in via my username&  pswd through a browser. I cannot create a connection to the same space via xEclipse.
>>
>> Any idea about how to cope with it?
>>
>> Thanks,
>> Omar.-
>>
>>
>> "Error connecting to remote XWiki: 'Failed to create input stream: Server returned HTTP response code: 401 for URL:https://wiki.LLLLLLLL.HH/xwiki/bin/login/XWiki/XWikiLogin;jsessionid=9ABDC68E028A86AF510B64DDE1B313D6?srid=impUiQ5i'. Please check your settings."
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>>
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: xEclipse login problem

Eduard Moraru-2
Hello again,

On 04/07/2010 12:35 PM, Omar Morales wrote:

> Hello there!
>
> I fixed the problem ... after a mate of mine explained to me the meaning of "xmlrpc" ...
>
> Anyway thank you for the help.
>
> Omar.-
>
>
> p.s. and how about re-crafting the connector so that it is just necessary to input where the wiki is (e.g. wiki.LLLLLLLL.HH)?
>    
Well, there are some problems here:

1) The first one would be that you could install your xwiki under
another webApp directory and, instead of
"https://wiki.LLLLLLLL.HH/xwiki/xmlrpc/confluence" you would have
"https://wiki.LLLLLLLL.HH/myXWikiInstallation/xmlrpc/confluence".

2) Another reason would be in a multi-wiki installation where you would
have roughly the same problem as in 1)

3) As far as I remember, XEclipse should be compatible with confluence
as well, so the same URL pattern may not apply there either.

4) You might have either http or https set up. etc.

Some UI tricks could be done do automatically suggest the XMLRPC URL
endpoint allowing further user customisations.

I have added this issue to the XEclipse TODO list.

You can monitor, vote for it or even fix it yourself and then share the
modifications at this address:
http://jira.xwiki.org/jira/browse/XECLIPSE-147

Thanks,
Eduard

>
> On Apr 6, 2010, at 12:58 PM, Eduard Moraru wrote:
>
>    
>> Hello Omar,
>>
>> What endpoint did you use to create the XEclipse connection?
>>
>> If you used
>> "https://wiki.LLLLLLLL.HH/xwiki/bin/login/XWiki/XWikiLogin;jsessionid=9ABDC68E028A86AF510B64DDE1B313D6?srid=impUiQ5i"
>> then that could be your problem.
>>
>> When creating a new XEclipse connection, the endpoint for the wiki is
>> the same, no matter what access you have.
>> So use: "https://wiki.LLLLLLLL.HH/xwiki/xmlrpc/confluence" as endpoint
>> and specify your user and password.
>>
>> After creating this connection, you should be able to navigate to and
>> use the space where you have been granted access.
>>
>> Thanks,
>> Eduard
>>
>> On 03/29/2010 06:54 PM, Omar Morales wrote:
>>      
>>> Hello there,
>>>
>>> I asked the Admin of my system to create a space in xWiki, into which I can log in via my username&   pswd through a browser. I cannot create a connection to the same space via xEclipse.
>>>
>>> Any idea about how to cope with it?
>>>
>>> Thanks,
>>> Omar.-
>>>
>>>
>>> "Error connecting to remote XWiki: 'Failed to create input stream: Server returned HTTP response code: 401 for URL:https://wiki.LLLLLLLL.HH/xwiki/bin/login/XWiki/XWikiLogin;jsessionid=9ABDC68E028A86AF510B64DDE1B313D6?srid=impUiQ5i'. Please check your settings."
>>> _______________________________________________
>>> users mailing list
>>> [hidden email]
>>> http://lists.xwiki.org/mailman/listinfo/users
>>>
>>>
>>>        
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>>      
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>
>    

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: xEclipse login problem

Omar Morales
That's great mate!

On Apr 7, 2010, at 12:47 PM, Eduard Moraru wrote:

> Hello again,
>
> On 04/07/2010 12:35 PM, Omar Morales wrote:
>> Hello there!
>>
>> I fixed the problem ... after a mate of mine explained to me the meaning of "xmlrpc" ...
>>
>> Anyway thank you for the help.
>>
>> Omar.-
>>
>>
>> p.s. and how about re-crafting the connector so that it is just necessary to input where the wiki is (e.g. wiki.LLLLLLLL.HH)?
>>
> Well, there are some problems here:
>
> 1) The first one would be that you could install your xwiki under
> another webApp directory and, instead of
> "https://wiki.LLLLLLLL.HH/xwiki/xmlrpc/confluence" you would have
> "https://wiki.LLLLLLLL.HH/myXWikiInstallation/xmlrpc/confluence".
>
> 2) Another reason would be in a multi-wiki installation where you would
> have roughly the same problem as in 1)
>
> 3) As far as I remember, XEclipse should be compatible with confluence
> as well, so the same URL pattern may not apply there either.
>
> 4) You might have either http or https set up. etc.
>
> Some UI tricks could be done do automatically suggest the XMLRPC URL
> endpoint allowing further user customisations.
>
> I have added this issue to the XEclipse TODO list.
>
> You can monitor, vote for it or even fix it yourself and then share the
> modifications at this address:
> http://jira.xwiki.org/jira/browse/XECLIPSE-147
>
> Thanks,
> Eduard
>
>>
>> On Apr 6, 2010, at 12:58 PM, Eduard Moraru wrote:
>>
>>
>>> Hello Omar,
>>>
>>> What endpoint did you use to create the XEclipse connection?
>>>
>>> If you used
>>> "https://wiki.LLLLLLLL.HH/xwiki/bin/login/XWiki/XWikiLogin;jsessionid=9ABDC68E028A86AF510B64DDE1B313D6?srid=impUiQ5i"
>>> then that could be your problem.
>>>
>>> When creating a new XEclipse connection, the endpoint for the wiki is
>>> the same, no matter what access you have.
>>> So use: "https://wiki.LLLLLLLL.HH/xwiki/xmlrpc/confluence" as endpoint
>>> and specify your user and password.
>>>
>>> After creating this connection, you should be able to navigate to and
>>> use the space where you have been granted access.
>>>
>>> Thanks,
>>> Eduard
>>>
>>> On 03/29/2010 06:54 PM, Omar Morales wrote:
>>>
>>>> Hello there,
>>>>
>>>> I asked the Admin of my system to create a space in xWiki, into which I can log in via my username&   pswd through a browser. I cannot create a connection to the same space via xEclipse.
>>>>
>>>> Any idea about how to cope with it?
>>>>
>>>> Thanks,
>>>> Omar.-
>>>>
>>>>
>>>> "Error connecting to remote XWiki: 'Failed to create input stream: Server returned HTTP response code: 401 for URL:https://wiki.LLLLLLLL.HH/xwiki/bin/login/XWiki/XWikiLogin;jsessionid=9ABDC68E028A86AF510B64DDE1B313D6?srid=impUiQ5i'. Please check your settings."
>>>> _______________________________________________
>>>> users mailing list
>>>> [hidden email]
>>>> http://lists.xwiki.org/mailman/listinfo/users
>>>>
>>>>
>>>>
>>> _______________________________________________
>>> users mailing list
>>> [hidden email]
>>> http://lists.xwiki.org/mailman/listinfo/users
>>>
>>>
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users
>>
>>
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users
>

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users