xeclipse problem

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

xeclipse problem

Bubulina
    Hello!
Did anyone encoutered such a problem with XEclipse?
My operating system is: Windows XP
Java: java 6 update 4
Xeclipse version: xwiki-eclipse-rcp-win32-win32-x86-1.1

xeclipse log:
!SESSION 2008-05-23 10:59:36.078 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_04
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=ro_RO
Command-line arguments:  -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.core.runtime 2 0 2008-05-23 10:59:37.234
!MESSAGE Authorization infrastructure (org.eclipse.core.runtime.compatibility.auth) not installed.
!STACK 0
java.lang.NoClassDefFoundError: org/eclipse/core/internal/runtime/auth/AuthorizationHandler
    at org.eclipse.core.internal.runtime.InternalPlatform.initializeAuthorizationHandler(InternalPlatform.java:603)
    at org.eclipse.core.internal.runtime.InternalPlatform.start(InternalPlatform.java:745)
    at org.eclipse.core.internal.runtime.PlatformActivator.start(PlatformActivator.java:31)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl$2.run(BundleContextImpl.java:999)
    at java.security.AccessController.doPrivileged(Native Method)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:993)
    at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:974)
    at org.eclipse.osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:346)
    at org.eclipse.osgi.framework.internal.core.AbstractBundle.resume(AbstractBundle.java:350)
    at org.eclipse.osgi.framework.internal.core.Framework.resumeBundle(Framework.java:1118)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.resumeBundles(StartLevelManager.java:634)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282)
    at org.eclipse.osgi.framework.internal.core.StartLevelManager.dispatchEvent(StartLevelManager.java:468)
    at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
    at org.eclipse.osgi.framework.eventmgr.EventManager$EventThread.run(EventManager.java:297)
Caused by: java.lang.ClassNotFoundException: org.eclipse.core.internal.runtime.auth.AuthorizationHandler
    at java.lang.ClassLoader.findClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClassInternal(BundleLoader.java:429)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
    at org.eclipse.osgi.framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
    at org.eclipse.osgi.internal.baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
    at java.lang.ClassLoader.loadClass(Unknown Source)
    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
    ... 16 more


I cannot connect to any server. and I haven't got a clue of what is that.
THX!





Take care ,
    Gabriela Radu :)
www.gabrielaradu.com


       
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: xeclipse problem

vmassol
Administrator
You probably don't have the correct version of eclipse our you're  
missing some stuff. Make sure you're using a supported Eclipse version  
if you're using the xeclipse plugin (and not the RCP version).
You could also try to use the xeclipse standalone version.

Thanks
-Vincent

On May 23, 2008, at 10:09 AM, Gabriela Radu wrote:

>    Hello!
> Did anyone encoutered such a problem with XEclipse?
> My operating system is: Windows XP
> Java: java 6 update 4
> Xeclipse version: xwiki-eclipse-rcp-win32-win32-x86-1.1
>
> xeclipse log:
> !SESSION 2008-05-23 10:59:36.078  
> -----------------------------------------------
> eclipse.buildId=unknown
> java.version=1.6.0_04
> java.vendor=Sun Microsystems Inc.
> BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=ro_RO
> Command-line arguments:  -os win32 -ws win32 -arch x86
>
> !ENTRY org.eclipse.core.runtime 2 0 2008-05-23 10:59:37.234
> !MESSAGE Authorization infrastructure  
> (org.eclipse.core.runtime.compatibility.auth) not installed.
> !STACK 0
> java.lang.NoClassDefFoundError: org/eclipse/core/internal/runtime/
> auth/AuthorizationHandler
>    at  
> org
> .eclipse
> .core
> .internal
> .runtime
> .InternalPlatform
> .initializeAuthorizationHandler(InternalPlatform.java:603)
>    at  
> org
> .eclipse
> .core.internal.runtime.InternalPlatform.start(InternalPlatform.java:
> 745)
>    at  
> org
> .eclipse
> .core
> .internal.runtime.PlatformActivator.start(PlatformActivator.java:31)
>    at org.eclipse.osgi.framework.internal.core.BundleContextImpl
> $2.run(BundleContextImpl.java:999)
>    at java.security.AccessController.doPrivileged(Native Method)
>    at  
> org
> .eclipse
> .osgi
> .framework
> .internal
> .core.BundleContextImpl.startActivator(BundleContextImpl.java:993)
>    at  
> org
> .eclipse
> .osgi
> .framework
> .internal.core.BundleContextImpl.start(BundleContextImpl.java:974)
>    at  
> org
> .eclipse
> .osgi.framework.internal.core.BundleHost.startWorker(BundleHost.java:
> 346)
>    at  
> org
> .eclipse
> .osgi
> .framework.internal.core.AbstractBundle.resume(AbstractBundle.java:
> 350)
>    at  
> org
> .eclipse
> .osgi.framework.internal.core.Framework.resumeBundle(Framework.java:
> 1118)
>    at  
> org
> .eclipse
> .osgi
> .framework
> .internal
> .core.StartLevelManager.resumeBundles(StartLevelManager.java:634)
>    at  
> org
> .eclipse
> .osgi
> .framework
> .internal.core.StartLevelManager.incFWSL(StartLevelManager.java:508)
>    at  
> org
> .eclipse
> .osgi
> .framework
> .internal
> .core.StartLevelManager.doSetStartLevel(StartLevelManager.java:282)
>    at  
> org
> .eclipse
> .osgi
> .framework
> .internal
> .core.StartLevelManager.dispatchEvent(StartLevelManager.java:468)
>    at  
> org
> .eclipse
> .osgi
> .framework.eventmgr.EventManager.dispatchEvent(EventManager.java:195)
>    at org.eclipse.osgi.framework.eventmgr.EventManager
> $EventThread.run(EventManager.java:297)
> Caused by: java.lang.ClassNotFoundException:  
> org.eclipse.core.internal.runtime.auth.AuthorizationHandler
>    at java.lang.ClassLoader.findClass(Unknown Source)
>    at java.lang.ClassLoader.loadClass(Unknown Source)
>    at java.lang.ClassLoader.loadClass(Unknown Source)
>    at  
> org
> .eclipse
> .osgi
> .framework
> .internal.core.BundleLoader.findClassInternal(BundleLoader.java:429)
>    at  
> org
> .eclipse
> .osgi
> .framework.internal.core.BundleLoader.findClass(BundleLoader.java:369)
>    at  
> org
> .eclipse
> .osgi
> .framework.internal.core.BundleLoader.findClass(BundleLoader.java:357)
>    at  
> org
> .eclipse
> .osgi
> .internal
> .baseadaptor.DefaultClassLoader.loadClass(DefaultClassLoader.java:83)
>    at java.lang.ClassLoader.loadClass(Unknown Source)
>    at java.lang.ClassLoader.loadClassInternal(Unknown Source)
>    ... 16 more
>
>
> I cannot connect to any server. and I haven't got a clue of what is  
> that.
> THX!
>
>
>
>
>
> Take care ,
>    Gabriela Radu :)
> www.gabrielaradu.com
>
>
>
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users

_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users