Quantcast

xwiki 8.4.4 and office presentation viewer problem

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

xwiki 8.4.4 and office presentation viewer problem

PascalB
Hello,

I have a problem with office presentation viewer. It is not displayed presentation slides when I use it because the jpg url is incorrect.

I use a tomcat server and proxy-ajp on apache2 (i followed xwiki doc)

My xwiki is on root of my server name.

If I click on the eye icone from an odp file in a page, my browser goint to this url: (under /bin/view/):
http://my.server.name.fr/bin/view/Encyclop%C3%A9die/Agenda%20du%20management%20de%20la%20qualit%C3%A9%20au%20CP2I?xpage=office&attachment=04072016-r%C3%A9union%20du%20r%C3%A9seau%20des%20auditeurs-VT-VDB-ME.odp
 but didn't display slide .

I saw with firebug that my browser didn't manage to display jpg file generated by xwiki: (/tmp)
http://my.server.name.fr/tmp/officeviewer/document%3Axwiki%3AEncyclop%C3%A9die.Agenda+du+management+de+la+qualit%C3%A9+au+CP2I/0/04072016-r%C3%A9union+du+r%C3%A9seau+des+auditeurs-VT-VDB-ME-slide0.jpg

I use this in my server.xml:
    <Engine name="Catalina" defaultHost="my.server.name.fr">
      <Host name="my.server.name.fr"
            appBase="webapps"
            workDir="/home/path/work">

and found target jpg file on /home/path/work/ROOT/xwiki-temp/tmp/officeviewer/xwiki/xxxxxx subdirectory

I didn't found source of this error.

If someone could help me?

Thxs

Pascal B



Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: xwiki 8.4.4 and office presentation viewer problem

PascalB
My Apache log show  403 errors for slidexx.jpg.

My IP - - [03/Apr/2017:15:52:05 +0200] "GET /tmp/officeviewer/document%3Axwiki%3AEncyclop%C3%A9die.Agenda+du+management+de+la+qualit%C3%A9+au+CP2I/0/04072016-r%C3%A9union+du+r%C3%A9seau+des+auditeurs-VT-VDB-ME-slide0.jpg HTTP/1.1" 403 1510 "https://iwiki-preprod.din.developpement-durable.gouv.fr/bin/view/Encyclop%C3%A9die/Agenda%20du%20management%20de%20la%20qualit%C3%A9%20au%20CP2I?xpage=office&attachment=04072016-r%C3%A9union%20du%20r%C3%A9seau%20des%20auditeurs-VT-VDB-ME.odp" "Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0"

slidexx*.jpg generated by LibreOffice are well created in the filesystem.
I can upload/download xwiki files in pages attachments.

When I access to tomcat without pass through AJP/Apache (http://MyServer:8080/bin/view/Encyclop%C3%A9die/Agenda%20du%20management%20de%20la%20qualit%C3%A9%20au%20CP2I?xpage=office&attachment=04072016-r%C3%A9union%20du%20r%C3%A9seau%20des%20auditeurs-VT-VDB-ME.odp

I have the same error/problem: jpg slide are not displayed

Any clue or a way to identify the origin of my problem?

Thxs


--------------------------------------------
En date de : Mer 29.3.17, Pascal BASTIEN <[hidden email]> a écrit :

 Objet: xwiki 8.4.4 and office presentation viewer problem
 À: "XWiki Users" <[hidden email]>
 Date: Mercredi 29 mars 2017, 14h19
 
 Hello,
 
 I have a problem with office presentation viewer. It is not
 displayed presentation slides when I use it because the jpg
 url is incorrect.
 
 I use a tomcat server and proxy-ajp on apache2 (i followed
 xwiki doc)
 
 My xwiki is on root of my server name.
 
 If I click on the eye icone from an odp file in a page, my
 browser goint to this url: (under /bin/view/):
 http://my.server.name.fr/bin/view/Encyclop%C3%A9die/Agenda%20du%20management%20de%20la%20qualit%C3%A9%20au%20CP2I?xpage=office&attachment=04072016-r%C3%A9union%20du%20r%C3%A9seau%20des%20auditeurs-VT-VDB-ME.odp
  but didn't display slide .
 
 I saw with firebug that my browser didn't manage to display
 jpg file generated by xwiki: (/tmp)
 http://my.server.name.fr/tmp/officeviewer/document%3Axwiki%3AEncyclop%C3%A9die.Agenda+du+management+de+la+qualit%C3%A9+au+CP2I/0/04072016-r%C3%A9union+du+r%C3%A9seau+des+auditeurs-VT-VDB-ME-slide0.jpg
 
 I use this in my server.xml:
     <Engine name="Catalina"
 defaultHost="my.server.name.fr">
       <Host name="my.server.name.fr"
             appBase="webapps"
            
 workDir="/home/path/work">
 
 and found target jpg file on
 /home/path/work/ROOT/xwiki-temp/tmp/officeviewer/xwiki/xxxxxx
 subdirectory
 
 I didn't found source of this error.
 
 If someone could help me?
 
 Thxs
 
 Pascal B
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: xwiki 8.4.4 and office presentation viewer problem

PascalB
In reply to this post by PascalB
Here, https://jira.xwiki.org/browse/XCOMMONS-1185

--------------------------------------------
En date de : Lun 3.4.17, Pascal BASTIEN <[hidden email]> a écrit :

 Objet: Re : xwiki 8.4.4 and office presentation viewer problem
 À: "XWiki Users" <[hidden email]>
 Date: Lundi 3 avril 2017, 16h02
 
 My Apache log show  403 errors for
 slidexx.jpg.
 
 My IP - - [03/Apr/2017:15:52:05 +0200]
 "GET
 /tmp/officeviewer/document%3Axwiki%3AEncyclop%C3%A9die.Agenda+du+management+de+la+qualit%C3%A9+au+CP2I/0/04072016-r%C3%A9union+du+r%C3%A9seau+des+auditeurs-VT-VDB-ME-slide0.jpg
 HTTP/1.1" 403 1510 "https://iwiki-preprod.din.developpement-durable.gouv.fr/bin/view/Encyclop%C3%A9die/Agenda%20du%20management%20de%20la%20qualit%C3%A9%20au%20CP2I?xpage=office&attachment=04072016-r%C3%A9union%20du%20r%C3%A9seau%20des%20auditeurs-VT-VDB-ME.odp"
 "Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101
 Firefox/45.0"
 
 slidexx*.jpg generated by LibreOffice
 are well created in the filesystem.
 I can upload/download xwiki files in
 pages attachments.
 
 When I access to tomcat without pass
 through AJP/Apache (http://MyServer:8080/bin/view/Encyclop%C3%A9die/Agenda%20du%20management%20de%20la%20qualit%C3%A9%20au%20CP2I?xpage=office&attachment=04072016-r%C3%A9union%20du%20r%C3%A9seau%20des%20auditeurs-VT-VDB-ME.odp
 
 I have the same error/problem: jpg
 slide are not displayed
 
 Any clue or a way to identify the
 origin of my problem?
 
 Thxs
 
 
 --------------------------------------------
 En date de : Mer 29.3.17, Pascal
 BASTIEN <[hidden email]>
 a écrit :
 
  Objet: xwiki 8.4.4 and office
 presentation viewer problem
  À: "XWiki Users" <[hidden email]>
  Date: Mercredi 29 mars 2017, 14h19
 
  Hello,
 
  I have a problem with office
 presentation viewer. It is not
  displayed presentation slides when I
 use it because the jpg
  url is incorrect.
 
  I use a tomcat server and proxy-ajp on
 apache2 (i followed
  xwiki doc)
 
  My xwiki is on root of my server
 name.
 
  If I click on the eye icone from an
 odp file in a page, my
  browser goint to this url: (under
 /bin/view/):
  http://my.server.name.fr/bin/view/Encyclop%C3%A9die/Agenda%20du%20management%20de%20la%20qualit%C3%A9%20au%20CP2I?xpage=office&attachment=04072016-r%C3%A9union%20du%20r%C3%A9seau%20des%20auditeurs-VT-VDB-ME.odp
   but didn't display slide .
 
  I saw with firebug that my browser
 didn't manage to display
  jpg file generated by xwiki: (/tmp)
  http://my.server.name.fr/tmp/officeviewer/document%3Axwiki%3AEncyclop%C3%A9die.Agenda+du+management+de+la+qualit%C3%A9+au+CP2I/0/04072016-r%C3%A9union+du+r%C3%A9seau+des+auditeurs-VT-VDB-ME-slide0.jpg
 
  I use this in my server.xml:
      <Engine name="Catalina"
  defaultHost="my.server.name.fr">
        <Host
 name="my.server.name.fr"
              appBase="webapps"
             
  workDir="/home/path/work">
 
  and found target jpg file on
 
 /home/path/work/ROOT/xwiki-temp/tmp/officeviewer/xwiki/xxxxxx
  subdirectory
 
  I didn't found source of this error.
 
  If someone could help me?
 
  Thxs
 
  Pascal B
Loading...