xwiki build.256 Build Successful

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

xwiki build.256 Build Successful

Ludovic Dubost-2
View results here -> http://build.xpertnet.biz/cc/buildresults/xwiki?log=log20060816103038Lbuild.256



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Database update

Youcef Bey-2

Hi all,

I have installed the new XWiki version. In fact, I used an old version and
try to update with the new one (xwiki-0.9.1252).

But, I found that the new database is a script file stored in ../db
directory! And check before the the MySQL databases but not find any xwiki
database, even I have removed the MySQL installation but the xwiki work!!

What's kind of database is used in the new XWiki version? And how updating
it from the old MySQL database.

Many thanks in advance.

Youcef
 





--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: Database update

jeremi joslin
On 8/16/06, Youcef Bey <[hidden email]> wrote:

>
> Hi all,
>
> I have installed the new XWiki version. In fact, I used an old version and
> try to update with the new one (xwiki-0.9.1252).
>
> But, I found that the new database is a script file stored in ../db
> directory! And check before the the MySQL databases but not find any xwiki
> database, even I have removed the MySQL installation but the xwiki work!!
>
> What's kind of database is used in the new XWiki version? And how updating
> it from the old MySQL database.
>
Hi,
which package are you using? do you use jetty or the installer? if
yes, XWIki is using hsqldb as database. You can still use mysql.

give a look to the configuration file, it's the one you need to modify
(hibernate.cfg.xml) :
http://svn.forge.objectweb.org/cgi-bin/viewcvs.cgi/xwiki/xwiki/tags/XWIKI_0_9_1252/src/main/web/WEB-INF/hibernate.cfg.xml?view=markup&rev=1086

change the "connection.url" of your installation. you can also look on
your old installation, and replace this file.


--
jeremi



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws