xwiki.cfg seems not to be applied?

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

xwiki.cfg seems not to be applied?

Florian Rustedt
Hello list,

In /etc/xwiki/xwiki.cfg I modified
* xwiki.defaultWeb
* xwiki.defaultPage
* and xwiki.showviewaction,
but none of them has been applied after I restarted tomcat?

Anyone else got similar issues on Ubuntu (12.04 LTS)?
Do I have to trigger something else to apply it?

Best regards
Florian
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: xwiki.cfg seems not to be applied?

Thomas Mortagne
Administrator
On Thu, May 31, 2012 at 3:46 PM, Florian Rustedt
<[hidden email]> wrote:

> Hello list,
>
> In /etc/xwiki/xwiki.cfg I modified
> * xwiki.defaultWeb
> * xwiki.defaultPage
> * and xwiki.showviewaction,
> but none of them has been applied after I restarted tomcat?
>
> Anyone else got similar issues on Ubuntu (12.04 LTS)?
> Do I have to trigger something else to apply it?

Did you uncommented them ?

>
> Best regards
> Florian
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users



--
Thomas Mortagne
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: xwiki.cfg seems not to be applied?

Florian Rustedt
:)

Sure

-----Ursprüngliche Nachricht-----
Von: [hidden email] [mailto:[hidden email]] Im Auftrag von Thomas Mortagne
Gesendet: Donnerstag, 31. Mai 2012 15:56
An: XWiki Users
Betreff: Re: [xwiki-users] xwiki.cfg seems not to be applied?

On Thu, May 31, 2012 at 3:46 PM, Florian Rustedt <[hidden email]> wrote:

> Hello list,
>
> In /etc/xwiki/xwiki.cfg I modified
> * xwiki.defaultWeb
> * xwiki.defaultPage
> * and xwiki.showviewaction,
> but none of them has been applied after I restarted tomcat?
>
> Anyone else got similar issues on Ubuntu (12.04 LTS)?
> Do I have to trigger something else to apply it?

Did you uncommented them ?

>
> Best regards
> Florian
> _______________________________________________
> users mailing list
> [hidden email]
> http://lists.xwiki.org/mailman/listinfo/users



--
Thomas Mortagne
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: xwiki.cfg seems not to be applied?

Sergiu Dumitriu-2
In reply to this post by Florian Rustedt
On 05/31/2012 09:46 AM, Florian Rustedt wrote:

> Hello list,
>
> In /etc/xwiki/xwiki.cfg I modified
> * xwiki.defaultWeb
> * xwiki.defaultPage
> * and xwiki.showviewaction,
> but none of them has been applied after I restarted tomcat?
>
> Anyone else got similar issues on Ubuntu (12.04 LTS)?
> Do I have to trigger something else to apply it?

The effect of xwiki.showviewaction should be visible almost right away.
Note that URLs with the /view/ part in them will still work, and there
won't be any redirection from an URL with /view/ to an URL without it.
But clicking on wiki links should point to non-/view/ URLs.

The other two are pretty much useless... Since getting access to the
configured values is hard, most of the code doesn't take them into
consideration and "Main" and "WebHome" are hardcoded all over the code.
My advice is to not use those. If your goal is to change the homepage
URL, then you should add a redirect inside the existing Main.WebHome to
your desired page.
--
Sergiu Dumitriu
http://purl.org/net/sergiu/
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: xwiki.cfg seems not to be applied?

Florian Rustedt
>The effect of xwiki.showviewaction should be visible almost right away.
>Note that URLs with the /view/ part in them will still work, and there won't be any redirection from an URL with /view/ >to an URL without it.
>But clicking on wiki links should point to non-/view/ URLs.

I expected after the login to have no "/view" any more in the url but it still was there?

>The other two are pretty much useless... Since getting access to the configured values is hard, most of the code >doesn't take them into consideration and "Main" and "WebHome" are hardcoded all over the code.
>My advice is to not use those. If your goal is to change the homepage URL, then you should add a redirect inside the >existing Main.WebHome to your desired page.

I tried that one but didn't receive the expected results. I opened the page Main.webHome in the WYSIWYG-Editor and went to the coding perspecvive.
There I entered "$response.sendRedirect($xwiki.getURL('Space.Page'))", but it showed me the source directly :)

So:
WHERE do I add this code snippet on the Main.webHome page?

Best regards
Florian
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
Reply | Threaded
Open this post in threaded view
|

Re: xwiki.cfg seems not to be applied?

rrodriguezIDIS
Hi!

>> ________________________________________
>> From: [hidden email] [[hidden email]] On Behalf Of Florian Rustedt [[hidden email]]
>> Sent: 31 May 2012 17:19
>> To: XWiki Users
>> Subject: Re: [xwiki-users] xwiki.cfg seems not to be applied?
>>
>The effect of xwiki.showviewaction should be visible almost right away.
>Note that URLs with the /view/ part in them will still work, and there won't be any redirection from an URL with /view/ >to an URL without it.
>But clicking on wiki links should point to non-/view/ URLs.
>>
>> I expected after the login to have no "/view" any more in the url but it still was there?
>>
>The other two are pretty much useless... Since getting access to the configured values is hard, most of the code >doesn't take them into consideration and "Main" and "WebHome" are hardcoded all over the code.
>My advice is to not use those. If your goal is to change the homepage URL, then you should add a redirect inside the >existing Main.WebHome to your desired page.
>>
>> I tried that one but didn't receive the expected results. I opened the page Main.webHome in the WYSIWYG-Editor and went to the coding perspecvive.
>> There I entered "$response.sendRedirect($xwiki.getURL('Space.Page'))", but it showed me the source directly :)
>>
>> So:
>> WHERE do I add this code snippet on the Main.webHome page?

Right in the body of the page. Please, check what syntax you are using. For XWiki 2.x syntaxes you must enclose the redirect line/method within Velocity script beginning and end tags. I received time ago the same advice and it is working fine here. Here the snippet in one of our homepages:

{{velocity}}
$response.sendRedirect($xwiki.getURL('Main.HomeMV2'))
{{/velocity}

HTH,

Ricardo

>> Best regards
>> Florian
>> _______________________________________________
>> users mailing list
>> [hidden email]
>> http://lists.xwiki.org/mailman/listinfo/users

Nota: A informaci?n contida nesta mensaxe e os seus posibles documentos adxuntos ? privada e confidencial e est? dirixida ?nicamente ? seu destinatario/a. Se vostede non ? o/a destinatario/a orixinal desta mensaxe, por favor elim?nea. A distribuci?n ou copia desta mensaxe non est? autorizada.

Nota: La informaci?n contenida en este mensaje y sus posibles documentos adjuntos es privada y confidencial y est? dirigida ?nicamente a su destinatario/a. Si usted no es el/la destinatario/a original de este mensaje, por favor elim?nelo. La distribuci?n o copia de este mensaje no est? autorizada.

See more languages: http://www.sergas.es/aviso_confidencialidad.htm
_______________________________________________
users mailing list
[hidden email]
http://lists.xwiki.org/mailman/listinfo/users
--
Ricardo Rodríguez
Research Management and Promotion Technician
Technical Secretariat
Health Research Institute of Santiago de Compostela (IDIS)
http://www.idisantiago.es