xwiki going wacky

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

xwiki going wacky

tsuter
I am having some major issues with xwiki.  I am adding content to it and
press the save button and it sometimes will save and sometimes won't.
Also, intermittently, I am forced to log in again to make changes.  This
isn't after any extended time.  Also, using the admin user, it will
sometimes let me log in with the changed password, but also, I have to
use the default password sometimes.  Anyone else have this issue?

Not using tomcat or a local MySQL db.  Using MySQL on a remote server,
and also xwiki is running on SunOne iPlanet WebServer.

Tim



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki going wacky

Ludovic Dubost

Hi Tim,

Which version are you running ?

Ludovic

Tim Suter wrote:

> I am having some major issues with xwiki.  I am adding content to it and
> press the save button and it sometimes will save and sometimes won't.
> Also, intermittently, I am forced to log in again to make changes.  This
> isn't after any extended time.  Also, using the admin user, it will
> sometimes let me log in with the changed password, but also, I have to
> use the default password sometimes.  Anyone else have this issue?
>
> Not using tomcat or a local MySQL db.  Using MySQL on a remote server,
> and also xwiki is running on SunOne iPlanet WebServer.
>
> Tim
>
>  
> ------------------------------------------------------------------------
>
>
> --
> You receive this message as a subscriber of the [hidden email] mailing list.
> To unsubscribe: mailto:[hidden email]
> For general help: mailto:[hidden email]?subject=help
> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>  

--
Ludovic Dubost
XPertNet: http://www.xpertnet.fr/
Blog: http://www.ludovic.org/blog/
XWiki: http://www.xwiki.com
Skype: ldubost AIM: nvludo Yahoo: ludovic




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki going wacky

tsuter
0.9.840

Ludovic Dubost wrote:

Hi Tim,

Which version are you running ?

Ludovic

Tim Suter wrote:
I am having some major issues with xwiki.  I am adding content to it and
press the save button and it sometimes will save and sometimes won't. Also, intermittently, I am forced to log in again to make changes.  This
isn't after any extended time.  Also, using the admin user, it will
sometimes let me log in with the changed password, but also, I have to
use the default password sometimes.  Anyone else have this issue?

Not using tomcat or a local MySQL db.  Using MySQL on a remote server,
and also xwiki is running on SunOne iPlanet WebServer.

Tim

  ------------------------------------------------------------------------


--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: [hidden email]
For general help: [hidden email]
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
 



-- You receive this message as a subscriber of the [hidden email] mailing list. To unsubscribe: [hidden email] For general help: [hidden email] ObjectWeb mailing lists service home page: http://www.objectweb.org/wws



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki going wacky

Ludovic Dubost

Your problems are quite weird and I don't really see what could be
having the exact effects you are seeing..
We would need some more "atomic" issue with some stack trace from the
tomcat log files to be able to help out.

Ludovic

Tim Suter wrote:

> 0.9.840
>
> Ludovic Dubost wrote:
>>
>> Hi Tim,
>>
>> Which version are you running ?
>>
>> Ludovic
>>
>> Tim Suter wrote:
>>> I am having some major issues with xwiki.  I am adding content to it
>>> and
>>> press the save button and it sometimes will save and sometimes
>>> won't. Also, intermittently, I am forced to log in again to make
>>> changes.  This
>>> isn't after any extended time.  Also, using the admin user, it will
>>> sometimes let me log in with the changed password, but also, I have to
>>> use the default password sometimes.  Anyone else have this issue?
>>>
>>> Not using tomcat or a local MySQL db.  Using MySQL on a remote server,
>>> and also xwiki is running on SunOne iPlanet WebServer.
>>>
>>> Tim
>>>
>>>  
>>> ------------------------------------------------------------------------
>>>
>>>
>>>
>>> --
>>> You receive this message as a subscriber of the
>>> [hidden email] mailing list.
>>> To unsubscribe: mailto:[hidden email]
>>> For general help: mailto:[hidden email]?subject=help
>>> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>>>  
>>
>>
>> ------------------------------------------------------------------------
>>
>>
>> --
>> You receive this message as a subscriber of the [hidden email] mailing list.
>> To unsubscribe: mailto:[hidden email]
>> For general help: mailto:[hidden email]?subject=help
>> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>>  
>
> ------------------------------------------------------------------------
>
>
> --
> You receive this message as a subscriber of the [hidden email] mailing list.
> To unsubscribe: mailto:[hidden email]
> For general help: mailto:[hidden email]?subject=help
> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>  

--
Ludovic Dubost
XPertNet: http://www.xpertnet.fr/
Blog: http://www.ludovic.org/blog/
XWiki: http://www.xwiki.com
Skype: ldubost AIM: nvludo Yahoo: ludovic




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki going wacky

tsuter
In reply to this post by tsuter
Yeah, I keep adding content and losing it.  I don't know what is going on with this.

Tim

Tim Suter wrote:
0.9.840

Ludovic Dubost wrote:

Hi Tim,

Which version are you running ?

Ludovic

Tim Suter wrote:
I am having some major issues with xwiki.  I am adding content to it and
press the save button and it sometimes will save and sometimes won't. Also, intermittently, I am forced to log in again to make changes.  This
isn't after any extended time.  Also, using the admin user, it will
sometimes let me log in with the changed password, but also, I have to
use the default password sometimes.  Anyone else have this issue?

Not using tomcat or a local MySQL db.  Using MySQL on a remote server,
and also xwiki is running on SunOne iPlanet WebServer.

Tim

  ------------------------------------------------------------------------


--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: [hidden email]
For general help: [hidden email]
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
 



-- You receive this message as a subscriber of the [hidden email] mailing list. To unsubscribe: [hidden email] For general help: [hidden email] ObjectWeb mailing lists service home page: http://www.objectweb.org/wws


-- You receive this message as a subscriber of the [hidden email] mailing list. To unsubscribe: [hidden email] For general help: [hidden email] ObjectWeb mailing lists service home page: http://www.objectweb.org/wws



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki going wacky

tsuter
In reply to this post by Ludovic Dubost
We aren't using tomcat.  We are using the iPlanet Web Server.

Tim

Ludovic Dubost wrote:

>
> Your problems are quite weird and I don't really see what could be
> having the exact effects you are seeing..
> We would need some more "atomic" issue with some stack trace from the
> tomcat log files to be able to help out.
>
> Ludovic
>
> Tim Suter wrote:
>
>> 0.9.840
>>
>> Ludovic Dubost wrote:
>>
>>>
>>> Hi Tim,
>>>
>>> Which version are you running ?
>>>
>>> Ludovic
>>>
>>> Tim Suter wrote:
>>>
>>>> I am having some major issues with xwiki.  I am adding content to
>>>> it and
>>>> press the save button and it sometimes will save and sometimes
>>>> won't. Also, intermittently, I am forced to log in again to make
>>>> changes.  This
>>>> isn't after any extended time.  Also, using the admin user, it will
>>>> sometimes let me log in with the changed password, but also, I have to
>>>> use the default password sometimes.  Anyone else have this issue?
>>>>
>>>> Not using tomcat or a local MySQL db.  Using MySQL on a remote server,
>>>> and also xwiki is running on SunOne iPlanet WebServer.
>>>>
>>>> Tim
>>>>
>>>>  
>>>> ------------------------------------------------------------------------
>>>>
>>>>
>>>>
>>>> --
>>>> You receive this message as a subscriber of the
>>>> [hidden email] mailing list.
>>>> To unsubscribe: mailto:[hidden email]
>>>> For general help: mailto:[hidden email]?subject=help
>>>> ObjectWeb mailing lists service home page:
>>>> http://www.objectweb.org/wws
>>>>  
>>>
>>>
>>>
>>> ------------------------------------------------------------------------
>>>
>>>
>>>
>>> --
>>> You receive this message as a subscriber of the
>>> [hidden email] mailing list.
>>> To unsubscribe: mailto:[hidden email]
>>> For general help: mailto:[hidden email]?subject=help
>>> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>>>  
>>
>>
>> ------------------------------------------------------------------------
>>
>>
>> --
>> You receive this message as a subscriber of the
>> [hidden email] mailing list.
>> To unsubscribe: mailto:[hidden email]
>> For general help: mailto:[hidden email]?subject=help
>> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>>  
>
>
>
>------------------------------------------------------------------------
>
>
>--
>You receive this message as a subscriber of the [hidden email] mailing list.
>To unsubscribe: mailto:[hidden email]
>For general help: mailto:[hidden email]?subject=help
>ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>  
>



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki going wacky SOLVED

tsuter
OK.  The reason why my changes "seem" to disappear is because I have edited them on a cluster and the servers need to be synced in order to realize the changes across all four servers.  DUH!  I kept wondering why the changes were disappearing and after looking at the access logs, that's what it was. 

Tim

Tim Suter wrote:
We aren't using tomcat.  We are using the iPlanet Web Server. 

Tim

Ludovic Dubost wrote:

  
Your problems are quite weird and I don't really see what could be
having the exact effects you are seeing..
We would need some more "atomic" issue with some stack trace from the
tomcat log files to be able to help out.

Ludovic

Tim Suter wrote:

    
0.9.840

Ludovic Dubost wrote:

      
Hi Tim,

Which version are you running ?

Ludovic

Tim Suter wrote:

        
I am having some major issues with xwiki.  I am adding content to
it and
press the save button and it sometimes will save and sometimes
won't. Also, intermittently, I am forced to log in again to make
changes.  This
isn't after any extended time.  Also, using the admin user, it will
sometimes let me log in with the changed password, but also, I have to
use the default password sometimes.  Anyone else have this issue?

Not using tomcat or a local MySQL db.  Using MySQL on a remote server,
and also xwiki is running on SunOne iPlanet WebServer.

Tim

 
------------------------------------------------------------------------



-- 
You receive this message as a subscriber of the
[hidden email] mailing list.
To unsubscribe: [hidden email]
For general help: [hidden email]
ObjectWeb mailing lists service home page:
http://www.objectweb.org/wws
  
          

------------------------------------------------------------------------



-- 
You receive this message as a subscriber of the
[hidden email] mailing list.
To unsubscribe: [hidden email]
For general help: [hidden email]
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
  
        
------------------------------------------------------------------------


-- 
You receive this message as a subscriber of the
[hidden email] mailing list.
To unsubscribe: [hidden email]
For general help: [hidden email]
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
  
      

------------------------------------------------------------------------


--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: [hidden email]
For general help: [hidden email]
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
 

    


  

-- You receive this message as a subscriber of the [hidden email] mailing list. To unsubscribe: [hidden email] For general help: [hidden email] ObjectWeb mailing lists service home page: http://www.objectweb.org/wws



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki going wacky SOLVED

Ludovic Dubost

Yes ! XWiki is not yet cluster ready.. there is work to configure the
caches to broadcast changes over the cluster.
There are also some maps and structure that needs to be but in a
CacheService so that they can be clustered

Ludovic

Tim Suter wrote:

> OK.  The reason why my changes "seem" to disappear is because I have
> edited them on a cluster and the servers need to be synced in order to
> realize the changes across all four servers.  DUH!  I kept wondering
> why the changes were disappearing and after looking at the access
> logs, that's what it was.
>
> Tim
>
> Tim Suter wrote:
>> We aren't using tomcat.  We are using the iPlanet Web Server.
>>
>> Tim
>>
>> Ludovic Dubost wrote:
>>
>>  
>>> Your problems are quite weird and I don't really see what could be
>>> having the exact effects you are seeing..
>>> We would need some more "atomic" issue with some stack trace from the
>>> tomcat log files to be able to help out.
>>>
>>> Ludovic
>>>
>>> Tim Suter wrote:
>>>
>>>    
>>>> 0.9.840
>>>>
>>>> Ludovic Dubost wrote:
>>>>
>>>>      
>>>>> Hi Tim,
>>>>>
>>>>> Which version are you running ?
>>>>>
>>>>> Ludovic
>>>>>
>>>>> Tim Suter wrote:
>>>>>
>>>>>        
>>>>>> I am having some major issues with xwiki.  I am adding content to
>>>>>> it and
>>>>>> press the save button and it sometimes will save and sometimes
>>>>>> won't. Also, intermittently, I am forced to log in again to make
>>>>>> changes.  This
>>>>>> isn't after any extended time.  Also, using the admin user, it will
>>>>>> sometimes let me log in with the changed password, but also, I have to
>>>>>> use the default password sometimes.  Anyone else have this issue?
>>>>>>
>>>>>> Not using tomcat or a local MySQL db.  Using MySQL on a remote server,
>>>>>> and also xwiki is running on SunOne iPlanet WebServer.
>>>>>>
>>>>>> Tim
>>>>>>
>>>>>>  
>>>>>> ------------------------------------------------------------------------
>>>>>>
>>>>>>
>>>>>>
>>>>>> --
>>>>>> You receive this message as a subscriber of the
>>>>>> [hidden email] mailing list.
>>>>>> To unsubscribe: mailto:[hidden email]
>>>>>> For general help: mailto:[hidden email]?subject=help
>>>>>> ObjectWeb mailing lists service home page:
>>>>>> http://www.objectweb.org/wws
>>>>>>  
>>>>>>          
>>>>> ------------------------------------------------------------------------
>>>>>
>>>>>
>>>>>
>>>>> --
>>>>> You receive this message as a subscriber of the
>>>>> [hidden email] mailing list.
>>>>> To unsubscribe: mailto:[hidden email]
>>>>> For general help: mailto:[hidden email]?subject=help
>>>>> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>>>>>  
>>>>>        
>>>> ------------------------------------------------------------------------
>>>>
>>>>
>>>> --
>>>> You receive this message as a subscriber of the
>>>> [hidden email] mailing list.
>>>> To unsubscribe: mailto:[hidden email]
>>>> For general help: mailto:[hidden email]?subject=help
>>>> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>>>>  
>>>>      
>>> ------------------------------------------------------------------------
>>>
>>>
>>> --
>>> You receive this message as a subscriber of the [hidden email] mailing list.
>>> To unsubscribe: mailto:[hidden email]
>>> For general help: mailto:[hidden email]?subject=help
>>> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>>>  
>>>
>>>    
>>
>>
>>  
>> ------------------------------------------------------------------------
>>
>>
>> --
>> You receive this message as a subscriber of the [hidden email] mailing list.
>> To unsubscribe: mailto:[hidden email]
>> For general help: mailto:[hidden email]?subject=help
>> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>>  
>
> ------------------------------------------------------------------------
>
>
> --
> You receive this message as a subscriber of the [hidden email] mailing list.
> To unsubscribe: mailto:[hidden email]
> For general help: mailto:[hidden email]?subject=help
> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>  

--
Ludovic Dubost
XPertNet: http://www.xpertnet.fr/
Blog: http://www.ludovic.org/blog/
XWiki: http://www.xwiki.com
Skype: ldubost AIM: nvludo Yahoo: ludovic




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki going wacky SOLVED

Matthew Conway

On Sep 7, 2005, at 5:02 PM, Ludovic Dubost wrote:


Yes ! XWiki is not yet cluster ready.. there is work to configure the caches to broadcast changes over the cluster.
There are also some maps and structure that needs to be but in a CacheService so that they can be clustered

How about just using a clustered hibernate cache like JCS or swarmcache?

Matt




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki going wacky SOLVED

tsuter
In reply to this post by Ludovic Dubost
I think I may be able to work around this issue by setting the cache to 0 for this.  This might allow the changes to come through.

Tim

Ludovic Dubost wrote:

Yes ! XWiki is not yet cluster ready.. there is work to configure the caches to broadcast changes over the cluster.
There are also some maps and structure that needs to be but in a CacheService so that they can be clustered

Ludovic

Tim Suter wrote:
OK.  The reason why my changes "seem" to disappear is because I have edited them on a cluster and the servers need to be synced in order to realize the changes across all four servers.  DUH!  I kept wondering why the changes were disappearing and after looking at the access logs, that's what it was.
Tim

Tim Suter wrote:
We aren't using tomcat.  We are using the iPlanet Web Server.
Tim

Ludovic Dubost wrote:

 
Your problems are quite weird and I don't really see what could be
having the exact effects you are seeing..
We would need some more "atomic" issue with some stack trace from the
tomcat log files to be able to help out.

Ludovic

Tim Suter wrote:

   
0.9.840

Ludovic Dubost wrote:

     
Hi Tim,

Which version are you running ?

Ludovic

Tim Suter wrote:

       
I am having some major issues with xwiki.  I am adding content to
it and
press the save button and it sometimes will save and sometimes
won't. Also, intermittently, I am forced to log in again to make
changes.  This
isn't after any extended time.  Also, using the admin user, it will
sometimes let me log in with the changed password, but also, I have to
use the default password sometimes.  Anyone else have this issue?

Not using tomcat or a local MySQL db.  Using MySQL on a remote server,
and also xwiki is running on SunOne iPlanet WebServer.

Tim

 
------------------------------------------------------------------------



-- 
You receive this message as a subscriber of the
[hidden email] mailing list.
To unsubscribe: [hidden email]
For general help: [hidden email]
ObjectWeb mailing lists service home page:
http://www.objectweb.org/wws
           
------------------------------------------------------------------------



-- 
You receive this message as a subscriber of the
[hidden email] mailing list.
To unsubscribe: [hidden email]
For general help: [hidden email]
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
         
------------------------------------------------------------------------


-- 
You receive this message as a subscriber of the
[hidden email] mailing list.
To unsubscribe: [hidden email]
For general help: [hidden email]
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
       
------------------------------------------------------------------------


--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: [hidden email]
For general help: [hidden email]
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
 

   


  ------------------------------------------------------------------------


--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: [hidden email]
For general help: [hidden email]
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
 

------------------------------------------------------------------------


--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: [hidden email]
For general help: [hidden email]
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
 



-- You receive this message as a subscriber of the [hidden email] mailing list. To unsubscribe: [hidden email] For general help: [hidden email] ObjectWeb mailing lists service home page: http://www.objectweb.org/wws



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws