xwiki on websphere errors

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

xwiki on websphere errors

CeDeROM
hi!

i have problems with running xwiki on ibm websphere v6.0 application
server and mysql/postgresql database. im using xwiki 0.9.840.

i get left side menu, top menu, etc, but there is no main contents,
instead i get error messages:

-on news i get:
Error number 4001 in 4: Error while parsing velocity page Main.
WebHome Wrapped Exception: Invocation of method 'searchDocuments' in
class com.xpn.xwiki.api.XWiki threw exception class com.xpn.xwiki.
XWikiException : Error number 3223 in 3: Exception while searching
documents with sql , BaseObject as obj where obj.name=doc.fullName
and obj.className='XWiki.ArticleClass' and obj.name<>'XWiki.
ArticleClassTemplate' order by doc.creationDate desc Wrapped
Exception: could not execute query

-knowgelde link works fine.

-on photogallery link i get:
Error number 4001 in 4: Error while parsing velocity page Photos.
WebHome Wrapped Exception: Invocation of method 'getDocument' in
class com.xpn.xwiki.api.XWiki threw exception class com.xpn.xwiki.
XWikiException : Error number 3202 in 3: Exception while reading
document Photos.Vietnam2001 Wrapped Exception: exception setting
property value with CGLIB (set hibernate.cglib.
use_reflection_optimizer=false for more info) setter of com.xpn.
xwiki.doc.XWikiDocument.setArchive

-on documentation i get runtime error:
Error number 3202 in 3: Exception while reading document Doc.WebHome
Wrapped Exception: exception setting property value with CGLIB (set
hibernate.cglib.use_reflection_optimizer=false for more info) setter
of com.xpn.xwiki.doc.XWikiDocument.setArchive
com.xpn.xwiki.XWikiException: Error number 3202 in 3: Exception
while reading document Doc.WebHome
...

-event calendar and presentation links works fine.

when im using standalone bibernate jar i get "Error 500: org/dom4j/
io/SAXReader", so i dont use it :)

any sugestions appreciated :)
tomek




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki on websphere errors

Ludovic Dubost

Hi,

There is not enough information about the exception to actually help you
on this.

Ludovic

CeDeROM wrote:

> hi!
>
> i have problems with running xwiki on ibm websphere v6.0 application
> server and mysql/postgresql database. im using xwiki 0.9.840.
>
> i get left side menu, top menu, etc, but there is no main contents,
> instead i get error messages:
>
> -on news i get:
> Error number 4001 in 4: Error while parsing velocity page Main.
> WebHome Wrapped Exception: Invocation of method 'searchDocuments' in
> class com.xpn.xwiki.api.XWiki threw exception class com.xpn.xwiki.
> XWikiException : Error number 3223 in 3: Exception while searching
> documents with sql , BaseObject as obj where obj.name=doc.fullName
> and obj.className='XWiki.ArticleClass' and obj.name<>'XWiki.
> ArticleClassTemplate' order by doc.creationDate desc Wrapped
> Exception: could not execute query
>
> -knowgelde link works fine.
>
> -on photogallery link i get:
> Error number 4001 in 4: Error while parsing velocity page Photos.
> WebHome Wrapped Exception: Invocation of method 'getDocument' in
> class com.xpn.xwiki.api.XWiki threw exception class com.xpn.xwiki.
> XWikiException : Error number 3202 in 3: Exception while reading
> document Photos.Vietnam2001 Wrapped Exception: exception setting
> property value with CGLIB (set hibernate.cglib.
> use_reflection_optimizer=false for more info) setter of com.xpn.
> xwiki.doc.XWikiDocument.setArchive
>
> -on documentation i get runtime error:
> Error number 3202 in 3: Exception while reading document Doc.WebHome
> Wrapped Exception: exception setting property value with CGLIB (set
> hibernate.cglib.use_reflection_optimizer=false for more info) setter
> of com.xpn.xwiki.doc.XWikiDocument.setArchive
> com.xpn.xwiki.XWikiException: Error number 3202 in 3: Exception
> while reading document Doc.WebHome
> ...
>
> -event calendar and presentation links works fine.
>
> when im using standalone bibernate jar i get "Error 500: org/dom4j/
> io/SAXReader", so i dont use it :)
>
> any sugestions appreciated :)
> tomek
>
>
>  
> ------------------------------------------------------------------------
>
>
> --
> You receive this message as a subscriber of the [hidden email] mailing list.
> To unsubscribe: mailto:[hidden email]
> For general help: mailto:[hidden email]?subject=help
> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>  

--
Ludovic Dubost
XPertNet: http://www.xpertnet.fr/
Blog: http://www.ludovic.org/blog/
XWiki: http://www.xwiki.com
Skype: ldubost AIM: nvludo Yahoo: ludovic




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki on websphere errors

CeDeROM
In reply to this post by CeDeROM
> There is not enough information about the exception to actually
help you
> on this.

I attach piece of server log. If needed I can attach whole log from
server start. I'm using mysql connector 3.1.6 and postgresql
connector version 8.0-312.jdbc3.
With pgsql I dont even get left side menu.

Tomek

--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws

=?iso-8859-2?Q?trace.log.gz?= (5K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: xwiki on websphere errors

Ludovic Dubost

Hi,

Please let's start with mysql first .. It does not make sense to debug
both things at a time.
The "cannot execute query" is not enough.. It should show a wrapped
exception but for some reason it doesn't.
Can you try with the What's New or WebSearch page ?
Can you also turn on debugging in log4j.properties so that you see if
hibernate generates a query..

Ludovic

CeDeROM wrote:

>> There is not enough information about the exception to actually
>>    
> help you
>  
>> on this.
>>    
>
> I attach piece of server log. If needed I can attach whole log from
> server start. I'm using mysql connector 3.1.6 and postgresql
> connector version 8.0-312.jdbc3.
> With pgsql I dont even get left side menu.
>
> Tomek
> ------------------------------------------------------------------------
>
>
> --
> You receive this message as a subscriber of the [hidden email] mailing list.
> To unsubscribe: mailto:[hidden email]
> For general help: mailto:[hidden email]?subject=help
> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>  

--
Ludovic Dubost
XPertNet: http://www.xpertnet.fr/
Blog: http://www.ludovic.org/blog/
XWiki: http://www.xwiki.com
Skype: ldubost AIM: nvludo Yahoo: ludovic




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki on websphere errors

CeDeROM
In reply to this post by CeDeROM
Hi Ludovic!

> Please let's start with mysql first .. It does not make sense to
debug both things at a time.

sure :) Now I have installed two instances of xwiki - one for mysql,
second for pgsql. both look and act identically.


> The "cannot execute query" is not enough.. It should show a
wrapped exception but for some reason it doesn't.
> Can you try with the What's New or WebSearch page ?

Sure! I have attached both exceptions along with full server log...
(btw. hale to bzip2 that packed all this from ~3MB to only 46kB! I
hope nobody will kill me for this attachment)

> Can you also turn on debugging in log4j.properties so that you see
if hibernate generates a query..

### Hibernate logging options ###
log4j.logger.org.hibernate.SQL=debug
log4j.logger.org.hibernate=debug
log4j.logger.org.hibernate.type=debug
log4j.logger.org.hibernate.ps.PreparedStatementCache=warn

is it ok?

Thank You!
Tomek

=?iso-8859-2?Q?logs.tar.bz2?= (60K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: xwiki on websphere errors

Ludovic Dubost

Hi,

This looks like a UTF-8 vs ISO-8859-1 problem.. The default database is
in ISO-8859-1 and your websphere/mysql install is probably not
configured for this.. There is also the fix from Stephane for JRCS and
UTF-8 which could help
http://www.xwiki.org/xwiki/bin/view/Dev/CharactersSets

If it still does not work, you might need to reload the database using
the Import/Export tool.

Ludovic

CeDeROM wrote:

> Hi Ludovic!
>
>  
>> Please let's start with mysql first .. It does not make sense to
>>    
> debug both things at a time.
>
> sure :) Now I have installed two instances of xwiki - one for mysql,
> second for pgsql. both look and act identically.
>
>
>  
>> The "cannot execute query" is not enough.. It should show a
>>    
> wrapped exception but for some reason it doesn't.
>  
>> Can you try with the What's New or WebSearch page ?
>>    
>
> Sure! I have attached both exceptions along with full server log...
> (btw. hale to bzip2 that packed all this from ~3MB to only 46kB! I
> hope nobody will kill me for this attachment)
>
>  
>> Can you also turn on debugging in log4j.properties so that you see
>>    
> if hibernate generates a query..
>
> ### Hibernate logging options ###
> log4j.logger.org.hibernate.SQL=debug
> log4j.logger.org.hibernate=debug
> log4j.logger.org.hibernate.type=debug
> log4j.logger.org.hibernate.ps.PreparedStatementCache=warn
>
> is it ok?
>
> Thank You!
> Tomek
> ------------------------------------------------------------------------
>
>
> --
> You receive this message as a subscriber of the [hidden email] mailing list.
> To unsubscribe: mailto:[hidden email]
> For general help: mailto:[hidden email]?subject=help
> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>  

--
Ludovic Dubost
XPertNet: http://www.xpertnet.fr/
Blog: http://www.ludovic.org/blog/
XWiki: http://www.xwiki.com
Skype: ldubost AIM: nvludo Yahoo: ludovic




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki on websphere errors

CeDeROM
Hi!

> This looks like a UTF-8 vs ISO-8859-1 problem.. The default
database is in ISO-8859-1 and your websphere/mysql install is
probably not configured for this.. There is also the fix from
Stephane for JRCS and  UTF-8 which could help
> http://www.xwiki.org/xwiki/bin/view/Dev/CharactersSets

1.My instalation of mysql doesn't support unicode/utf-8 coding so I
will use PostgreSQL from now on (postgres rox).
2. Yes, the database is in iso8859-1, while websphere seems to use
utf-8. I have asked question on ibm usenet how to change default
encoding for application or globally, to use iso8859-1 (if its
possible).
3. Stephan's fix doesnt work for me, because attached jat is too old
(I get "Error 500: LinkageError while defining class"). Could You
pplease generate newer version Ludovic?

Anyway I dont understand how reading iso8859-1 as utf-8 could work.
..


> If it still does not work, you might need to reload the database
using the Import/Export tool.

Is there way to change coding of database data?

Tomek

ps/2: There are photos of xwiki:
http://test.zetonet.pl/pliki/scr1.gif
http://test.zetonet.pl/pliki/scr2.gif



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki on websphere errors

Ludovic Dubost

I'm not saying to switch to UTF-8. If you can stay in ISO it's better..
but configure your websphere to be ISO also
You can use the same env variable and file.encoding param we use for
tomcat.. See InstallLinuxTomcat on xwiki.org
 
Ludovic

CeDeROM wrote:

> Hi!
>
>
>
>  
>> This looks like a UTF-8 vs ISO-8859-1 problem.. The default
>>    
>
> database is in ISO-8859-1 and your websphere/mysql install is
>
> probably not configured for this.. There is also the fix from
>
> Stephane for JRCS and  UTF-8 which could help
>
>  
>> http://www.xwiki.org/xwiki/bin/view/Dev/CharactersSets
>>    
>
>
>
> 1.My instalation of mysql doesn't support unicode/utf-8 coding so I
>
> will use PostgreSQL from now on (postgres rox).
>
> 2. Yes, the database is in iso8859-1, while websphere seems to use
>
> utf-8. I have asked question on ibm usenet how to change default
>
> encoding for application or globally, to use iso8859-1 (if its
>
> possible).
>
> 3. Stephan's fix doesnt work for me, because attached jat is too old
>
> (I get "Error 500: LinkageError while defining class"). Could You
>
> pplease generate newer version Ludovic?
>
>
>
> Anyway I dont understand how reading iso8859-1 as utf-8 could work.
>
> ..
>
>
>
>
>
>  
>> If it still does not work, you might need to reload the database
>>    
>
> using the Import/Export tool.
>
>
>
> Is there way to change coding of database data?
>
>
>
> Tomek
>
>
>
> ps/2: There are photos of xwiki:
>
> http://test.zetonet.pl/pliki/scr1.gif
>
> http://test.zetonet.pl/pliki/scr2.gif
>
>  
> ------------------------------------------------------------------------
>
>
> --
> You receive this message as a subscriber of the [hidden email] mailing list.
> To unsubscribe: mailto:[hidden email]
> For general help: mailto:[hidden email]?subject=help
> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>  

--
Ludovic Dubost
XPertNet: http://www.xpertnet.fr/
Blog: http://www.ludovic.org/blog/
XWiki: http://www.xwiki.com
Skype: ldubost AIM: nvludo Yahoo: ludovic




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki on websphere errors

CeDeROM
Hi!

> I'm not saying to switch to UTF-8. If you can stay in ISO it's
better.. but configure your websphere to be ISO also

I have modified a bit server startup scripts and started websphere
server with  -Dfile.encoding=ISO8859-1 and XWiki is working both
with MySQL and PostgreSQL! After all, only this was important...
Now, i'm wondering what about utf-8 applications...

Also I have compiled unicode-ready jrcs with ibm's java tools. I
will include jar as attachment on Dev.CharactersSets, as build with
jakarta ant caused linking problems.

Greetings!
Tomek




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki on websphere errors

CeDeROM
also LANG=en_US.ISO8859-1 is essential!



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki on websphere errors

Ludovic Dubost
In reply to this post by CeDeROM

Great !

Thanks for the jrcs lib..
Concerning UTF-8 applications it does work but it is a little more
complex to setup..
The Mandriva Club is working on pure UTF-8: http://club.mandriva.com

Ludovic

CeDeROM wrote:

> Hi!
>
>  
>> I'm not saying to switch to UTF-8. If you can stay in ISO it's
>>    
> better.. but configure your websphere to be ISO also
>
> I have modified a bit server startup scripts and started websphere
> server with  -Dfile.encoding=ISO8859-1 and XWiki is working both
> with MySQL and PostgreSQL! After all, only this was important...
> Now, i'm wondering what about utf-8 applications...
>
> Also I have compiled unicode-ready jrcs with ibm's java tools. I
> will include jar as attachment on Dev.CharactersSets, as build with
> jakarta ant caused linking problems.
>
> Greetings!
> Tomek
>
>
>  
> ------------------------------------------------------------------------
>
>
> --
> You receive this message as a subscriber of the [hidden email] mailing list.
> To unsubscribe: mailto:[hidden email]
> For general help: mailto:[hidden email]?subject=help
> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>  

--
Ludovic Dubost
XPertNet: http://www.xpertnet.fr/
Blog: http://www.ludovic.org/blog/
XWiki: http://www.xwiki.com
Skype: ldubost AIM: nvludo Yahoo: ludovic




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki on websphere errors

Ryszard Lach
In reply to this post by CeDeROM
On Tue, Aug 23, 2005 at 12:27:01PM +0200, CeDeROM wrote:
> I have modified a bit server startup scripts and started websphere
> server with  -Dfile.encoding=ISO8859-1 and XWiki is working both
> with MySQL and PostgreSQL! After all, only this was important...
> Now, i'm wondering what about utf-8 applications...

I'm pretty interested in installing/configuring Xwiki in UTF-8, I've
spent some time on this issue but still need a complete step-by-stem
Unicode-ready installation (e.g. to be able to make smooth upgrades). If
you wan't - you can contact me at priv, maybe we'll be able to speed
things up and prepare a more or less complete howto.

R.

--
"First they ignore you. Then they laugh at you. Then they
fight you. Then you win." - Mohandas Gandhi.



--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
Reply | Threaded
Open this post in threaded view
|

Re: xwiki on websphere errors

Ludovic Dubost

What would be really helpfull is to check if we can have a "config" only
solution..
Currently the xwiki.cfg file can be managed outside of the xwiki.war.
However there are some UTF-8 params in velocity.properties and in web.xml
There is also the JRCS file which we would need to check if we can use
the same one in both cases.
Finally there is the default Database which needs either to be converted
either loaded from scratch with the right encoding settings..

The final objective would be to be able to have an install process which
allows to choose the encoding and handle everything by configuration..
We can also move to UTF-8 by default, but then this would mean we need:

 1/ a migration process for non UTF-8 installs
 2/ a manual to move back to ISO for installs that would not be converted

Ludovic

Ryszard Lach wrote:

> On Tue, Aug 23, 2005 at 12:27:01PM +0200, CeDeROM wrote:
>  
>> I have modified a bit server startup scripts and started websphere
>> server with  -Dfile.encoding=ISO8859-1 and XWiki is working both
>> with MySQL and PostgreSQL! After all, only this was important...
>> Now, i'm wondering what about utf-8 applications...
>>    
>
> I'm pretty interested in installing/configuring Xwiki in UTF-8, I've
> spent some time on this issue but still need a complete step-by-stem
> Unicode-ready installation (e.g. to be able to make smooth upgrades). If
> you wan't - you can contact me at priv, maybe we'll be able to speed
> things up and prepare a more or less complete howto.
>
> R.
>
>  
> ------------------------------------------------------------------------
>
>
> --
> You receive this message as a subscriber of the [hidden email] mailing list.
> To unsubscribe: mailto:[hidden email]
> For general help: mailto:[hidden email]?subject=help
> ObjectWeb mailing lists service home page: http://www.objectweb.org/wws
>  

--
Ludovic Dubost
XPertNet: http://www.xpertnet.fr/
Blog: http://www.ludovic.org/blog/
XWiki: http://www.xwiki.com
Skype: ldubost AIM: nvludo Yahoo: ludovic




--
You receive this message as a subscriber of the [hidden email] mailing list.
To unsubscribe: mailto:[hidden email]
For general help: mailto:[hidden email]?subject=help
ObjectWeb mailing lists service home page: http://www.objectweb.org/wws